aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2011-08-05 12:51:17 +0800
committervanilla <vanilla@FreeBSD.org>2011-08-05 12:51:17 +0800
commitbc906a1f888312242cde987d8719ad0978f311cd (patch)
treebcbebe899a78fa49119ae0459a5f9eb6b2c88470 /www
parent4707ef0abf1363637fe80610ae36bebdaa955675 (diff)
downloadfreebsd-ports-gnome-bc906a1f888312242cde987d8719ad0978f311cd.tar.gz
freebsd-ports-gnome-bc906a1f888312242cde987d8719ad0978f311cd.tar.zst
freebsd-ports-gnome-bc906a1f888312242cde987d8719ad0978f311cd.zip
Upgrade to 0.5.3.
PR: ports/159410 Submitted by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/node-devel/Makefile17
-rw-r--r--www/node-devel/distinfo4
-rw-r--r--www/node-devel/files/patch-SConstruct11
-rw-r--r--www/node-devel/files/patch-deps-uv-config-unix.mk13
-rw-r--r--www/node-devel/files/patch-man-and-pkgconfig-path20
-rw-r--r--www/node-devel/files/patch-platform-freebsd28
-rw-r--r--www/node-devel/files/patch-uv-unix.c10
-rw-r--r--www/node-devel/files/patch-wafadmin-Node.py4
-rw-r--r--www/node-devel/files/patch-wscript20
-rw-r--r--www/node-devel/pkg-plist22
10 files changed, 85 insertions, 64 deletions
diff --git a/www/node-devel/Makefile b/www/node-devel/Makefile
index c77e05d5b5a7..63a914d7c5ff 100644
--- a/www/node-devel/Makefile
+++ b/www/node-devel/Makefile
@@ -1,22 +1,20 @@
# New ports collection makefile for: node
-# Date created: 2010-10-26
+# Date created: 2010-04-12
# Whom: Jin-Sih Lin <linpct@gmail.com>
#
# $FreeBSD$
#
PORTNAME= node
-PORTVERSION= 0.4.1
+PORTVERSION= 0.5.3
CATEGORIES= www
-MASTER_SITES= http://nodejs.org/dist/
+MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
PKGNAMESUFFIX= -devel
DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= linpct@gmail.com
COMMENT= V8 javascript for client and server
-IGNORE= is currently suspended, install www/node that is the current stable version
-
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
MAN1= node.1
@@ -24,13 +22,12 @@ MAN1= node.1
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
USE_PYTHON= yes
-USE_GNOME= pkgconfig
-
-ONLY_FOR_ARCHS= i386
-MAKE_JOBS_SAFE= yes
+USE_GMAKE= yes
-CONFLICTS= node-0.2.[0-9]*
+CONFLICTS= node-0.4.[0-9]*
+ONLY_FOR_ARCHS= i386 amd64
+MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST}
PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
diff --git a/www/node-devel/distinfo b/www/node-devel/distinfo
index eae78880c677..92b8f0f01d07 100644
--- a/www/node-devel/distinfo
+++ b/www/node-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (node-v0.4.1.tar.gz) = fdd61c479a0c9f30102454ee53d2ba0c5fc9f6d06d1073958ae2fd3fc314de23
-SIZE (node-v0.4.1.tar.gz) = 4855576
+SHA256 (node-v0.5.3.tar.gz) = 27e5a488040e59e192b3db6675c5f0b6b00cccdd53f1a7cdf98b6477220fbb1e
+SIZE (node-v0.5.3.tar.gz) = 5539172
diff --git a/www/node-devel/files/patch-SConstruct b/www/node-devel/files/patch-SConstruct
new file mode 100644
index 000000000000..b14bb95ffc1c
--- /dev/null
+++ b/www/node-devel/files/patch-SConstruct
@@ -0,0 +1,11 @@
+--- deps/v8/SConstruct.orig 2011-04-06 19:17:46.000000000 +0800
++++ deps/v8/SConstruct 2011-05-12 20:48:13.000000000 +0800
+@@ -178,7 +178,7 @@ LIBRARY_FLAGS = {
+ }
+ },
+ 'os:freebsd': {
+- 'CPPPATH' : ['/usr/local/include'],
++ 'CPPPATH' : [join(root_dir, 'src'), '/usr/local/include'],
+ 'LIBPATH' : ['/usr/local/lib'],
+ 'CCFLAGS': ['-ansi'],
+ 'LIBS': ['execinfo']
diff --git a/www/node-devel/files/patch-deps-uv-config-unix.mk b/www/node-devel/files/patch-deps-uv-config-unix.mk
new file mode 100644
index 000000000000..c5487a27465a
--- /dev/null
+++ b/www/node-devel/files/patch-deps-uv-config-unix.mk
@@ -0,0 +1,13 @@
+--- deps/uv/config-unix.mk.orig 2011-08-05 10:43:22.000000000 +0800
++++ deps/uv/config-unix.mk 2011-08-05 10:43:28.000000000 +0800
+@@ -18,8 +18,8 @@
+ # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+ # IN THE SOFTWARE.
+
+-CC = $(PREFIX)gcc
+-AR = $(PREFIX)ar
++#CC = $(PREFIX)gcc
++#AR = $(PREFIX)ar
+ E=
+ CSTDFLAG=--std=c89 -pedantic -Wall -Wextra -Wno-unused-parameter
+ CFLAGS=-g
diff --git a/www/node-devel/files/patch-man-and-pkgconfig-path b/www/node-devel/files/patch-man-and-pkgconfig-path
deleted file mode 100644
index b509f022af8a..000000000000
--- a/www/node-devel/files/patch-man-and-pkgconfig-path
+++ /dev/null
@@ -1,20 +0,0 @@
---- wscript.orig 2011-02-05 15:45:34.000000000 +0800
-+++ wscript 2011-02-05 15:46:27.000000000 +0800
-@@ -810,8 +810,6 @@
-
- # Only install the man page if it exists.
- # Do 'make doc install' to build and install it.
-- if os.path.exists('doc/node.1'):
-- bld.install_files('${PREFIX}/share/man/man1/', 'doc/node.1')
-
- bld.install_files('${PREFIX}/bin/', 'tools/node-waf', chmod=0755)
- bld.install_files('${PREFIX}/lib/node/wafadmin', 'tools/wafadmin/*.py')
-@@ -823,7 +821,7 @@
- node_conf.target = 'tools/nodejs.pc'
- node_conf.dict = subflags(node)
-
-- bld.install_files('${PREFIX}/lib/pkgconfig', 'tools/nodejs.pc')
-+ bld.install_files('${PREFIX}/libdata/pkgconfig', 'tools/nodejs.pc')
-
- def shutdown():
- Options.options.debug
diff --git a/www/node-devel/files/patch-platform-freebsd b/www/node-devel/files/patch-platform-freebsd
deleted file mode 100644
index 1b2684957452..000000000000
--- a/www/node-devel/files/patch-platform-freebsd
+++ /dev/null
@@ -1,28 +0,0 @@
---- deps/v8/src/platform-freebsd.cc.orig 2011-02-05 15:15:52.000000000 +0800
-+++ deps/v8/src/platform-freebsd.cc 2011-02-05 15:34:20.000000000 +0800
-@@ -526,6 +526,16 @@
- return result;
- }
-
-+ virtual bool TryLock() {
-+ int result = pthread_mutex_trylock(&mutex_);
-+ // Return false if the lock is busy and locking failed.
-+ if (result == EBUSY) {
-+ return false;
-+ }
-+ ASSERT(result == 0); // Verify no other errors.
-+ return true;
-+ }
-+
- private:
- pthread_mutex_t mutex_; // Pthread mutex for POSIX platforms.
- };
-@@ -604,7 +614,7 @@
- TickSample sample;
-
- // We always sample the VM state.
-- sample.state = VMState::current_state();
-+ // sample.state = VMState::current_state();
-
- // If profiling, we extract the current pc and sp.
- if (active_sampler_->IsProfiling()) {
diff --git a/www/node-devel/files/patch-uv-unix.c b/www/node-devel/files/patch-uv-unix.c
new file mode 100644
index 000000000000..234839b40e17
--- /dev/null
+++ b/www/node-devel/files/patch-uv-unix.c
@@ -0,0 +1,10 @@
+--- deps/uv/src/uv-unix.c.orig 2011-08-02 15:17:41.000000000 +0800
++++ deps/uv/src/uv-unix.c 2011-08-03 16:27:45.000000000 +0800
+@@ -54,6 +54,7 @@
+
+ #if defined(__FreeBSD__)
+ #include <sys/sysctl.h>
++#include <sys/wait.h>
+ #endif
+
+
diff --git a/www/node-devel/files/patch-wafadmin-Node.py b/www/node-devel/files/patch-wafadmin-Node.py
index b593bc720531..1041bd074d67 100644
--- a/www/node-devel/files/patch-wafadmin-Node.py
+++ b/www/node-devel/files/patch-wafadmin-Node.py
@@ -1,5 +1,5 @@
---- tools/wafadmin/Node.py.orig 2010-10-25 05:45:39.000000000 +0800
-+++ tools/wafadmin/Node.py 2010-10-27 18:30:12.000000000 +0800
+--- tools/wafadmin/Node.py.orig 2011-08-03 16:32:55.000000000 +0800
++++ tools/wafadmin/Node.py 2011-08-03 16:56:11.000000000 +0800
@@ -349,6 +349,12 @@
if self == from_node: return '.'
if from_node.parent == self: return '..'
diff --git a/www/node-devel/files/patch-wscript b/www/node-devel/files/patch-wscript
new file mode 100644
index 000000000000..a1e675c86ed8
--- /dev/null
+++ b/www/node-devel/files/patch-wscript
@@ -0,0 +1,20 @@
+--- wscript.orig 2011-08-03 16:28:40.000000000 +0800
++++ wscript 2011-08-03 16:29:22.000000000 +0800
+@@ -623,7 +623,7 @@
+ #
+ cmd = 'cp -r ' + sh_escape(srcdir) + '/* ' + sh_escape(blddir)
+ if not sys.platform.startswith('win32'):
+- cmd += ' && if [[ -z "$NODE_MAKE" ]]; then NODE_MAKE=make; fi; $NODE_MAKE -C ' + sh_escape(blddir)
++ cmd += ' && gmake -C ' + sh_escape(blddir)
+ else:
+ cmd += ' && make -C ' + sh_escape(blddir)
+ return cmd
+@@ -949,8 +949,6 @@
+
+ # Only install the man page if it exists.
+ # Do 'make doc install' to build and install it.
+- if os.path.exists('doc/node.1'):
+- bld.install_files('${PREFIX}/share/man/man1/', 'doc/node.1')
+
+ bld.install_files('${PREFIX}/bin/', 'tools/node-waf', chmod=0755)
+ bld.install_files('${LIBDIR}/node/wafadmin', 'tools/wafadmin/*.py')
diff --git a/www/node-devel/pkg-plist b/www/node-devel/pkg-plist
index 991e3b0261a0..7c7ea610b589 100644
--- a/www/node-devel/pkg-plist
+++ b/www/node-devel/pkg-plist
@@ -1,14 +1,31 @@
bin/node
bin/node-waf
+include/node/ares.h
+include/node/ares_version.h
+include/node/c-ares/ares.h
+include/node/c-ares/ares_version.h
include/node/config.h
include/node/eio.h
include/node/ev.h
+include/node/ev/config_cygwin.h
+include/node/ev/config_darwin.h
+include/node/ev/config_freebsd.h
+include/node/ev/config_linux.h
+include/node/ev/config_sunos.h
+include/node/ev/ev++.h
+include/node/ev/ev_vars.h
+include/node/ev/ev_wrap.h
+include/node/ev/event.h
+include/node/ngx-queue.h
include/node/node.h
include/node/node_buffer.h
include/node/node_config.h
-include/node/node_events.h
include/node/node_object_wrap.h
include/node/node_version.h
+include/node/tree.h
+include/node/uv-unix.h
+include/node/uv-win.h
+include/node/uv.h
include/node/v8-debug.h
include/node/v8-preparser.h
include/node/v8-profiler.h
@@ -64,8 +81,9 @@ lib/node/wafadmin/__init__.py
lib/node/wafadmin/ansiterm.py
lib/node/wafadmin/pproc.py
lib/node/wafadmin/py3kfixes.py
-libdata/pkgconfig/nodejs.pc
@dirrm lib/node/wafadmin/Tools
@dirrm lib/node/wafadmin
@dirrm lib/node
+@dirrm include/node/ev
+@dirrm include/node/c-ares
@dirrm include/node