aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2009-01-03 14:55:58 +0800
committerbeech <beech@FreeBSD.org>2009-01-03 14:55:58 +0800
commitbd03f74aca30518cc2636b0bc8c5699bbd0c2e97 (patch)
treec8d2f2caa398a5adebf5fcc07153a85a4b3fa894 /www
parent3082aa9e61d8d458db2603c5e545a5499738d95f (diff)
downloadfreebsd-ports-gnome-bd03f74aca30518cc2636b0bc8c5699bbd0c2e97.tar.gz
freebsd-ports-gnome-bd03f74aca30518cc2636b0bc8c5699bbd0c2e97.tar.zst
freebsd-ports-gnome-bd03f74aca30518cc2636b0bc8c5699bbd0c2e97.zip
- Fix plist
Diffstat (limited to 'www')
-rw-r--r--www/cherokee/Makefile10
-rw-r--r--www/cherokee/pkg-plist12
2 files changed, 13 insertions, 9 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index d288b59c415d..a3161c92b145 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cherokee
PORTVERSION= 0.11.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.cherokee-project.com/download/0.11/${PORTVERSION}/ \
LOCAL/beech
@@ -25,7 +25,7 @@ USE_RC_SUBR= cherokee.sh
USE_BISON= build
USE_PYTHON= 2.4+
GNU_CONFIGURE= yes
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}Marek Kubica <marek@xivilization.net>
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-wwwroot=${PREFIX}/www/cherokee \
@@ -62,15 +62,19 @@ CONFIGURE_ARGS+=--disable-ipv6
.ifdef WITH_MYSQL
USE_MYSQL= yes
CONFIGURE_ARGS+=--with-mysql=yes
+PLIST_SUB+= MYSQL=""
.else
CONFIGURE_ARGS+=--with-mysql=no
+PLIST_SUB+= MYSQL="@comment "
.endif
.ifdef WITH_LDAP
USE_OPENLDAP= yes
CONFIGURE_ARGS+=--with-ldap=yes
+PLIST_SUB+= LDAP=""
.else
CONFIGURE_ARGS+=--with-ldap=no
+PLIST_SUB+= LDAP="@comment "
.endif
post-patch:
@@ -86,7 +90,7 @@ post-patch:
s:%wwwroot%:${PREFIX}/www/cherokee:g; \
s:%prefix%:${PREFIX}:g; \
s:%localstatedir%:/var:g; \
- s:#.*User.*nobody:User www:g; \
+ s:#.*User.*nobody:User www:g; \1
s:#.*Group.*nogroup:Group www:g; \
s:#.*PollMethod.*poll:PollMethod kqueue:g' \
$$i > $${i%.pre};done
diff --git a/www/cherokee/pkg-plist b/www/cherokee/pkg-plist
index cdd30d7bde21..85e7f8ea22c5 100644
--- a/www/cherokee/pkg-plist
+++ b/www/cherokee/pkg-plist
@@ -64,8 +64,8 @@ lib/cherokee/libplugin_common.la
lib/cherokee/libplugin_common.so
lib/cherokee/libplugin_custom_error.la
lib/cherokee/libplugin_custom_error.so
-lib/cherokee/libplugin_dbslayer.la
-lib/cherokee/libplugin_dbslayer.so
+%%MYSQL%%lib/cherokee/libplugin_dbslayer.la
+%%MYSQL%%lib/cherokee/libplugin_dbslayer.so
lib/cherokee/libplugin_deflate.la
lib/cherokee/libplugin_deflate.so
lib/cherokee/libplugin_directory.la
@@ -96,16 +96,16 @@ lib/cherokee/libplugin_htdigest.la
lib/cherokee/libplugin_htdigest.so
lib/cherokee/libplugin_htpasswd.la
lib/cherokee/libplugin_htpasswd.so
-lib/cherokee/libplugin_ldap.la
-lib/cherokee/libplugin_ldap.so
+%%LDAP%%lib/cherokee/libplugin_ldap.la
+%%LDAP%%lib/cherokee/libplugin_ldap.so
lib/cherokee/libplugin_libssl.la
lib/cherokee/libplugin_libssl.so
lib/cherokee/libplugin_method.la
lib/cherokee/libplugin_method.so
lib/cherokee/libplugin_mirror.la
lib/cherokee/libplugin_mirror.so
-lib/cherokee/libplugin_mysql.la
-lib/cherokee/libplugin_mysql.so
+%%MYSQL%%lib/cherokee/libplugin_mysql.la
+%%MYSQL%%lib/cherokee/libplugin_mysql.so
lib/cherokee/libplugin_ncsa.la
lib/cherokee/libplugin_ncsa.so
lib/cherokee/libplugin_not.la