aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2005-06-12 00:13:12 +0800
committerskv <skv@FreeBSD.org>2005-06-12 00:13:12 +0800
commitbd66c37b2ebc3af08e4801d5ee95d052d7106537 (patch)
tree5d1cee6ab34a9bc371efc1528a966de11e512cf8 /www
parentfa6b19a74d8cf69c7178487be2538d36f7b0d459 (diff)
downloadfreebsd-ports-gnome-bd66c37b2ebc3af08e4801d5ee95d052d7106537.tar.gz
freebsd-ports-gnome-bd66c37b2ebc3af08e4801d5ee95d052d7106537.tar.zst
freebsd-ports-gnome-bd66c37b2ebc3af08e4801d5ee95d052d7106537.zip
* reflect renaming on CPAN File-Spec to PathTools
+ add devel/p5-PathTools, remove devel/p5-File-Spec + update dependencies for all affected ports (make them unconditional), bump PORTREVISION for these ports module was renamed * reflect renaming on CPAN PodParser to Pod-Parser + add textproc/p5-Pod-Parser, remove textproc/p5-PodParser + update dependencies for all affected ports (make them unconditional), bump PORTREVISION for these ports * for all changed ports make dependencies on File::Temp, Digest::MD5, Storable unconditional * remove 'CONFIGURE_ARGS= INSTALLDIRS=site' from Makefile's (this variable is forced by bsd.port.mk now) * update Class-Autouse to 1.17 * update POE-API-Hooks to 1.05 * make portlint happy (clean IGNORE, convert spaces to tabs and so on)
Diffstat (limited to 'www')
-rw-r--r--www/MT/Makefile4
-rw-r--r--www/p5-Apache-DebugInfo/Makefile2
-rw-r--r--www/p5-Apache-Test/Makefile10
-rw-r--r--www/p5-Bundle-Slash/Makefile10
-rw-r--r--www/p5-Bundle-Sledge/Makefile15
-rw-r--r--www/p5-CGI-Cache/Makefile11
-rw-r--r--www/p5-CGI.pm/Makefile17
-rw-r--r--www/p5-HTML-Embperl/Makefile6
-rw-r--r--www/p5-HTML-Mason/Makefile7
-rw-r--r--www/p5-HTML-Template/Makefile21
-rw-r--r--www/p5-HTML-Template/files/patch-Template.pm12
-rw-r--r--www/p5-POE-Component-Server-HTTP/Makefile3
-rw-r--r--www/p5-PodToHTML/Makefile3
-rw-r--r--www/p5-Template-Toolkit/Makefile12
-rw-r--r--www/p5-WWW-Mechanize/Makefile3
-rw-r--r--www/p5-WWW-Search/Makefile16
-rw-r--r--www/p5-libapreq/Makefile6
-rw-r--r--www/rt2/Makefile11
-rw-r--r--www/slash/Makefile10
19 files changed, 57 insertions, 122 deletions
diff --git a/www/MT/Makefile b/www/MT/Makefile
index c81a37d4953b..fa8e642739d4 100644
--- a/www/MT/Makefile
+++ b/www/MT/Makefile
@@ -7,7 +7,7 @@
PORTNAME= MT
PORTVERSION= 2.661
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://www.movabletype.org/downloads/
.if defined(WITH_OLD_DISTFILE)
@@ -77,7 +77,7 @@ RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.endif
.endif
.if ${PERL_LEVEL} < 500601
-RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools
.endif
pre-everything::
diff --git a/www/p5-Apache-DebugInfo/Makefile b/www/p5-Apache-DebugInfo/Makefile
index fbb38d6c3f2e..296163794497 100644
--- a/www/p5-Apache-DebugInfo/Makefile
+++ b/www/p5-Apache-DebugInfo/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= skv@FreeBSD.org
COMMENT= Log various bits of per-request data
.if defined(WITH_MODPERL2)
-IGNORE= "This port does not support mod_perl2"
+IGNORE= This port does not support mod_perl2
.else
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
BUILD_DEPENDS= ${RUN_DEPENDS}
diff --git a/www/p5-Apache-Test/Makefile b/www/p5-Apache-Test/Makefile
index 6fe596a3d9e7..1563fba4b666 100644
--- a/www/p5-Apache-Test/Makefile
+++ b/www/p5-Apache-Test/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Apache-Test
PORTVERSION= 1.24
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache
@@ -16,9 +17,10 @@ MAINTAINER= skv@FreeBSD.org
COMMENT= Test.pm wrapper with helpers for testing Apache
.if defined(WITH_MODPERL2)
-IGNORE= "This port is already included in mod_perl2"
+IGNORE= This port is already included in mod_perl2
.else
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
BUILD_DEPENDS= ${RUN_DEPENDS}
.endif
@@ -32,10 +34,6 @@ MAN3= Apache::Test.3 Apache::TestConfig.3 Apache::TestConfigData.3 \
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif
-
.if ${PERL_LEVEL} < 500800
EXTRA_PATCHES= ${PATCHDIR}/500503-Makefile.PL
.endif
diff --git a/www/p5-Bundle-Slash/Makefile b/www/p5-Bundle-Slash/Makefile
index 67d136cf97bf..ccd4e1403c1f 100644
--- a/www/p5-Bundle-Slash/Makefile
+++ b/www/p5-Bundle-Slash/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Bundle-Slash
PORTVERSION= 2.32
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Bundle
@@ -16,6 +17,7 @@ MAINTAINER= autrijus@autrijus.org
COMMENT= A bundle to install all modules used for Slash
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
@@ -59,10 +61,4 @@ PERL_CONFIGURE= yes
MAN3= Bundle::Slash.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Bundle-Sledge/Makefile b/www/p5-Bundle-Sledge/Makefile
index 8949b4e4e0c7..b7b170895ca1 100644
--- a/www/p5-Bundle-Sledge/Makefile
+++ b/www/p5-Bundle-Sledge/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Bundle-Sledge
PORTVERSION= 0.03
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Bundle
@@ -18,6 +19,8 @@ COMMENT= A bundle to install all modules used for Sledge
BUILD_DEPENDS= ${PM_DEPENDS}
RUN_DEPENDS= ${PM_DEPENDS}
+PM_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
PM_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
PM_DEPENDS+= ${SITE_PERL}/Apache/Reload.pm:${PORTSDIR}/www/p5-Apache-Reload
PM_DEPENDS+= ${SITE_PERL}/Test/Inline.pm:${PORTSDIR}/devel/p5-Test-Inline
@@ -48,14 +51,4 @@ PERL_CONFIGURE= yes
MAN3= Bundle::Sledge.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-PM_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
-.if ${PERL_LEVEL} < 500601
-PM_DEPENDS+= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
-PM_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Cache/Makefile b/www/p5-CGI-Cache/Makefile
index 1b37bcc24959..2699bc8e5532 100644
--- a/www/p5-CGI-Cache/Makefile
+++ b/www/p5-CGI-Cache/Makefile
@@ -7,6 +7,7 @@
PORTNAME= CGI-Cache
PORTVERSION= 1.40
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= CGI
@@ -16,19 +17,13 @@ MAINTAINER= petef@FreeBSD.org
COMMENT= Perl extension to cache output of time-intensive CGI scripts
BUILD_DEPENDS= ${SITE_PERL}/File/Cache.pm:${PORTSDIR}/devel/p5-File-Cache \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
${SITE_PERL}/Cache/SizeAwareFileCache.pm:${PORTSDIR}/devel/p5-Cache-Cache \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
-
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} <= 500600
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec/Functions.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif
-
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= CGI::Cache.3
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-CGI.pm/Makefile b/www/p5-CGI.pm/Makefile
index be42504e0837..7cc84f46ca97 100644
--- a/www/p5-CGI.pm/Makefile
+++ b/www/p5-CGI.pm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= CGI.pm
PORTVERSION= 3.10
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
@@ -16,8 +17,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Simple Common Gateway Interface Class for Perl
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
-CONFIGURE_ARGS= INSTALLDIRS=site
MAN3= CGI.3 CGI::Apache.3 CGI::Carp.3 CGI::Cookie.3 \
CGI::Fast.3 CGI::Pretty.3 CGI::Push.3 CGI::Switch.3 \
@@ -41,15 +44,7 @@ post-install:
@${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-
post-patch:
- @${PERL} -i -pe '$$_ = "" if /require 5\.6/' ${WRKSRC}/Makefile.PL
-
-.endif
+ @${REINPLACE_CMD} -e '/require 5\.6/d; /INSTALLDIRS/d' ${WRKSRC}/Makefile.PL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Embperl/Makefile b/www/p5-HTML-Embperl/Makefile
index 6b1dd059aa37..43156ca94c3c 100644
--- a/www/p5-HTML-Embperl/Makefile
+++ b/www/p5-HTML-Embperl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= HTML-Embperl
PORTVERSION= 1.3.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTML
@@ -19,6 +19,7 @@ COMMENT= A module to allow embedded perl in HTML documents
.if !defined(WITHOUT_APACHE)
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
${SITE_PERL}/Apache/Session.pm:${PORTSDIR}/www/p5-Apache-Session
# ${SITE_PERL}/Apache/SessionX.pm:${PORTSDIR}/www/p5-Apache-SessionX
.endif
@@ -34,7 +35,6 @@ CONFIGURE_ENV= NOAPACHE=true
INSTALL_TARGET= pure_install
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= HTML::Embperl.3 HTML::Embperl::Faq.3 HTML::Embperl::Changes.3 \
HTML::Embperl::FeaturesD.3 HTML::Embperl::TipsAndTricks.3 \
HTML::Embperl::Intro.3 HTML::Embperl::Session.3 HTML::Embperl::Mail.3 \
@@ -47,8 +47,6 @@ MAN1= embpexec.pl.1
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
BROKEN= Incorrect pkg-plist
.endif
diff --git a/www/p5-HTML-Mason/Makefile b/www/p5-HTML-Mason/Makefile
index 3a4d6ed7925d..9f5d0fa1f4fe 100644
--- a/www/p5-HTML-Mason/Makefile
+++ b/www/p5-HTML-Mason/Makefile
@@ -7,7 +7,7 @@
PORTNAME= HTML-Mason
PORTVERSION= 1.28
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTML
@@ -17,6 +17,7 @@ MAINTAINER= dsh@vlink.ru
COMMENT= High-performance, dynamic web site authoring system
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
${SITE_PERL}/Class/Container.pm:${PORTSDIR}/devel/p5-Class-Container \
${SITE_PERL}/Cache/Cache.pm:${PORTSDIR}/devel/p5-Cache-Cache
@@ -61,10 +62,6 @@ OPTIONS= MOD_PERL "with mod_perl dependency" off
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif
-
.if defined(WITH_MOD_PERL)
.if defined(WITH_APACHE2)
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq2
diff --git a/www/p5-HTML-Template/Makefile b/www/p5-HTML-Template/Makefile
index 4d63a202e1c3..34564b7ec28a 100644
--- a/www/p5-HTML-Template/Makefile
+++ b/www/p5-HTML-Template/Makefile
@@ -7,6 +7,7 @@
PORTNAME= HTML-Template
PORTVERSION= 2.7
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTML
@@ -15,22 +16,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl module to use HTML Templates from CGI scripts
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
MAN3= HTML::Template.3
-post-patch:
- ${PERL} -i -pe 's@%%PERL_INC%%@${SITE_PERL}@' ${WRKSRC}/Template.pm
-
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600 && !exists(${SITE_PERL}/File/Spec.pm)
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif
-.if ${PERL_LEVEL} < 500800 && !exists(${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm)
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Template/files/patch-Template.pm b/www/p5-HTML-Template/files/patch-Template.pm
deleted file mode 100644
index 6c4d3879d1f3..000000000000
--- a/www/p5-HTML-Template/files/patch-Template.pm
+++ /dev/null
@@ -1,12 +0,0 @@
---- Template.pm.orig Fri Jun 18 21:42:06 2004
-+++ Template.pm Fri Jun 25 13:33:50 2004
-@@ -890,7 +890,9 @@
- use strict; # and no funny business, either.
-
- use Carp; # generate better errors with more context
-+BEGIN { unshift(@INC, "%%PERL_INC%%"); }
- use File::Spec; # generate paths that work on all platforms
-+shift(@INC);
- use Digest::MD5 qw(md5_hex); # generate cache keys
-
- # define accessor constants used to improve readability of array
diff --git a/www/p5-POE-Component-Server-HTTP/Makefile b/www/p5-POE-Component-Server-HTTP/Makefile
index 8f20ea7a4c4b..9cda220e37a1 100644
--- a/www/p5-POE-Component-Server-HTTP/Makefile
+++ b/www/p5-POE-Component-Server-HTTP/Makefile
@@ -7,6 +7,7 @@
PORTNAME= POE-Component-Server-HTTP
PORTVERSION= 0.07
+PORTREVISION= 1
CATEGORIES= www devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= POE
@@ -18,7 +19,7 @@ COMMENT= POE Component to create HTTP Servers
BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
${SITE_PERL}/HTTP/Date.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/POE/API/Peek.pm:${PORTSDIR}/devel/p5-POE-API-Peek \
- ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
${SITE_PERL}/HTTP/Status.pm:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/www/p5-PodToHTML/Makefile b/www/p5-PodToHTML/Makefile
index 0a826d07301c..e5458afbe251 100644
--- a/www/p5-PodToHTML/Makefile
+++ b/www/p5-PodToHTML/Makefile
@@ -6,6 +6,7 @@
PORTNAME= PodToHTML
PORTVERSION= 0.05
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pod
@@ -15,7 +16,7 @@ MAINTAINER= hrs@FreeBSD.org
COMMENT= Generating HTML from several files containg POD documentation
BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser \
+ ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-Pod-Parser \
${SITE_PERL}/HTML/Element.pm:${PORTSDIR}/www/p5-HTML-Tree \
${SITE_PERL}/HTML/FormatPS.pm:${PORTSDIR}/textproc/p5-HTML-Format
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/www/p5-Template-Toolkit/Makefile b/www/p5-Template-Toolkit/Makefile
index 3b193d6a0de4..ceb9f2a8d986 100644
--- a/www/p5-Template-Toolkit/Makefile
+++ b/www/p5-Template-Toolkit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Template-Toolkit
PORTVERSION= 2.14
+PORTREVISION= 2
CATEGORIES= www textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Template
@@ -15,7 +16,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Extensive Toolkit for template processing
-BUILD_DEPENDS= ${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
+ ${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig
RUN_DEPENDS= ${BUILD_DEPENDS}
OPTIONS=TEXT_AUTOFORMAT "With Text::Autoformat Plugin" off \
@@ -40,13 +43,6 @@ MASTER_SITE_BACKUP+= http://www.template-toolkit.org/download/
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec/Functions.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif
-.endif
-
.if defined(WITH_TEXT_AUTOFORMAT)
BUILD_DEPENDS+=${SITE_PERL}/Text/Autoformat.pm:${PORTSDIR}/textproc/p5-Text-Autoformat
.endif
diff --git a/www/p5-WWW-Mechanize/Makefile b/www/p5-WWW-Mechanize/Makefile
index 75981599a266..d8834f976b01 100644
--- a/www/p5-WWW-Mechanize/Makefile
+++ b/www/p5-WWW-Mechanize/Makefile
@@ -7,6 +7,7 @@
PORTNAME= WWW-Mechanize
PORTVERSION= 1.12
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= WWW
@@ -40,7 +41,7 @@ post-install:
.if ${PERL_LEVEL} < 500800
BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
- ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser
+ ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-Pod-Parser
.if ${PERL_LEVEL} < 500601
IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
.endif
diff --git a/www/p5-WWW-Search/Makefile b/www/p5-WWW-Search/Makefile
index fd3d87689987..cda1a3d019a7 100644
--- a/www/p5-WWW-Search/Makefile
+++ b/www/p5-WWW-Search/Makefile
@@ -7,6 +7,7 @@
PORTNAME= WWW-Search
PORTVERSION= 2.46
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= WWW
@@ -15,7 +16,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A perl5 module for WWW searches
-BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/HTML/TreeBuilder.pm:${PORTSDIR}/www/p5-HTML-Tree \
${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
@@ -42,13 +45,4 @@ MAN3= WWW::Search.3 \
post-patch:
@${RM} ${WRKSRC}/lib/WWW/Search/Test.pm.orig
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-libapreq/Makefile b/www/p5-libapreq/Makefile
index 3cbc0eb39bef..528b1de6c9fa 100644
--- a/www/p5-libapreq/Makefile
+++ b/www/p5-libapreq/Makefile
@@ -8,15 +8,15 @@
PORTNAME= libapreq
PORTVERSION= 1.33
CATEGORIES= www perl5 devel
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Apache
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Generic Apache Request Library
.if defined(WITH_MODPERL2)
-IGNORE= "This port does not support mod_perl2"
+IGNORE= This port does not support mod_perl2
.else
RUN_DEPENDS?= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
BUILD_DEPENDS= ${RUN_DEPENDS} \
diff --git a/www/rt2/Makefile b/www/rt2/Makefile
index e6666738a1f4..51125eca4449 100644
--- a/www/rt2/Makefile
+++ b/www/rt2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rt2
PORTVERSION= 2.0.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.fsck.com/pub/rt/release/
DISTNAME= rt-${PORTVERSION:S/./-/g}
@@ -16,6 +16,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= RT is an industrial-grade ticketing system written in Perl
BUILD_DEPENDS= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/${PERL_ARCH}/Apache/Cookie.pm:${PORTSDIR}/www/p5-libapreq \
${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI \
${SITE_PERL}/Apache/Session.pm:${PORTSDIR}/www/p5-Apache-Session \
@@ -157,11 +159,4 @@ post-install:
BROKEN= "Broken pkg-plist"
.endif
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif
-.endif
-
.include <bsd.port.post.mk>
diff --git a/www/slash/Makefile b/www/slash/Makefile
index f46fe02419e1..80a5bcd47f3f 100644
--- a/www/slash/Makefile
+++ b/www/slash/Makefile
@@ -7,6 +7,7 @@
PORTNAME= slash
PORTVERSION= 2.2.6
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= slashcode
@@ -16,6 +17,7 @@ MAINTAINER= autrijus@autrijus.org
COMMENT= Slash-Like Automatic Storytelling Homepage system
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
${SITE_PERL}/Bundle/Slash.pm:${PORTSDIR}/www/p5-Bundle-Slash
RUN_DEPENDS= ${BUILD_DEPENDS} \
${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
@@ -46,10 +48,4 @@ post-install:
@${FIND} ${PREFIX}/slash -name "*.orig" -delete
@${SED} s!%%LOCALBASE%%!${LOCALBASE}!g ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>