aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2013-07-20 07:39:43 +0800
committerjkim <jkim@FreeBSD.org>2013-07-20 07:39:43 +0800
commitbddba08419588596cbda5657581017257709f4e6 (patch)
tree925db422fd4a052af02ee96201d29e6e9d302fb8 /www
parent69c55efa2ebca24577adf9ee83f51760abe72aa9 (diff)
downloadfreebsd-ports-gnome-bddba08419588596cbda5657581017257709f4e6.tar.gz
freebsd-ports-gnome-bddba08419588596cbda5657581017257709f4e6.tar.zst
freebsd-ports-gnome-bddba08419588596cbda5657581017257709f4e6.zip
Fix build with Clang and make it default again.
Tested by: Mike Jakubik <mike.jakubik@intertainservices.com>, RedPorts
Diffstat (limited to 'www')
-rw-r--r--www/chromium/Makefile2
-rw-r--r--www/chromium/files/patch-base__allocator__allocator_extension.cc26
-rw-r--r--www/chromium/files/patch-base__profiler__alternate_timer.cc11
-rw-r--r--www/chromium/files/patch-base__tracked_objects.cc11
-rw-r--r--www/chromium/files/patch-chrome__browser__metrics__thread_watcher.cc11
-rw-r--r--www/chromium/files/patch-chrome__browser__sync__glue__synced_session_tracker.cc11
-rw-r--r--www/chromium/files/patch-third_party__WebKit__Source__wtf__TypeTraits.h11
-rw-r--r--www/chromium/files/patch-third_party__hunspell__src__hunspell__affentry.hxx20
-rw-r--r--www/chromium/files/patch-third_party__libjingle__source__talk__base__taskrunner.cc11
-rw-r--r--www/chromium/files/patch-third_party__sfntly__cpp__src__sfntly__table__core__cmap_table.cc47
-rw-r--r--www/chromium/files/patch-v8__src__stub-cache.cc11
11 files changed, 171 insertions, 1 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 7eb7a5b0e544..d0eafe567867 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -92,7 +92,7 @@ OPTIONS_DEFINE= CODECS GCONF PULSEAUDIO CLANG DEBUG
CODECS_DESC= Compile and enable patented codecs like H.264
CLANG_DESC= Build Chromium with Clang instead of GCC 4.6+
-OPTIONS_DEFAULT= CODECS GCONF
+OPTIONS_DEFAULT= CODECS GCONF CLANG
.include <bsd.port.options.mk>
diff --git a/www/chromium/files/patch-base__allocator__allocator_extension.cc b/www/chromium/files/patch-base__allocator__allocator_extension.cc
new file mode 100644
index 000000000000..8fd88b515e23
--- /dev/null
+++ b/www/chromium/files/patch-base__allocator__allocator_extension.cc
@@ -0,0 +1,26 @@
+--- base/allocator/allocator_extension.cc 2013-07-03 23:39:54.000000000 -0400
++++ base/allocator/allocator_extension.cc 2013-07-19 00:39:26.000000000 -0400
+@@ -35,20 +35,20 @@
+ void SetGetAllocatorWasteSizeFunction(
+ thunks::GetAllocatorWasteSizeFunction get_allocator_waste_size_function) {
+ DCHECK_EQ(thunks::GetGetAllocatorWasteSizeFunction(),
+- reinterpret_cast<thunks::GetAllocatorWasteSizeFunction>(NULL));
++ static_cast<thunks::GetAllocatorWasteSizeFunction>(0));
+ thunks::SetGetAllocatorWasteSizeFunction(get_allocator_waste_size_function);
+ }
+
+ void SetGetStatsFunction(thunks::GetStatsFunction get_stats_function) {
+ DCHECK_EQ(thunks::GetGetStatsFunction(),
+- reinterpret_cast<thunks::GetStatsFunction>(NULL));
++ static_cast<thunks::GetStatsFunction>(0));
+ thunks::SetGetStatsFunction(get_stats_function);
+ }
+
+ void SetReleaseFreeMemoryFunction(
+ thunks::ReleaseFreeMemoryFunction release_free_memory_function) {
+ DCHECK_EQ(thunks::GetReleaseFreeMemoryFunction(),
+- reinterpret_cast<thunks::ReleaseFreeMemoryFunction>(NULL));
++ static_cast<thunks::ReleaseFreeMemoryFunction>(0));
+ thunks::SetReleaseFreeMemoryFunction(release_free_memory_function);
+ }
+
diff --git a/www/chromium/files/patch-base__profiler__alternate_timer.cc b/www/chromium/files/patch-base__profiler__alternate_timer.cc
new file mode 100644
index 000000000000..20789aaf9eed
--- /dev/null
+++ b/www/chromium/files/patch-base__profiler__alternate_timer.cc
@@ -0,0 +1,11 @@
+--- base/profiler/alternate_timer.cc 2013-07-03 23:39:54.000000000 -0400
++++ base/profiler/alternate_timer.cc 2013-07-19 00:41:06.000000000 -0400
+@@ -21,7 +21,7 @@
+ // Set an alternate timer function to replace the OS time function when
+ // profiling.
+ void SetAlternateTimeSource(NowFunction* now_function, TimeSourceType type) {
+- DCHECK_EQ(reinterpret_cast<NowFunction*>(NULL), g_time_function);
++ DCHECK_EQ(static_cast<NowFunction*>(0), g_time_function);
+ g_time_function = now_function;
+ g_time_source_type = type;
+ }
diff --git a/www/chromium/files/patch-base__tracked_objects.cc b/www/chromium/files/patch-base__tracked_objects.cc
new file mode 100644
index 000000000000..3e97663f0781
--- /dev/null
+++ b/www/chromium/files/patch-base__tracked_objects.cc
@@ -0,0 +1,11 @@
+--- base/tracked_objects.cc 2013-07-03 23:39:54.000000000 -0400
++++ base/tracked_objects.cc 2013-07-19 00:42:10.000000000 -0400
+@@ -346,7 +346,7 @@
+ }
+ // We must NOT do any allocations during this callback.
+ // Using the simple linked lists avoids all allocations.
+- DCHECK_EQ(this->next_retired_worker_, reinterpret_cast<ThreadData*>(NULL));
++ DCHECK_EQ(this->next_retired_worker_, static_cast<ThreadData*>(0));
+ this->next_retired_worker_ = first_retired_worker_;
+ first_retired_worker_ = this;
+ }
diff --git a/www/chromium/files/patch-chrome__browser__metrics__thread_watcher.cc b/www/chromium/files/patch-chrome__browser__metrics__thread_watcher.cc
new file mode 100644
index 000000000000..b98401bb49ab
--- /dev/null
+++ b/www/chromium/files/patch-chrome__browser__metrics__thread_watcher.cc
@@ -0,0 +1,11 @@
+--- chrome/browser/metrics/thread_watcher.cc 2013-07-03 23:45:55.000000000 -0400
++++ chrome/browser/metrics/thread_watcher.cc 2013-07-19 01:38:45.000000000 -0400
+@@ -40,7 +40,7 @@
+ MSVC_PUSH_DISABLE_WARNING(4748)
+
+ int* NullPointer() {
+- return reinterpret_cast<int*>(NULL);
++ return static_cast<int*>(0);
+ }
+
+ void NullPointerCrash(int line_number) {
diff --git a/www/chromium/files/patch-chrome__browser__sync__glue__synced_session_tracker.cc b/www/chromium/files/patch-chrome__browser__sync__glue__synced_session_tracker.cc
new file mode 100644
index 000000000000..58c0ba1895e9
--- /dev/null
+++ b/www/chromium/files/patch-chrome__browser__sync__glue__synced_session_tracker.cc
@@ -0,0 +1,11 @@
+--- chrome/browser/sync/glue/synced_session_tracker.cc 2013-07-03 23:46:07.000000000 -0400
++++ chrome/browser/sync/glue/synced_session_tracker.cc 2013-07-19 01:50:13.000000000 -0400
+@@ -232,7 +232,7 @@
+ }
+ DCHECK(window_ptr);
+ DCHECK_EQ(window_ptr->window_id.id(), window_id);
+- DCHECK_EQ(reinterpret_cast<SessionWindow*>(NULL),
++ DCHECK_EQ(static_cast<SessionWindow*>(0),
+ GetSession(session_tag)->windows[window_id]);
+ GetSession(session_tag)->windows[window_id] = window_ptr;
+ }
diff --git a/www/chromium/files/patch-third_party__WebKit__Source__wtf__TypeTraits.h b/www/chromium/files/patch-third_party__WebKit__Source__wtf__TypeTraits.h
new file mode 100644
index 000000000000..eb7304f0c127
--- /dev/null
+++ b/www/chromium/files/patch-third_party__WebKit__Source__wtf__TypeTraits.h
@@ -0,0 +1,11 @@
+--- third_party/WebKit/Source/wtf/TypeTraits.h 2013-07-04 00:14:12.000000000 -0400
++++ third_party/WebKit/Source/wtf/TypeTraits.h 2013-07-19 01:29:01.000000000 -0400
+@@ -24,7 +24,7 @@
+
+ #include <wtf/Platform.h>
+
+-#if (defined(__GLIBCXX__) && (__GLIBCXX__ >= 20070724) && defined(__GXX_EXPERIMENTAL_CXX0X__)) || (defined(_MSC_VER) && (_MSC_VER >= 1600))
++#if !COMPILER(CLANG) && ((defined(__GLIBCXX__) && (__GLIBCXX__ >= 20070724) && defined(__GXX_EXPERIMENTAL_CXX0X__)) || (defined(_MSC_VER) && (_MSC_VER >= 1600)))
+ #include <type_traits>
+ #if defined(__GLIBCXX__) && (__GLIBCXX__ >= 20070724) && defined(__GXX_EXPERIMENTAL_CXX0X__)
+ #include <tr1/memory>
diff --git a/www/chromium/files/patch-third_party__hunspell__src__hunspell__affentry.hxx b/www/chromium/files/patch-third_party__hunspell__src__hunspell__affentry.hxx
new file mode 100644
index 000000000000..40c13656fa08
--- /dev/null
+++ b/www/chromium/files/patch-third_party__hunspell__src__hunspell__affentry.hxx
@@ -0,0 +1,20 @@
+--- third_party/hunspell/src/hunspell/affentry.hxx 2013-07-03 23:52:32.000000000 -0400
++++ third_party/hunspell/src/hunspell/affentry.hxx 2013-07-19 01:31:57.000000000 -0400
+@@ -27,7 +27,7 @@
+ struct hentry * checkword(const char * word, int len, char in_compound,
+ const FLAG needflag = FLAG_NULL);
+
+- struct hentry * check_twosfx(const char * word, int len, char in_compound, const FLAG needflag = NULL);
++ struct hentry * check_twosfx(const char * word, int len, char in_compound, const FLAG needflag = 0);
+
+ char * check_morph(const char * word, int len, char in_compound,
+ const FLAG needflag = FLAG_NULL);
+@@ -90,7 +90,7 @@
+ // const FLAG cclass = FLAG_NULL, const FLAG needflag = FLAG_NULL, char in_compound=IN_CPD_NOT);
+ const FLAG cclass = FLAG_NULL, const FLAG needflag = FLAG_NULL, const FLAG badflag = 0);
+
+- struct hentry * check_twosfx(const char * word, int len, int optflags, PfxEntry* ppfx, const FLAG needflag = NULL);
++ struct hentry * check_twosfx(const char * word, int len, int optflags, PfxEntry* ppfx, const FLAG needflag = 0);
+
+ char * check_twosfx_morph(const char * word, int len, int optflags,
+ PfxEntry* ppfx, const FLAG needflag = FLAG_NULL);
diff --git a/www/chromium/files/patch-third_party__libjingle__source__talk__base__taskrunner.cc b/www/chromium/files/patch-third_party__libjingle__source__talk__base__taskrunner.cc
new file mode 100644
index 000000000000..3028ca125afd
--- /dev/null
+++ b/www/chromium/files/patch-third_party__libjingle__source__talk__base__taskrunner.cc
@@ -0,0 +1,11 @@
+--- third_party/libjingle/source/talk/base/taskrunner.cc 2013-07-03 23:54:05.000000000 -0400
++++ third_party/libjingle/source/talk/base/taskrunner.cc 2013-07-19 00:46:25.000000000 -0400
+@@ -119,7 +119,7 @@
+ std::vector<Task *>::iterator it;
+ it = std::remove(tasks_.begin(),
+ tasks_.end(),
+- reinterpret_cast<Task *>(NULL));
++ static_cast<Task *>(0));
+
+ tasks_.erase(it, tasks_.end());
+
diff --git a/www/chromium/files/patch-third_party__sfntly__cpp__src__sfntly__table__core__cmap_table.cc b/www/chromium/files/patch-third_party__sfntly__cpp__src__sfntly__table__core__cmap_table.cc
new file mode 100644
index 000000000000..179b20f94ab3
--- /dev/null
+++ b/www/chromium/files/patch-third_party__sfntly__cpp__src__sfntly__table__core__cmap_table.cc
@@ -0,0 +1,47 @@
+--- third_party/sfntly/cpp/src/sfntly/table/core/cmap_table.cc 2013-07-03 23:54:15.000000000 -0400
++++ third_party/sfntly/cpp/src/sfntly/table/core/cmap_table.cc 2013-07-19 00:44:09.000000000 -0400
+@@ -439,7 +439,7 @@
+ }
+
+ CMapTable::CMapFormat0::Builder::Builder(const CMapId& cmap_id)
+- : CMap::Builder(reinterpret_cast<ReadableFontData*>(NULL),
++ : CMap::Builder(static_cast<ReadableFontData*>(0),
+ CMapFormat::kFormat0,
+ cmap_id) {
+ }
+@@ -563,7 +563,7 @@
+ : CMapTable::CMap::Builder(data ? down_cast<WritableFontData*>(
+ data->Slice(offset, data->ReadUShort(
+ offset + Offset::kFormat0Length)))
+- : reinterpret_cast<WritableFontData*>(NULL),
++ : static_cast<WritableFontData*>(0),
+ CMapFormat::kFormat2, cmap_id) {
+ // TODO(arthurhsu): FIXIT: heavy lifting and leak, need fix.
+ }
+@@ -574,7 +574,7 @@
+ : CMapTable::CMap::Builder(data ? down_cast<ReadableFontData*>(
+ data->Slice(offset, data->ReadUShort(
+ offset + Offset::kFormat0Length)))
+- : reinterpret_cast<ReadableFontData*>(NULL),
++ : static_cast<ReadableFontData*>(0),
+ CMapFormat::kFormat2, cmap_id) {
+ // TODO(arthurhsu): FIXIT: heavy lifting and leak, need fix.
+ }
+@@ -958,7 +958,7 @@
+ CMapTable::CMapFormat4::Builder::Builder(SegmentList* segments,
+ IntegerList* glyph_id_array,
+ const CMapId& cmap_id)
+- : CMap::Builder(reinterpret_cast<ReadableFontData*>(NULL),
++ : CMap::Builder(static_cast<ReadableFontData*>(0),
+ CMapFormat::kFormat4, cmap_id),
+ segments_(segments->begin(), segments->end()),
+ glyph_id_array_(glyph_id_array->begin(), glyph_id_array->end()) {
+@@ -966,7 +966,7 @@
+ }
+
+ CMapTable::CMapFormat4::Builder::Builder(const CMapId& cmap_id)
+- : CMap::Builder(reinterpret_cast<ReadableFontData*>(NULL),
++ : CMap::Builder(static_cast<ReadableFontData*>(0),
+ CMapFormat::kFormat4, cmap_id) {
+ }
+
diff --git a/www/chromium/files/patch-v8__src__stub-cache.cc b/www/chromium/files/patch-v8__src__stub-cache.cc
new file mode 100644
index 000000000000..a35cc4288528
--- /dev/null
+++ b/www/chromium/files/patch-v8__src__stub-cache.cc
@@ -0,0 +1,11 @@
+--- v8/src/stub-cache.cc 2013-07-03 23:56:49.000000000 -0400
++++ v8/src/stub-cache.cc 2013-07-19 00:35:10.000000000 -0400
+@@ -1476,7 +1476,7 @@
+ Handle<Name> name) {
+ return (FLAG_print_code_stubs && !name.is_null() && name->IsString())
+ ? GetCodeWithFlags(flags, *Handle<String>::cast(name)->ToCString())
+- : GetCodeWithFlags(flags, reinterpret_cast<char*>(NULL));
++ : GetCodeWithFlags(flags, static_cast<char*>(0));
+ }
+
+