aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-11-14 06:13:24 +0800
committerantoine <antoine@FreeBSD.org>2015-11-14 06:13:24 +0800
commitbdef459d162c3b334a8d451de3ccc9083977bb54 (patch)
tree40de89588d283834a724d8036a4c3ffe380bc724 /www
parent419563864db70c9c8ace727ddaf9b19429e66b65 (diff)
downloadfreebsd-ports-gnome-bdef459d162c3b334a8d451de3ccc9083977bb54.tar.gz
freebsd-ports-gnome-bdef459d162c3b334a8d451de3ccc9083977bb54.tar.zst
freebsd-ports-gnome-bdef459d162c3b334a8d451de3ccc9083977bb54.zip
Chase PHP 5.4 expiration date
Diffstat (limited to 'www')
-rw-r--r--www/autoindex2/Makefile3
-rw-r--r--www/cakephp11/Makefile3
-rw-r--r--www/cakephp13/Makefile3
-rw-r--r--www/cakephp21/Makefile3
-rw-r--r--www/cakephp22/Makefile3
-rw-r--r--www/cakephp23/Makefile3
-rw-r--r--www/fluxcms/Makefile3
-rw-r--r--www/fusionpbx/Makefile3
-rw-r--r--www/jawstats/Makefile3
-rw-r--r--www/ojs2/Makefile3
-rw-r--r--www/pecl-zendopcache/Makefile3
-rw-r--r--www/webcalendar/Makefile3
12 files changed, 36 insertions, 0 deletions
diff --git a/www/autoindex2/Makefile b/www/autoindex2/Makefile
index bf49a61e3fc9..636113bae9d4 100644
--- a/www/autoindex2/Makefile
+++ b/www/autoindex2/Makefile
@@ -10,6 +10,9 @@ MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME}%20PHP%20Script%202.x/${PORTNAME}%20P
MAINTAINER= ports@FreeBSD.org
COMMENT= PHP 5.x script that put a directory listing into a table
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= dos2unix
diff --git a/www/cakephp11/Makefile b/www/cakephp11/Makefile
index 634ad92413bd..70a16922f44a 100644
--- a/www/cakephp11/Makefile
+++ b/www/cakephp11/Makefile
@@ -13,6 +13,9 @@ DISTNAME= cake_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Framework for developing PHP web applications
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USES= tar:bzip2
USE_APACHE_RUN= 22+
diff --git a/www/cakephp13/Makefile b/www/cakephp13/Makefile
index d2896e9c7b36..a91799f13dca 100644
--- a/www/cakephp13/Makefile
+++ b/www/cakephp13/Makefile
@@ -11,6 +11,9 @@ COMMENT= Framework for developing PHP web applications
LICENSE= MIT
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USE_GITHUB= yes
PORTDOCS= README
diff --git a/www/cakephp21/Makefile b/www/cakephp21/Makefile
index 400277ccf171..83c67a03ed86 100644
--- a/www/cakephp21/Makefile
+++ b/www/cakephp21/Makefile
@@ -11,6 +11,9 @@ COMMENT= Framework for developing PHP web applications
LICENSE= MIT
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USE_GITHUB= yes
PORTDOCS= README
diff --git a/www/cakephp22/Makefile b/www/cakephp22/Makefile
index 77df9c90bfb9..b96ce151e476 100644
--- a/www/cakephp22/Makefile
+++ b/www/cakephp22/Makefile
@@ -11,6 +11,9 @@ COMMENT= Framework for developing PHP web applications
LICENSE= MIT
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USE_GITHUB= yes
PORTDOCS= README.md
diff --git a/www/cakephp23/Makefile b/www/cakephp23/Makefile
index e1c68e9dd744..f2df558ffc70 100644
--- a/www/cakephp23/Makefile
+++ b/www/cakephp23/Makefile
@@ -10,6 +10,9 @@ COMMENT= Framework for developing PHP web applications
LICENSE= MIT
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USE_GITHUB= yes
PORTDOCS= README.md
diff --git a/www/fluxcms/Makefile b/www/fluxcms/Makefile
index d56e5029ebc2..cf6f2f827bbd 100644
--- a/www/fluxcms/Makefile
+++ b/www/fluxcms/Makefile
@@ -11,6 +11,9 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-snapshot-20090308
MAINTAINER= beat@FreeBSD.org
COMMENT= Extensible and flexible CMS based on PHP 5 and XML/XSLT
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
USES= shebangfix tar:tgz
SHEBANG_FILES= div/db/dbexport.sh \
div/db/dbexport40.sh \
diff --git a/www/fusionpbx/Makefile b/www/fusionpbx/Makefile
index 17645dc4580b..29fb13c6a4fa 100644
--- a/www/fusionpbx/Makefile
+++ b/www/fusionpbx/Makefile
@@ -13,6 +13,9 @@ COMMENT= PHP5 Graphical User Interface for FreeSwitch
LICENSE= MPL
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC
RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_odbc.so:${PORTSDIR}/databases/php${PHP_VER}-pdo_odbc
diff --git a/www/jawstats/Makefile b/www/jawstats/Makefile
index 3249262bf2d8..f4c872a550e1 100644
--- a/www/jawstats/Makefile
+++ b/www/jawstats/Makefile
@@ -9,6 +9,9 @@ MASTER_SITES= http://www.jawstats.com/src/
MAINTAINER= Alan@Wave2.org
COMMENT= JAWStats is a Free Web Site Statistics tool
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
RUN_DEPENDS= awstats>=6.8:${PORTSDIR}/www/awstats
NO_WRKSUBDIR= yes
diff --git a/www/ojs2/Makefile b/www/ojs2/Makefile
index 28d5ee827562..d7e820a530a3 100644
--- a/www/ojs2/Makefile
+++ b/www/ojs2/Makefile
@@ -13,6 +13,9 @@ DISTNAME= ojs-2.2.1
MAINTAINER= filiperocha@gmail.com
COMMENT= Journal management and publishing system
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
DIST_SUBDIR= ${PORTNAME}
NO_BUILD= yes
diff --git a/www/pecl-zendopcache/Makefile b/www/pecl-zendopcache/Makefile
index bc3b085127b6..b667e2e4f034 100644
--- a/www/pecl-zendopcache/Makefile
+++ b/www/pecl-zendopcache/Makefile
@@ -13,6 +13,9 @@ COMMENT= Opcode cacher and optimizer for PHP
LICENSE= PHP301
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
OPTIONS_DEFINE= DOCS
USES= tar:tgz
diff --git a/www/webcalendar/Makefile b/www/webcalendar/Makefile
index 89843a4c858c..133614d26a69 100644
--- a/www/webcalendar/Makefile
+++ b/www/webcalendar/Makefile
@@ -10,6 +10,9 @@ COMMENT= Web-based calendar application
LICENSE= GPLv2
+DEPRECATED= PHP 5.4 EOL reached
+EXPIRATION_DATE= 2016-01-15
+
PORTSCOUT= limit:^1\.2\. skipb:1
USE_PHP= pcre session
WANT_PHP_WEB= yes