aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2016-03-02 02:15:22 +0800
committergarga <garga@FreeBSD.org>2016-03-02 02:15:22 +0800
commitbf4c2a96dafc24dbf12a84ea04381804e1c791e6 (patch)
treef9815357cb5beb006de769c705572462d1edcea9 /www
parentbad5ef4408a57a219399e730d0052fa51fa47332 (diff)
downloadfreebsd-ports-gnome-bf4c2a96dafc24dbf12a84ea04381804e1c791e6.tar.gz
freebsd-ports-gnome-bf4c2a96dafc24dbf12a84ea04381804e1c791e6.tar.zst
freebsd-ports-gnome-bf4c2a96dafc24dbf12a84ea04381804e1c791e6.zip
Patch lightsquid to consider TCP_REFRESH_UNMODIFIED as a HIT and increment
counter. Bump PORTREVISION Obtained from: pfSense Forum https://forum.pfsense.org/index.php?topic=107659.msg599640#msg599640 Sponsored by: Rubicon Communications (Netgate)
Diffstat (limited to 'www')
-rw-r--r--www/lightsquid/Makefile2
-rw-r--r--www/lightsquid/files/patch-lightparser.pl17
2 files changed, 14 insertions, 5 deletions
diff --git a/www/lightsquid/Makefile b/www/lightsquid/Makefile
index 374052e075a0..4ef21e5f981d 100644
--- a/www/lightsquid/Makefile
+++ b/www/lightsquid/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lightsquid
PORTVERSION= 1.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= SF
diff --git a/www/lightsquid/files/patch-lightparser.pl b/www/lightsquid/files/patch-lightparser.pl
index 577d62309980..b0a25af57013 100644
--- a/www/lightsquid/files/patch-lightparser.pl
+++ b/www/lightsquid/files/patch-lightparser.pl
@@ -1,6 +1,6 @@
---- lightparser.pl.orig Wed Jan 10 19:06:49 2007
-+++ lightparser.pl Thu Jan 11 00:53:59 2007
-@@ -36,7 +36,7 @@
+--- lightparser.pl.orig 2009-07-02 22:15:32 UTC
++++ lightparser.pl
+@@ -36,7 +36,7 @@ require "lightsquid.cfg";
require "common.pl";
#include ip2name function
@@ -8,4 +8,13 @@
+require "$ip2namepath/ip2name.$ip2name";
$SIG{INT} = \&LOCKREMOVER; # traps keyboard interrupt
- my $lockfilepath ="$lockpath/lockfile";
+ my $lockfilepath ="$lockpath/lockfile";
+@@ -202,7 +202,7 @@ while (<FF>) {
+ next;
+ };
+
+- if ($Ltype =~ m/HIT/) {
++ if ($Ltype =~ m/(HIT|UNMODIFIED)/) {
+ $CacheHIT+=$Lsize;
+ } else {
+ $CacheMISS+=$Lsize;