aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-16 04:48:01 +0800
committerpav <pav@FreeBSD.org>2005-09-16 04:48:01 +0800
commitc08df558638e2b359f2222e2e08ef0e5a9aeca7f (patch)
tree0b32c97efed0ebefee49f4a6376bff42aab1b666 /www
parent6860ec1947658e9ed362b36894da90f94927705e (diff)
downloadfreebsd-ports-gnome-c08df558638e2b359f2222e2e08ef0e5a9aeca7f.tar.gz
freebsd-ports-gnome-c08df558638e2b359f2222e2e08ef0e5a9aeca7f.tar.zst
freebsd-ports-gnome-c08df558638e2b359f2222e2e08ef0e5a9aeca7f.zip
- Fix a bug in the installer
PR: ports/84867 Submitted by: Fumihiko Kimura <jfkimura@yahoo.co.jp> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/tdiary-devel/Makefile1
-rw-r--r--www/tdiary-devel/files/tdiaryinst.rb.in5
2 files changed, 6 insertions, 0 deletions
diff --git a/www/tdiary-devel/Makefile b/www/tdiary-devel/Makefile
index e5b812689f7c..63ff11f2c039 100644
--- a/www/tdiary-devel/Makefile
+++ b/www/tdiary-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tdiary
PORTVERSION= 2.1.2
+PORTREVISION= 1
CATEGORIES?= www ruby
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.tdiary.org/download/
diff --git a/www/tdiary-devel/files/tdiaryinst.rb.in b/www/tdiary-devel/files/tdiaryinst.rb.in
index 435c506b1ad1..634ecddeade4 100644
--- a/www/tdiary-devel/files/tdiaryinst.rb.in
+++ b/www/tdiary-devel/files/tdiaryinst.rb.in
@@ -260,6 +260,11 @@ class TdiaryInstall
FileUtils16.chmod(0777, "#{@passwd.dir}/#{@httpdir}/#{@diarydir}", *@fileutilOptions) if ! defined?($OPT_SUEXEC)
FileUtils16.rm("#{@passwd.dir}/#{@httpdir}/#{@diarydir}/tdiary-FreeBSD.sh", :force, *@fileutilOptions)
+ FileUtils16.chmod(0701, "#{@passwd.dir}/#{@diarydir}", *@fileutilOptions) if defined?($OPT_SUEXEC)
+ FileUtils16.chmod(0701, "#{@passwd.dir}/#{@httpdir}/#{@diarydir}", *@fileutilOptions) if defined?($OPT_SUEXEC)
+ FileUtils16.chmod(0700, "#{@passwd.dir}/#{@httpdir}/#{@diarydir}/index.rb", *@fileutilOptions) if defined?($OPT_SUEXEC)
+ FileUtils16.chmod(0700, "#{@passwd.dir}/#{@httpdir}/#{@diarydir}/update.rb", *@fileutilOptions) if defined?($OPT_SUEXEC)
+
if @euid == 0 then
Find.find("#{@passwd.dir}/#{@diarydir}", "#{@passwd.dir}/#{@httpdir}/#{@diarydir}") do |f|
File.chown(@passwd.uid, @passwd.gid, f)