aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2017-12-19 17:30:10 +0800
committerLars Engels <lme@FreeBSD.org>2017-12-19 17:30:10 +0800
commitc1f41e3c90a3bd0d79c7c59cc39793dcf78aeabe (patch)
tree36c609759794e1f467b284fcb8506f0ec4a5d9e4 /www
parent119945cd3b316d67d2890c208b07ab25ee56c1db (diff)
downloadfreebsd-ports-gnome-c1f41e3c90a3bd0d79c7c59cc39793dcf78aeabe.tar.gz
freebsd-ports-gnome-c1f41e3c90a3bd0d79c7c59cc39793dcf78aeabe.tar.zst
freebsd-ports-gnome-c1f41e3c90a3bd0d79c7c59cc39793dcf78aeabe.zip
www/tomcat{85,-devel}
- Add support for jsvc umask - Bump PORTREVISION jsvc support `-umask` parameter since 1.0.8, it can be useful e.g. to set to 0027 to have group-readable Catalina log files. PR: 224266, 224321 Submitted by: Lapo Luchini Approved by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/tomcat-devel/Makefile1
-rw-r--r--www/tomcat-devel/files/tomcat_devel.in6
-rw-r--r--www/tomcat85/Makefile1
-rw-r--r--www/tomcat85/files/tomcat85.in6
4 files changed, 14 insertions, 0 deletions
diff --git a/www/tomcat-devel/Makefile b/www/tomcat-devel/Makefile
index 8049cf41d8dc..df933111104a 100644
--- a/www/tomcat-devel/Makefile
+++ b/www/tomcat-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tomcat
PORTVERSION= 9.0.2
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= APACHE/${PORTNAME}/${PORTNAME}-${PORTVERSION:C/([0-9])(.*)/\1/}/v${PORTVERSION}/bin
PKGNAMESUFFIX= -devel
diff --git a/www/tomcat-devel/files/tomcat_devel.in b/www/tomcat-devel/files/tomcat_devel.in
index 82c64f2cffd2..0e9daba04a7c 100644
--- a/www/tomcat-devel/files/tomcat_devel.in
+++ b/www/tomcat-devel/files/tomcat_devel.in
@@ -58,6 +58,10 @@
# Set to "30" by default.
# Set the wait time (in seconds) for Tomcat process startup
#
+# tomcat_devel_umask (str):
+# Set to "0077" by default.
+# Sets the umask for Tomcat process.
+#
# You may symlink this script with other names to run multiple
# instances of tomcat-devel with different configurations.
#
@@ -94,6 +98,7 @@ eval "_tomcat_logging_config=\${${name}_logging_config:-'${_tomcat_catalina_base
eval "_tomcat_classpath=\${${name}_classpath:-''}"
eval "_tomcat_java_opts=\${${name}_java_opts:-''}"
eval "_tomcat_wait=\${${name}_wait:-'30'}"
+eval "_tomcat_umask=\${${name}_umask:-'0077'}"
pidfile="/var/run/${name}.pid"
@@ -106,6 +111,7 @@ command="%%LOCALBASE%%/bin/jsvc"
command_args="-java-home '${_tomcat_java_home}' \
-server \
-user ${_tomcat_catalina_user} \
+ -umask ${_tomcat_umask} \
-pidfile '${pidfile}' \
-wait ${_tomcat_wait} \
-outfile '${_tomcat_stdout}' \
diff --git a/www/tomcat85/Makefile b/www/tomcat85/Makefile
index 73e64a464855..5b92a87a1983 100644
--- a/www/tomcat85/Makefile
+++ b/www/tomcat85/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tomcat
PORTVERSION= 8.5.24
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= APACHE/tomcat/tomcat-8/v${PORTVERSION}/bin
PKGNAMESUFFIX= 85
diff --git a/www/tomcat85/files/tomcat85.in b/www/tomcat85/files/tomcat85.in
index aac2a984c844..021f45971cfc 100644
--- a/www/tomcat85/files/tomcat85.in
+++ b/www/tomcat85/files/tomcat85.in
@@ -58,6 +58,10 @@
# Set to "30" by default.
# Set the wait time (in seconds) for Tomcat process startup
#
+# tomcat85_umask (str):
+# Set to "0077" by default.
+# Sets the umask for Tomcat process.
+#
# You may symlink this script with other names to run multiple
# instances of tomcat85 with different configurations.
#
@@ -94,6 +98,7 @@ eval "_tomcat_logging_config=\${${name}_logging_config:-'${_tomcat_catalina_base
eval "_tomcat_classpath=\${${name}_classpath:-''}"
eval "_tomcat_java_opts=\${${name}_java_opts:-''}"
eval "_tomcat_wait=\${${name}_wait:-'30'}"
+eval "_tomcat_umask=\${${name}_umask:-'0077'}"
pidfile="/var/run/${name}.pid"
@@ -106,6 +111,7 @@ command="%%LOCALBASE%%/bin/jsvc"
command_args="-java-home '${_tomcat_java_home}' \
-server \
-user ${_tomcat_catalina_user} \
+ -umask ${_tomcat_umask} \
-pidfile '${pidfile}' \
-wait ${_tomcat_wait} \
-outfile '${_tomcat_stdout}' \