aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2004-06-14 21:22:58 +0800
committerAndrey A. Chernov <ache@FreeBSD.org>2004-06-14 21:22:58 +0800
commitc43d638eb485743baed1d6b727ab07aa59eeab51 (patch)
treefbd1ef089bc6e5ebba52ff2e4912714d36e87d8a /www
parenta9e73f8ac0360c40dbd33c9b726c1375a0801d77 (diff)
downloadfreebsd-ports-gnome-c43d638eb485743baed1d6b727ab07aa59eeab51.tar.gz
freebsd-ports-gnome-c43d638eb485743baed1d6b727ab07aa59eeab51.tar.zst
freebsd-ports-gnome-c43d638eb485743baed1d6b727ab07aa59eeab51.zip
Fix connection problem with mod_dav and FP
http://issues.apache.org/bugzilla/show_bug.cgi?id=29237 PR: 67928 Submitted by: Helge Oldach <apache13jun14@oldach.net>
Diffstat (limited to 'www')
-rw-r--r--www/apache13/Makefile2
-rw-r--r--www/apache13/files/patch-http_request.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/www/apache13/Makefile b/www/apache13/Makefile
index f20126d5cc64..67497e5d18bb 100644
--- a/www/apache13/Makefile
+++ b/www/apache13/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apache
PORTVERSION= 1.3.31
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= apache_${PORTVERSION}
diff --git a/www/apache13/files/patch-http_request.c b/www/apache13/files/patch-http_request.c
new file mode 100644
index 000000000000..e4642e4f2d27
--- /dev/null
+++ b/www/apache13/files/patch-http_request.c
@@ -0,0 +1,11 @@
+--- src/main/http_request.c.bak Wed Apr 28 20:58:42 2004
++++ src/main/http_request.c Mon Jun 14 17:11:06 2004
+@@ -1056,7 +1056,7 @@
+ */
+ if ((r->status != HTTP_NOT_MODIFIED) && (r->status != HTTP_NO_CONTENT)
+ && !ap_status_drops_connection(r->status)
+- && r->connection && (r->connection->keepalive > 0)) {
++ && r->connection && (r->connection->keepalive != -1)) {
+
+ (void) ap_discard_request_body(r);
+ }