aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2012-07-04 01:09:44 +0800
committerSergey A. Osokin <osa@FreeBSD.org>2012-07-04 01:09:44 +0800
commitc50207ee17c49db5df33767f8dc2b10df8d5b736 (patch)
tree4e39480cef934dd0654ee0a98d91c317f9eedcee /www
parent5ee8ff9eeaf4cb6bfa44883bd33f6ef659e6c4eb (diff)
downloadfreebsd-ports-gnome-c50207ee17c49db5df33767f8dc2b10df8d5b736.tar.gz
freebsd-ports-gnome-c50207ee17c49db5df33767f8dc2b10df8d5b736.tar.zst
freebsd-ports-gnome-c50207ee17c49db5df33767f8dc2b10df8d5b736.zip
Update from 1.2.1 to 1.2.2.
<ChangeLog> *) Change: the "single" parameter of the "keepalive" directive is now ignored. *) Change: SSL compression is now disabled when using all versions of OpenSSL, including ones prior to 1.0.0. *) Feature: the "proxy_pass", "fastcgi_pass", "scgi_pass", "uwsgi_pass" directives, and the "server" directive inside the "upstream" block, now support IPv6 addresses. *) Feature: the "resolver" directive now support IPv6 addresses and an optional port specification. *) Feature: the "least_conn" directive inside the "upstream" block. *) Feature: it is now possible to specify a weight for servers while using the "ip_hash" directive. *) Feature: it is now possible to use the "ip_hash" directive to balance IPv6 clients. *) Feature: the $status variable can now be used not only in the "log_format" directive. *) Bugfix: nginx could not be built with ngx_cpp_test_module; the bug had appeared in 1.1.12. *) Bugfix: access to variables from SSI and embedded perl module might not work after reconfiguration. Thanks to Yichun Zhang. *) Bugfix: in the ngx_http_xslt_filter_module. Thanks to Kuramoto Eiji. *) Bugfix: memory leak if $geoip_org variable was used. Thanks to Denis F. Latypoff. *) Bugfix: in the "proxy_cookie_domain" and "proxy_cookie_path" directives. *) Bugfix: a segmentation fault might occur in a worker process on shutdown if the "resolver" directive was used. *) Bugfix: a segmentation fault might occur in a worker process if the ngx_http_mp4_module was used. *) Bugfix: in the ngx_http_mp4_module. *) Bugfix: a segmentation fault might occur in a worker process if conflicting wildcard server names were used. *) Bugfix: nginx might be terminated abnormally on a SIGBUS signal on ARM platform. *) Bugfix: an alert "sendmsg() failed (9: Bad file number)" on HP-UX while reconfiguration. </ChangeLog>
Diffstat (limited to 'www')
-rw-r--r--www/nginx/Makefile5
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/extra-patch-naxsi_runtime.c16
-rw-r--r--www/nginx/files/extra-patch-ngx_http_subs_filter_module.c11
4 files changed, 32 insertions, 4 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index db2b7fe3542d..2ebf1c77d257 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 1.2.1
-PORTREVISION= 2
+PORTVERSION= 1.2.2
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
@@ -462,6 +461,7 @@ MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:subs_filter/}
MASTER_SITE_SUBDIR+= osa/:subs_filter
DISTFILES+= ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_VERSION}.tar.gz:subs_filter
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_VERSION}
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_subs_filter_module.c
.endif
.if ${PORT_OPTIONS:MHTTP_SECURE_LINK}
@@ -607,6 +607,7 @@ NGINX_NAXSI_VERSION= 0.46-1
MASTER_SITES+= http://naxsi.googlecode.com/files/:naxsi
DISTFILES+= naxsi-${NGINX_NAXSI_VERSION}.tgz:naxsi
CONFIGURE_ARGS+=--add-module=${WRKDIR}/naxsi-${NGINX_NAXSI_VERSION}/naxsi_src
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-naxsi_runtime.c
.endif
.if ${PORT_OPTIONS:MHTTP_REWRITE} || defined(USE_HTTP_REWRITE)
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 820bffb730eb..5fe2c1a832ef 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,5 +1,5 @@
-SHA256 (nginx-1.2.1.tar.gz) = 994ad97cbf6f7045f95ea9d6d401aad1e95766671e402c48af85aba5235a2dd7
-SIZE (nginx-1.2.1.tar.gz) = 718161
+SHA256 (nginx-1.2.2.tar.gz) = 409477c7a9fba58c110a176fd7965b9db188bcf8be0e7f8a0731b8ae1e6ee880
+SIZE (nginx-1.2.2.tar.gz) = 722069
SHA256 (giom-nginx_accept_language_module-02262ce.tar.gz) = 3191f4caa70d9a8942c4f10b6abaaa96af451991d4b5e1e3d7b991376b00bf0c
SIZE (giom-nginx_accept_language_module-02262ce.tar.gz) = 3398
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
diff --git a/www/nginx/files/extra-patch-naxsi_runtime.c b/www/nginx/files/extra-patch-naxsi_runtime.c
new file mode 100644
index 000000000000..7d6a5a621b4d
--- /dev/null
+++ b/www/nginx/files/extra-patch-naxsi_runtime.c
@@ -0,0 +1,16 @@
+--- ../naxsi-0.46-1/naxsi_src/naxsi_runtime.c.orig 2012-07-03 20:58:17.000000000 +0400
++++ ../naxsi-0.46-1/naxsi_src/naxsi_runtime.c 2012-07-03 21:01:32.000000000 +0400
+@@ -116,7 +116,12 @@
+ tmp_idx = 0;
+ len = str->len;
+ while
+-#if defined nginx_version && (nginx_version > 1001011)
++#if defined nginx_version && (nginx_version > 1002001)
++ (tmp_idx < len &&
++ (match = pcre_exec(rl->br->rx->regex->code, 0,
++ (const char *) str->data, str->len, tmp_idx, 0,
++ captures, 6)) >= 0)
++#elif defined nginx_version && ((nginx_version > 1001011) && (nginx_version <= 1002001))
+ (tmp_idx < len &&
+ (match = pcre_exec(rl->br->rx->regex->pcre, 0,
+ (const char *) str->data, str->len, tmp_idx, 0,
diff --git a/www/nginx/files/extra-patch-ngx_http_subs_filter_module.c b/www/nginx/files/extra-patch-ngx_http_subs_filter_module.c
new file mode 100644
index 000000000000..c2e579f26420
--- /dev/null
+++ b/www/nginx/files/extra-patch-ngx_http_subs_filter_module.c
@@ -0,0 +1,11 @@
+--- ../ngx_http_subs_filter_module-0.5.2.r59/ngx_http_subs_filter_module.c.orig 2012-07-03 20:55:52.000000000 +0400
++++ ../ngx_http_subs_filter_module-0.5.2.r59/ngx_http_subs_filter_module.c 2012-07-03 20:56:52.000000000 +0400
+@@ -1302,7 +1302,7 @@
+
+ n = 0;
+
+-#if defined(nginx_version) && nginx_version >= 1003001
++#if defined(nginx_version) && nginx_version >= 1002002
+ rc = pcre_fullinfo(re->code, NULL, PCRE_INFO_CAPTURECOUNT, &n);
+ #elif defined(nginx_version) && nginx_version >= 1001012
+ rc = pcre_fullinfo(re->pcre, NULL, PCRE_INFO_CAPTURECOUNT, &n);