aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-09-09 23:01:34 +0800
committerSteve Wills <swills@FreeBSD.org>2012-09-09 23:01:34 +0800
commitc850dea23e2d4a9d850e2cbd0141aa3f8fc1485f (patch)
treeb4848497f4175bda7ef349780d1071adb94a3331 /www
parent4e7e939867e723d73efc4a61a3f0283834008190 (diff)
downloadfreebsd-ports-gnome-c850dea23e2d4a9d850e2cbd0141aa3f8fc1485f.tar.gz
freebsd-ports-gnome-c850dea23e2d4a9d850e2cbd0141aa3f8fc1485f.tar.zst
freebsd-ports-gnome-c850dea23e2d4a9d850e2cbd0141aa3f8fc1485f.zip
Http_post does a POST operation and dumps the results to stdout. This supports
ipv6 and https (SSL). WWW: http://www.acme.com/software/http_post/ PR: ports/171492 Submitted by: masaki@club.kyutech.ac.jp
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/http_post/Makefile28
-rw-r--r--www/http_post/distinfo2
-rw-r--r--www/http_post/files/Makefile.bsd12
-rw-r--r--www/http_post/pkg-descr4
5 files changed, 47 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d669ffd3c186..c3f61227c7f4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -337,6 +337,7 @@
SUBDIR += http-analyze
SUBDIR += http_get
SUBDIR += http_load
+ SUBDIR += http_post
SUBDIR += httpclient
SUBDIR += httpcore
SUBDIR += httpgrabber
diff --git a/www/http_post/Makefile b/www/http_post/Makefile
new file mode 100644
index 000000000000..ea9ef55ecaac
--- /dev/null
+++ b/www/http_post/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: http_post
+# Date created: 9 Sep 2012
+# Whom: Masaki TAGAWA <masaki@club.kyutech.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= http_post
+PORTVERSION= 1.0.20110118
+CATEGORIES= www ipv6
+MASTER_SITES= http://www.acme.com/software/http_post/
+DISTNAME= ${PORTNAME}_18jan2011
+
+MAINTAINER= masaki@club.kyutech.ac.jp
+COMMENT= Do a POST operaion and Dump http-contents to stdout
+
+WRKSRC= ${WRKDIR}/http_post
+MAKEFILE= ${FILESDIR}/Makefile.bsd
+
+MAN1= http_post.1
+MANCOMPRESSED= yes
+PLIST_FILES= bin/http_post
+
+.ifndef NO_OPENSSL
+USE_OPENSSL= yes
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/http_post/distinfo b/www/http_post/distinfo
new file mode 100644
index 000000000000..7a70d3e7d393
--- /dev/null
+++ b/www/http_post/distinfo
@@ -0,0 +1,2 @@
+SHA256 (http_post_18jan2011.tar.gz) = 3a000cc417000d7dc92735f17a073df74e82a38ac1d382afe05454d175645559
+SIZE (http_post_18jan2011.tar.gz) = 8136
diff --git a/www/http_post/files/Makefile.bsd b/www/http_post/files/Makefile.bsd
new file mode 100644
index 000000000000..7d72745bef47
--- /dev/null
+++ b/www/http_post/files/Makefile.bsd
@@ -0,0 +1,12 @@
+PROG = http_post
+SRCS = http_post.c
+
+.ifndef NO_OPENSSL
+CFLAGS += -DUSE_SSL -I${OPENSSLBASE}/include ${OPENSSL_CFLAGS}
+LDFLAGS += -L${OPENSSLBASE}/lib -lssl -lcrypto
+.endif
+
+BINDIR = ${PREFIX}/bin
+MANDIR = ${PREFIX}/man/man
+
+.include <bsd.prog.mk>
diff --git a/www/http_post/pkg-descr b/www/http_post/pkg-descr
new file mode 100644
index 000000000000..f5937a96b383
--- /dev/null
+++ b/www/http_post/pkg-descr
@@ -0,0 +1,4 @@
+Http_post does a POST operation and dumps the results to stdout. This supports
+ipv6 and https (SSL).
+
+WWW: http://www.acme.com/software/http_post/