aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2015-07-01 05:07:30 +0800
committerthierry <thierry@FreeBSD.org>2015-07-01 05:07:30 +0800
commitca78cf7ceada6828429e6de33be63cda68f05d7a (patch)
tree393c236c61b42b96461b178d7cd7328db830e49b /www
parentca7c759f002484028ee151456a242ecb7912f483 (diff)
downloadfreebsd-ports-gnome-ca78cf7ceada6828429e6de33be63cda68f05d7a.tar.gz
freebsd-ports-gnome-ca78cf7ceada6828429e6de33be63cda68f05d7a.tar.zst
freebsd-ports-gnome-ca78cf7ceada6828429e6de33be63cda68f05d7a.zip
Upgrade to 5.0.0.
Note: to avoid conflicts with the other tidy-s, the previous names are kept.
Diffstat (limited to 'www')
-rw-r--r--www/tidy-html5/Makefile9
-rw-r--r--www/tidy-html5/distinfo4
-rw-r--r--www/tidy-html5/files/patch-CMakeLists.txt4
-rw-r--r--www/tidy-html5/files/patch-test_testone.sh11
-rw-r--r--www/tidy-html5/pkg-plist12
5 files changed, 28 insertions, 12 deletions
diff --git a/www/tidy-html5/Makefile b/www/tidy-html5/Makefile
index d67e001da3f0..bcf1419b7e78 100644
--- a/www/tidy-html5/Makefile
+++ b/www/tidy-html5/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tidy-html5
-PORTVERSION= 4.9.36
+PORTVERSION= 5.0.0
CATEGORIES= www
MAINTAINER= thierry@FreeBSD.org
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
USE_GITHUB= yes
GH_ACCOUNT= htacg
GH_PROJECT= ${PORTNAME}
-GH_TAGNAME= b65988c
+GH_TAGNAME= 1e70fc6
USES= cmake
USE_GNOME= libxslt
@@ -27,6 +27,11 @@ PLIST_SUB= VER=${PORTVERSION}
pre-configure:
${REINPLACE_CMD} -e 's|build/cmake/||' ${WRKSRC}/test/testone.sh
+post-install:
+ # To avoid conflict ATM - to be removed later
+ ${MV} ${STAGEDIR}${PREFIX}/bin/tidy ${STAGEDIR}${PREFIX}/bin/tidy5
+ ${MV} ${STAGEDIR}${PREFIX}/lib/libtidy.so ${STAGEDIR}${PREFIX}/lib/libtidy5.so
+
regression-test:
(cd ${WRKSRC}/test && ./testall.sh)
diff --git a/www/tidy-html5/distinfo b/www/tidy-html5/distinfo
index 369a2cacd2e0..f80f3e2dbec2 100644
--- a/www/tidy-html5/distinfo
+++ b/www/tidy-html5/distinfo
@@ -1,2 +1,2 @@
-SHA256 (htacg-tidy-html5-4.9.36-b65988c_GH0.tar.gz) = dd4221eeb5bfcbd842126a583b0a27cc3a1550e59ddf2857caa44fdfced53792
-SIZE (htacg-tidy-html5-4.9.36-b65988c_GH0.tar.gz) = 680205
+SHA256 (htacg-tidy-html5-5.0.0-1e70fc6_GH0.tar.gz) = cf9bf72c49776c585ae85d4cea3dc5863c925852c69804c1189691e5751cd875
+SIZE (htacg-tidy-html5-5.0.0-1e70fc6_GH0.tar.gz) = 680570
diff --git a/www/tidy-html5/files/patch-CMakeLists.txt b/www/tidy-html5/files/patch-CMakeLists.txt
index 36710cc00a79..6c396517a701 100644
--- a/www/tidy-html5/files/patch-CMakeLists.txt
+++ b/www/tidy-html5/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2015-05-20 18:09:57 UTC
+--- CMakeLists.txt.orig 2015-06-30 18:06:02 UTC
+++ CMakeLists.txt
-@@ -24,7 +24,7 @@ option( BUILD_SHARED_LIB "Set ON to buil
+@@ -42,7 +42,7 @@ option( BUILD_SHARED_LIB "Set OFF to NOT
option( BUILD_TAB2SPACE "Set ON to build utility app, tab2space" OFF )
option( BUILD_SAMPLE_CODE "Set ON to build the sample code" OFF )
if (NOT MAN_INSTALL_DIR)
diff --git a/www/tidy-html5/files/patch-test_testone.sh b/www/tidy-html5/files/patch-test_testone.sh
new file mode 100644
index 000000000000..8f3613788b1e
--- /dev/null
+++ b/www/tidy-html5/files/patch-test_testone.sh
@@ -0,0 +1,11 @@
+--- test/testone.sh.orig 2015-06-30 18:06:02 UTC
++++ test/testone.sh
+@@ -19,7 +19,7 @@ set +f
+ TESTNO=$1
+ EXPECTED=$2
+ #TIDY=../bin/tidy
+-TIDY=../build/cmake/tidy5
++TIDY=../build/cmake/tidy
+ if [ ! -f "$TIDY" ]; then
+ echo "$BN: Can NOT locate binary '$TIDY'!"
+ echo "$BN: Fix me with the correct location of the binary to run."
diff --git a/www/tidy-html5/pkg-plist b/www/tidy-html5/pkg-plist
index a48f61d26131..c7799285b0a0 100644
--- a/www/tidy-html5/pkg-plist
+++ b/www/tidy-html5/pkg-plist
@@ -1,10 +1,10 @@
bin/tidy5
-include/buffio.h
-include/platform.h
include/tidy.h
+include/tidybuffio.h
include/tidyenum.h
-lib/libtidy5s.a
+include/tidyplatform.h
lib/libtidy5.so
-lib/libtidy5.so.4
-lib/libtidy5.so.%%VER%%
-man/man1/tidy5.1.gz
+lib/libtidy.so.5
+lib/libtidy.so.%%VER%%
+lib/libtidys.a
+man/man1/tidy.1.gz