aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2016-05-10 18:37:41 +0800
committerdemon <demon@FreeBSD.org>2016-05-10 18:37:41 +0800
commitcb229dd3d2e968488f03d3232df0badf24115951 (patch)
treecaae8cc24ed826023be7315bcdbd6c8cb46ec824 /www
parentc9cbfb8cddc32ec12671d84d2624454526c1afe2 (diff)
downloadfreebsd-ports-gnome-cb229dd3d2e968488f03d3232df0badf24115951.tar.gz
freebsd-ports-gnome-cb229dd3d2e968488f03d3232df0badf24115951.tar.zst
freebsd-ports-gnome-cb229dd3d2e968488f03d3232df0badf24115951.zip
Update to version 2.0.13.
Diffstat (limited to 'www')
-rw-r--r--www/uwsgi/Makefile3
-rw-r--r--www/uwsgi/distinfo4
-rw-r--r--www/uwsgi/files/patch-2483e64.diff61
3 files changed, 3 insertions, 65 deletions
diff --git a/www/uwsgi/Makefile b/www/uwsgi/Makefile
index 1b62694944d7..03017f762038 100644
--- a/www/uwsgi/Makefile
+++ b/www/uwsgi/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= uwsgi
-PORTVERSION= 2.0.12
-PORTREVISION= 1
+PORTVERSION= 2.0.13
CATEGORIES= www python
MASTER_SITES= http://projects.unbit.it/downloads/
diff --git a/www/uwsgi/distinfo b/www/uwsgi/distinfo
index 2574ac3dbd36..d57d812c5d70 100644
--- a/www/uwsgi/distinfo
+++ b/www/uwsgi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (uwsgi-2.0.12.tar.gz) = 306b51db97648d6d23bb7eacd76e5a413434575f220dac1de231c8c26d33e409
-SIZE (uwsgi-2.0.12.tar.gz) = 784048
+SHA256 (uwsgi-2.0.13.tar.gz) = 038ba9c21ad71ab02a5b966b95ee8627af0aa4966e066865f7063a0ab1c0305e
+SIZE (uwsgi-2.0.13.tar.gz) = 784960
diff --git a/www/uwsgi/files/patch-2483e64.diff b/www/uwsgi/files/patch-2483e64.diff
deleted file mode 100644
index c434e2eee9c5..000000000000
--- a/www/uwsgi/files/patch-2483e64.diff
+++ /dev/null
@@ -1,61 +0,0 @@
-commit 2483e64e6dd504af5eefd4da94fc57c0f83b2563
-Author: Joerg Sonnenberger <joerg@NetBSD.org>
-Date: Wed Jan 13 17:00:53 2016 +0100
-
- plugins: properly update loop indexes once
-
- Fix clang warning about changing the loop variable in both loop
- body and header
-
-diff --git plugins/cgi/cgi_plugin.c plugins/cgi/cgi_plugin.c
-index e4fe6e6..340886a 100644
---- plugins/cgi/cgi_plugin.c
-+++ plugins/cgi/cgi_plugin.c
-@@ -763,12 +763,11 @@ clear2:
- }
-
- // fill cgi env
-- for(i=0;i<wsgi_req->var_cnt;i++) {
-+ for(i=0;i<wsgi_req->var_cnt;i+=2) {
- // no need to free the putenv() memory
- if (putenv(uwsgi_concat3n(wsgi_req->hvec[i].iov_base, wsgi_req->hvec[i].iov_len, "=", 1, wsgi_req->hvec[i+1].iov_base, wsgi_req->hvec[i+1].iov_len))) {
- uwsgi_error("putenv()");
- }
-- i++;
- }
-
-
-diff --git plugins/gccgo/gccgo_plugin.c plugins/gccgo/gccgo_plugin.c
-index 09cfd69..98d8f71 100644
---- plugins/gccgo/gccgo_plugin.c
-+++ plugins/gccgo/gccgo_plugin.c
-@@ -233,9 +233,8 @@ static int uwsgi_gccgo_request(struct wsgi_request *wsgi_req) {
-
- wsgi_req->async_environ = uwsgigo_env(wsgi_req);
- int i;
-- for(i=0;i<wsgi_req->var_cnt;i++) {
-+ for(i=0;i<wsgi_req->var_cnt;i+=2) {
- uwsgigo_env_add(wsgi_req->async_environ, wsgi_req->hvec[i].iov_base, wsgi_req->hvec[i].iov_len, wsgi_req->hvec[i+1].iov_base, wsgi_req->hvec[i+1].iov_len);
-- i++;
- }
- uwsgigo_request(wsgi_req->async_environ, wsgi_req);
- end:
-diff --git plugins/jwsgi/jwsgi_plugin.c plugins/jwsgi/jwsgi_plugin.c
-index 8cdac16..3b98632 100644
---- plugins/jwsgi/jwsgi_plugin.c
-+++ plugins/jwsgi/jwsgi_plugin.c
-@@ -71,13 +71,12 @@ static int uwsgi_jwsgi_request(struct wsgi_request *wsgi_req) {
- if (!hm) return -1;
-
- int i;
-- for(i=0;i<wsgi_req->var_cnt;i++) {
-+ for(i=0;i<wsgi_req->var_cnt;i+=2) {
- char *hk = wsgi_req->hvec[i].iov_base;
- uint16_t hk_l = wsgi_req->hvec[i].iov_len;
- char *hv = wsgi_req->hvec[i+1].iov_base;
- uint16_t hv_l = wsgi_req->hvec[i+1].iov_len;
- if (uwsgi_jwsgi_add_request_item(hm, hk, hk_l, hv, hv_l)) goto end;
-- i++;
- }
-
- if (uwsgi_jwsgi_add_request_input(hm, "jwsgi.input", 11)) goto end;