aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2019-09-11 19:04:07 +0800
committerkoobs <koobs@FreeBSD.org>2019-09-11 19:04:07 +0800
commitcbd38b01321dce117d6acd9e9606f8e450de05fe (patch)
tree846252a67f8c91c2468625069d2393110b3e44bc /www
parent7c3be71f46cca0258d679f36b9eee2a636dac1d7 (diff)
downloadfreebsd-ports-gnome-cbd38b01321dce117d6acd9e9606f8e450de05fe.tar.gz
freebsd-ports-gnome-cbd38b01321dce117d6acd9e9606f8e450de05fe.tar.zst
freebsd-ports-gnome-cbd38b01321dce117d6acd9e9606f8e450de05fe.zip
www/py-soupsieve: Add missing dependency
soupsieve depends on backports.functools_lru_cache [1] on Python versions < 3, add the dependency accordingly. While I'm here: - Add TEST_DEPENDS and test target to improve future QA Note: soupsieve 'requires' [2] beautifulsoup4, but beautifulsoup4 depends on soupsieve via install_requires, causing a technical circular dependency, which is why soupsieve doesn't seem to explicitly install_requires on it ... anymore [3]. This seems bizzare. [1] requirements/project.txt: backports.functools_lru_cache ; python_version < '3' [2] https://github.com/facelessuser/soupsieve#installation [3] https://github.com/facelessuser/soupsieve/commit/9a792216ea1ffce018c7968105540c08b82b96db QA: 624 passed, 2 skipped, 6 warnings in 35.70 seconds PR: 240490 Reported by: jbeich Approved by: portmgr (blanket: missing dependencies, ports compliance) MFH: 2019Q3 (blanket(s): run-time bugfix)
Diffstat (limited to 'www')
-rw-r--r--www/py-soupsieve/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/www/py-soupsieve/Makefile b/www/py-soupsieve/Makefile
index a0828d5709cc..fa2fee055062 100644
--- a/www/py-soupsieve/Makefile
+++ b/www/py-soupsieve/Makefile
@@ -2,6 +2,7 @@
PORTNAME= soupsieve
PORTVERSION= 1.9
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,8 +13,23 @@ COMMENT= CSS4 selector implementation for BeautifulSoup
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}html5lib>0:www/py-html5lib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}beautifulsoup>4:www/py-beautifulsoup@${PY_FLAVOR}
+
USES= python
USE_PYTHON= autoplist concurrent distutils
+
NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VER} < 3
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.functools_lru_cache>0:devel/py-backports.functools_lru_cache@${PY_FLAVOR}
+.endif
+
+do-test:
+ cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs
+
+.include <bsd.port.post.mk>