aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-05-25 13:19:00 +0800
committermiwi <miwi@FreeBSD.org>2014-05-25 13:19:00 +0800
commitcf22b6019062917a5e8147e95ff46a49e29ee5c0 (patch)
tree34e2472c5215cf9457826563a24e6fabcd2d8933 /www
parent1d468cf14604d30fbda3299bf6c6b9db27dd8b52 (diff)
downloadfreebsd-ports-gnome-cf22b6019062917a5e8147e95ff46a49e29ee5c0.tar.gz
freebsd-ports-gnome-cf22b6019062917a5e8147e95ff46a49e29ee5c0.tar.zst
freebsd-ports-gnome-cf22b6019062917a5e8147e95ff46a49e29ee5c0.zip
- Stage support
PR: 189913 Submitted by: Joseph Benden <joe@thrallingpenguin.com>
Diffstat (limited to 'www')
-rw-r--r--www/smarty2/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/www/smarty2/Makefile b/www/smarty2/Makefile
index a8cfc2d775fb..fbc1c96dbaf4 100644
--- a/www/smarty2/Makefile
+++ b/www/smarty2/Makefile
@@ -19,7 +19,6 @@ WRKSRC= ${WRKDIR}/Smarty-${PORTVERSION}
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
@@ -34,21 +33,21 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
do-install:
- @${MKDIR} ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
.for f in Config_File.class.php Smarty.class.php Smarty_Compiler.class.php debug.tpl
- @${INSTALL_DATA} ${WRKSRC}/libs/$f ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/libs/$f ${STAGEDIR}${DATADIR}
.endfor
- @${MKDIR} ${DATADIR}/internals
- @${INSTALL_DATA} ${WRKSRC}/libs/internals/* ${DATADIR}/internals
- @${MKDIR} ${DATADIR}/plugins
- @${INSTALL_DATA} ${WRKSRC}/libs/plugins/* ${DATADIR}/plugins
+ @${MKDIR} ${STAGEDIR}${DATADIR}/internals
+ @${INSTALL_DATA} ${WRKSRC}/libs/internals/* ${STAGEDIR}${DATADIR}/internals
+ @${MKDIR} ${STAGEDIR}${DATADIR}/plugins
+ @${INSTALL_DATA} ${WRKSRC}/libs/plugins/* ${STAGEDIR}${DATADIR}/plugins
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in BUGS FAQ INSTALL NEWS README
- @${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/$f ${STAGEDIR}${DOCSDIR}
.endfor
- @${MKDIR} ${DOCSDIR}/manual
- @cd ${WRKDIR}/manual-en && ${FIND} . | ${CPIO} --quiet -dumpR ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}/manual
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/manual
+ @cd ${WRKDIR}/manual-en && ${FIND} . | ${CPIO} --quiet -dumpR ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR}/manual
.endif
post-install: