aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-02-19 00:23:54 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-02-19 00:23:54 +0800
commitd091acf15a2d54f37c1fd8a99aa970b53053c9b9 (patch)
tree6ff9d24041d05586f0690995748a35eddd33e228 /www
parent2de54b565bb7a7cec8693a443890ae3ceabfe9ca (diff)
downloadfreebsd-ports-gnome-d091acf15a2d54f37c1fd8a99aa970b53053c9b9.tar.gz
freebsd-ports-gnome-d091acf15a2d54f37c1fd8a99aa970b53053c9b9.tar.zst
freebsd-ports-gnome-d091acf15a2d54f37c1fd8a99aa970b53053c9b9.zip
- Fix runtime when DEFAULT_VERSIONS=python=3.*
- Add missing dependency on USES=python:2 (required by gyp) - Pet portlint: use @(owner,group,mode) syntax instead of CHMOD - Bump PORTREVISION for dependency and package change
Diffstat (limited to 'www')
-rw-r--r--www/npm/Makefile7
-rw-r--r--www/npm/pkg-plist2
2 files changed, 5 insertions, 4 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index b2747b793650..4b44f4bb9c50 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= npm
PORTVERSION= 2.2.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
@@ -17,7 +18,7 @@ NODE_DEVEL_DESC=Use www/node-devel instead of www/node
MAKE_ARGS= npm_config_prefix=${STAGEDIR}${PREFIX}
NO_BUILD= yes
REINPLACE_ARGS= -i ''
-USES= cpe tar:xz
+USES= cpe python:2 tar:xz
MANPREFIX= ${PREFIX}/lib/node_modules/npm
@@ -29,11 +30,11 @@ NODE_DEVEL_RUN_DEPENDS_OFF= node>=0.8.0:${PORTSDIR}/www/node
post-patch:
@${REINPLACE_CMD} -e 's|node cli.js|& --cache ${WRKDIR}/.cache|' ${WRKSRC}/Makefile
- @${ECHO_CMD} 'MANPATH ${MANPREFIX}/man' > ${WRKDIR}/npm.conf
+ @${ECHO_CMD} 'MANPATH ${PREFIX}/lib/node_modules/npm/man' > ${WRKDIR}/npm.conf
+ @${REINPLACE_CMD} -e 's|exec python|exec ${PYTHON_CMD}|' ${WRKSRC}/node_modules/node-gyp/gyp/gyp
post-install:
${INSTALL_DATA} ${WRKDIR}/npm.conf ${STAGEDIR}${PREFIX}/etc/man.d/npm.conf
- ${CHMOD} +x ${STAGEDIR}${PREFIX}/lib/node_modules/npm/bin/node-gyp-bin/node-gyp
# maintainer section:
# require: bash, git, gmake, perl, node
diff --git a/www/npm/pkg-plist b/www/npm/pkg-plist
index 2925d7caa081..938c825c9d65 100644
--- a/www/npm/pkg-plist
+++ b/www/npm/pkg-plist
@@ -9,7 +9,7 @@ lib/node_modules/npm/CONTRIBUTING.md
lib/node_modules/npm/LICENSE
lib/node_modules/npm/Makefile
lib/node_modules/npm/README.md
-lib/node_modules/npm/bin/node-gyp-bin/node-gyp
+@(,,755) lib/node_modules/npm/bin/node-gyp-bin/node-gyp
lib/node_modules/npm/bin/node-gyp-bin/node-gyp.cmd
lib/node_modules/npm/bin/npm
lib/node_modules/npm/bin/npm-cli.js