aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2013-08-20 00:04:22 +0800
committerzi <zi@FreeBSD.org>2013-08-20 00:04:22 +0800
commitd2d7b24823b95655cce4e8f3760cc42b70b4bc3a (patch)
treebea2d9df6129efa9d439edfc6c5829801b63c01d /www
parent0a5149ca25c15a6495f270b479dab46b0595d7be (diff)
downloadfreebsd-ports-gnome-d2d7b24823b95655cce4e8f3760cc42b70b4bc3a.tar.gz
freebsd-ports-gnome-d2d7b24823b95655cce4e8f3760cc42b70b4bc3a.tar.zst
freebsd-ports-gnome-d2d7b24823b95655cce4e8f3760cc42b70b4bc3a.zip
- Enable MYSQL2 support as an OPTION
Diffstat (limited to 'www')
-rw-r--r--www/redmine/Makefile11
-rw-r--r--www/redmine/files/extra-patch-Gemfile19
2 files changed, 28 insertions, 2 deletions
diff --git a/www/redmine/Makefile b/www/redmine/Makefile
index 3c86aa4a3b72..6a0f503bb0ab 100644
--- a/www/redmine/Makefile
+++ b/www/redmine/Makefile
@@ -26,14 +26,15 @@ USE_RAKE= yes
NO_BUILD= yes
SUB_LIST+= RUBY_NAME=${RUBY_NAME}
-OPTIONS_DEFINE= MYSQL POSTGRESQL RMAGIC WWWSERVER LDAP
-OPTIONS_DEFAULT=MYSQL RMAGIC WWWSERVER THIN
+OPTIONS_DEFINE= MYSQL MYSQL2 POSTGRESQL RMAGIC WWWSERVER LDAP
+OPTIONS_DEFAULT=MYSQL2 RMAGIC WWWSERVER THIN
OPTIONS_SINGLE= WWWSERVER
OPTIONS_SINGLE_WWWSERVER= THIN PASSENGER
POSTGRESQL_DESC=Enable PostgreSQL support
RMAGIC_DESC= Enable Gantt charts support
THIN_DESC= Use Thin WEB server
PASSENGER_DESC= Use Apache/Nginx WEB server
+MYSQL2_DESC= MySQL database support (via mysql2 rubygem)
NO_OPTIONS_SORT=yes
.include <bsd.port.pre.mk>
@@ -42,12 +43,18 @@ NO_OPTIONS_SORT=yes
RUN_DEPENDS+= rubygem-mysql>=2.8.1:${PORTSDIR}/databases/rubygem-mysql
.endif
+.if ${PORT_OPTIONS:MMYSQL2}
+RUN_DEPENDS+= rubygem-mysql2>=0:${PORTSDIR}/databases/rubygem-mysql2
+.endif
+
.if ${PORT_OPTIONS:MPOSTGRESQL}
RUN_DEPENDS+= rubygem-pg>=0:${PORTSDIR}/databases/rubygem-pg
.endif
.if ${PORT_OPTIONS:MRMAGIC}
RUN_DEPENDS+= rubygem-rmagick>=2.0.0:${PORTSDIR}/graphics/rubygem-rmagick
+.else
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Gemfile
.endif
.if ${PORT_OPTIONS:MWWWSERVER}
diff --git a/www/redmine/files/extra-patch-Gemfile b/www/redmine/files/extra-patch-Gemfile
new file mode 100644
index 000000000000..1f3ded2ccd18
--- /dev/null
+++ b/www/redmine/files/extra-patch-Gemfile
@@ -0,0 +1,19 @@
+--- ./Gemfile.orig 2013-07-30 12:49:03.000000000 -0400
++++ ./Gemfile 2013-07-30 12:49:13.000000000 -0400
+@@ -18,16 +18,6 @@
+ gem "rack-openid"
+ end
+
+-# Optional gem for exporting the gantt to a PNG file, not supported with jruby
+-platforms :mri, :mingw do
+- group :rmagick do
+- # RMagick 2 supports ruby 1.9
+- # RMagick 1 would be fine for ruby 1.8 but Bundler does not support
+- # different requirements for the same gem on different platforms
+- gem "rmagick", ">= 2.0.0"
+- end
+-end
+-
+ platforms :jruby do
+ # jruby-openssl is bundled with JRuby 1.7.0
+ gem "jruby-openssl" if Object.const_defined?(:JRUBY_VERSION) && JRUBY_VERSION < '1.7.0'