aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-06-11 22:38:55 +0800
committerrafan <rafan@FreeBSD.org>2007-06-11 22:38:55 +0800
commitd2f4618a7112b04bc6c29159ed3eb702289fe0be (patch)
treef0bafd797275c643ce24c5a8439b87f601c9b3da /www
parent56037dec09fadffda1fb1d20dd8eaa8d33ed91be (diff)
downloadfreebsd-ports-gnome-d2f4618a7112b04bc6c29159ed3eb702289fe0be.tar.gz
freebsd-ports-gnome-d2f4618a7112b04bc6c29159ed3eb702289fe0be.tar.zst
freebsd-ports-gnome-d2f4618a7112b04bc6c29159ed3eb702289fe0be.zip
- Don't install CVS directory, backup files, .orig files
- Correct configuration file path - Add '-d' to pax to make it not traverse directories - Style cleanup - Bump PORTREVISION PR: ports/113480 Submitted by: Jan Srzednicki <w at wrzask.pl> Approved by: Bartek Rutkowski <r at robakdesign.com>
Diffstat (limited to 'www')
-rw-r--r--www/hastymail/Makefile28
-rw-r--r--www/hastymail/files/pkg-message.in11
-rw-r--r--www/hastymail/patch-lib-constant.php11
-rw-r--r--www/hastymail2-devel/Makefile28
-rw-r--r--www/hastymail2-devel/files/pkg-message.in11
-rw-r--r--www/hastymail2-devel/patch-lib-constant.php11
-rw-r--r--www/hastymail2/Makefile28
-rw-r--r--www/hastymail2/files/pkg-message.in11
-rw-r--r--www/hastymail2/patch-lib-constant.php11
9 files changed, 114 insertions, 36 deletions
diff --git a/www/hastymail/Makefile b/www/hastymail/Makefile
index 5577b05d96ad..956d5913c894 100644
--- a/www/hastymail/Makefile
+++ b/www/hastymail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hastymail
PORTVERSION= 1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= hastymail
@@ -27,16 +27,30 @@ USE_PHP= session imap
.include <bsd.port.pre.mk>
+# Don't install automatically CVS directories, patched files and the default config file.
+FIND_SKIP_OPTS= -not -name hastymail.conf-example -not -name '*.orig' \
+ -not -name '*.bak' -not -path '*/CVS/*' -not -name CVS
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," \
+ ${WRKSRC}/lib/constant.php
+
pre-install:
- @${FIND} -s -d ${WRKSRC}/ -type f | ${SED} "s?${WRKSRC}?${INSTALL_DIR}?g" >${PLIST}
- @${FIND} -s -d ${WRKSRC}/ -type d | ${SED} "s?${WRKSRC}?@dirrm ${INSTALL_DIR}?g" >> ${PLIST}
+ @${FIND} -s -d ${WRKSRC}/ -type f ${FIND_SKIP_OPTS} | \
+ ${SED} "s?${WRKSRC}?${INSTALL_DIR}?g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC}/ -type d ${FIND_SKIP_OPTS} | \
+ ${SED} "s?${WRKSRC}?@dirrm ${INSTALL_DIR}?g" >> ${PLIST}
+ @${ECHO_CMD} etc/hastymail.conf.sample >> ${PLIST}
do-install:
- @${MKDIR} ${PREFIX}/${INSTALL_DIR}
- @cd ${WRKSRC} && ${FIND} . | ${PAX} -rw ${PREFIX}/${INSTALL_DIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${INSTALL_DIR}
+ @${MKDIR} ${PREFIX}/${INSTALL_DIR}
+ @cd ${WRKSRC} && ${FIND} . ${FIND_SKIP_OPTS} | \
+ ${PAX} -rwd ${PREFIX}/${INSTALL_DIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${INSTALL_DIR}
+ @${INSTALL_DATA} ${WRKSRC}/hastymail.conf-example \
+ ${PREFIX}/etc/hastymail.conf.sample
post-install:
- @${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/hastymail/files/pkg-message.in b/www/hastymail/files/pkg-message.in
index d4bbccf29d59..dbdd5916852a 100644
--- a/www/hastymail/files/pkg-message.in
+++ b/www/hastymail/files/pkg-message.in
@@ -1,12 +1,13 @@
******************************************************
You have successfully installed Hastymail webmail client.
-Dont forget to move config file to proper directory and
-to change that variable in hastymail/lib/constant.php
+Don't forget to edit your own config file. A sample config
+has been installed in:
-$config_file = '/etc/hastymail.conf';
+%%PREFIX%%/etc/hastymail.conf.sample
-as needed. After that, follow the instructions in INSTALL
-file to configure Hastymail finally.
+The proper config file path is:
+
+%%PREFIX%%/etc/hastymail.conf
******************************************************
diff --git a/www/hastymail/patch-lib-constant.php b/www/hastymail/patch-lib-constant.php
new file mode 100644
index 000000000000..d9b680408222
--- /dev/null
+++ b/www/hastymail/patch-lib-constant.php
@@ -0,0 +1,11 @@
+--- lib/constant.php.orig Fri Jun 8 15:15:54 2007
++++ lib/constant.php Fri Jun 8 15:16:10 2007
+@@ -24,7 +24,7 @@
+ */
+
+ /* absolute path to the configuration file */
+-$config_file = '/etc/hastymail.conf';
++$config_file = '%%PREFIX%%/etc/hastymail.conf';
+
+ /* hastymail version */
+ $version = '1.5';
diff --git a/www/hastymail2-devel/Makefile b/www/hastymail2-devel/Makefile
index 5577b05d96ad..956d5913c894 100644
--- a/www/hastymail2-devel/Makefile
+++ b/www/hastymail2-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hastymail
PORTVERSION= 1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= hastymail
@@ -27,16 +27,30 @@ USE_PHP= session imap
.include <bsd.port.pre.mk>
+# Don't install automatically CVS directories, patched files and the default config file.
+FIND_SKIP_OPTS= -not -name hastymail.conf-example -not -name '*.orig' \
+ -not -name '*.bak' -not -path '*/CVS/*' -not -name CVS
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," \
+ ${WRKSRC}/lib/constant.php
+
pre-install:
- @${FIND} -s -d ${WRKSRC}/ -type f | ${SED} "s?${WRKSRC}?${INSTALL_DIR}?g" >${PLIST}
- @${FIND} -s -d ${WRKSRC}/ -type d | ${SED} "s?${WRKSRC}?@dirrm ${INSTALL_DIR}?g" >> ${PLIST}
+ @${FIND} -s -d ${WRKSRC}/ -type f ${FIND_SKIP_OPTS} | \
+ ${SED} "s?${WRKSRC}?${INSTALL_DIR}?g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC}/ -type d ${FIND_SKIP_OPTS} | \
+ ${SED} "s?${WRKSRC}?@dirrm ${INSTALL_DIR}?g" >> ${PLIST}
+ @${ECHO_CMD} etc/hastymail.conf.sample >> ${PLIST}
do-install:
- @${MKDIR} ${PREFIX}/${INSTALL_DIR}
- @cd ${WRKSRC} && ${FIND} . | ${PAX} -rw ${PREFIX}/${INSTALL_DIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${INSTALL_DIR}
+ @${MKDIR} ${PREFIX}/${INSTALL_DIR}
+ @cd ${WRKSRC} && ${FIND} . ${FIND_SKIP_OPTS} | \
+ ${PAX} -rwd ${PREFIX}/${INSTALL_DIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${INSTALL_DIR}
+ @${INSTALL_DATA} ${WRKSRC}/hastymail.conf-example \
+ ${PREFIX}/etc/hastymail.conf.sample
post-install:
- @${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/hastymail2-devel/files/pkg-message.in b/www/hastymail2-devel/files/pkg-message.in
index d4bbccf29d59..dbdd5916852a 100644
--- a/www/hastymail2-devel/files/pkg-message.in
+++ b/www/hastymail2-devel/files/pkg-message.in
@@ -1,12 +1,13 @@
******************************************************
You have successfully installed Hastymail webmail client.
-Dont forget to move config file to proper directory and
-to change that variable in hastymail/lib/constant.php
+Don't forget to edit your own config file. A sample config
+has been installed in:
-$config_file = '/etc/hastymail.conf';
+%%PREFIX%%/etc/hastymail.conf.sample
-as needed. After that, follow the instructions in INSTALL
-file to configure Hastymail finally.
+The proper config file path is:
+
+%%PREFIX%%/etc/hastymail.conf
******************************************************
diff --git a/www/hastymail2-devel/patch-lib-constant.php b/www/hastymail2-devel/patch-lib-constant.php
new file mode 100644
index 000000000000..d9b680408222
--- /dev/null
+++ b/www/hastymail2-devel/patch-lib-constant.php
@@ -0,0 +1,11 @@
+--- lib/constant.php.orig Fri Jun 8 15:15:54 2007
++++ lib/constant.php Fri Jun 8 15:16:10 2007
+@@ -24,7 +24,7 @@
+ */
+
+ /* absolute path to the configuration file */
+-$config_file = '/etc/hastymail.conf';
++$config_file = '%%PREFIX%%/etc/hastymail.conf';
+
+ /* hastymail version */
+ $version = '1.5';
diff --git a/www/hastymail2/Makefile b/www/hastymail2/Makefile
index 5577b05d96ad..956d5913c894 100644
--- a/www/hastymail2/Makefile
+++ b/www/hastymail2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hastymail
PORTVERSION= 1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= hastymail
@@ -27,16 +27,30 @@ USE_PHP= session imap
.include <bsd.port.pre.mk>
+# Don't install automatically CVS directories, patched files and the default config file.
+FIND_SKIP_OPTS= -not -name hastymail.conf-example -not -name '*.orig' \
+ -not -name '*.bak' -not -path '*/CVS/*' -not -name CVS
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," \
+ ${WRKSRC}/lib/constant.php
+
pre-install:
- @${FIND} -s -d ${WRKSRC}/ -type f | ${SED} "s?${WRKSRC}?${INSTALL_DIR}?g" >${PLIST}
- @${FIND} -s -d ${WRKSRC}/ -type d | ${SED} "s?${WRKSRC}?@dirrm ${INSTALL_DIR}?g" >> ${PLIST}
+ @${FIND} -s -d ${WRKSRC}/ -type f ${FIND_SKIP_OPTS} | \
+ ${SED} "s?${WRKSRC}?${INSTALL_DIR}?g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC}/ -type d ${FIND_SKIP_OPTS} | \
+ ${SED} "s?${WRKSRC}?@dirrm ${INSTALL_DIR}?g" >> ${PLIST}
+ @${ECHO_CMD} etc/hastymail.conf.sample >> ${PLIST}
do-install:
- @${MKDIR} ${PREFIX}/${INSTALL_DIR}
- @cd ${WRKSRC} && ${FIND} . | ${PAX} -rw ${PREFIX}/${INSTALL_DIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${INSTALL_DIR}
+ @${MKDIR} ${PREFIX}/${INSTALL_DIR}
+ @cd ${WRKSRC} && ${FIND} . ${FIND_SKIP_OPTS} | \
+ ${PAX} -rwd ${PREFIX}/${INSTALL_DIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${INSTALL_DIR}
+ @${INSTALL_DATA} ${WRKSRC}/hastymail.conf-example \
+ ${PREFIX}/etc/hastymail.conf.sample
post-install:
- @${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/hastymail2/files/pkg-message.in b/www/hastymail2/files/pkg-message.in
index d4bbccf29d59..dbdd5916852a 100644
--- a/www/hastymail2/files/pkg-message.in
+++ b/www/hastymail2/files/pkg-message.in
@@ -1,12 +1,13 @@
******************************************************
You have successfully installed Hastymail webmail client.
-Dont forget to move config file to proper directory and
-to change that variable in hastymail/lib/constant.php
+Don't forget to edit your own config file. A sample config
+has been installed in:
-$config_file = '/etc/hastymail.conf';
+%%PREFIX%%/etc/hastymail.conf.sample
-as needed. After that, follow the instructions in INSTALL
-file to configure Hastymail finally.
+The proper config file path is:
+
+%%PREFIX%%/etc/hastymail.conf
******************************************************
diff --git a/www/hastymail2/patch-lib-constant.php b/www/hastymail2/patch-lib-constant.php
new file mode 100644
index 000000000000..d9b680408222
--- /dev/null
+++ b/www/hastymail2/patch-lib-constant.php
@@ -0,0 +1,11 @@
+--- lib/constant.php.orig Fri Jun 8 15:15:54 2007
++++ lib/constant.php Fri Jun 8 15:16:10 2007
+@@ -24,7 +24,7 @@
+ */
+
+ /* absolute path to the configuration file */
+-$config_file = '/etc/hastymail.conf';
++$config_file = '%%PREFIX%%/etc/hastymail.conf';
+
+ /* hastymail version */
+ $version = '1.5';