aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2014-09-22 18:40:00 +0800
committerxmj <xmj@FreeBSD.org>2014-09-22 18:40:00 +0800
commitd39787ca07e42b7a91488f45cc6c58333ae10780 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /www
parent143e62b0f3ebf9f9c709e4c068013418325fc64c (diff)
downloadfreebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.tar.gz
freebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.tar.zst
freebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.zip
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile2
-rw-r--r--www/linux-c6-flashplugin11/Makefile54
-rw-r--r--www/linux-c6-flashplugin11/distinfo4
-rw-r--r--www/linux-c6-flashplugin11/pkg-descr10
-rw-r--r--www/linux-c6-flashplugin11/pkg-message7
-rw-r--r--www/linux-c6-flashplugin11/pkg-plist26
-rw-r--r--www/linux-c6-qt47-webkit/Makefile29
-rw-r--r--www/linux-c6-qt47-webkit/distinfo.i3862
-rw-r--r--www/linux-c6-qt47-webkit/pkg-descr5
-rw-r--r--www/linux-c6-qt47-webkit/pkg-plist9
-rw-r--r--www/linux-f10-flashplugin11/Makefile6
-rw-r--r--www/linux-seamonkey/Makefile.common10
-rw-r--r--www/nspluginwrapper/Makefile2
-rw-r--r--www/nspluginwrapper/files/patch-src__npw-config.c8
14 files changed, 162 insertions, 12 deletions
diff --git a/www/Makefile b/www/Makefile
index d9ba2ea99e94..6c7abb92cb07 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -376,6 +376,8 @@
SUBDIR += links
SUBDIR += links-hacked
SUBDIR += links1
+ SUBDIR += linux-c6-qt47-webkit
+ SUBDIR += linux-c6-flashplugin11
SUBDIR += linux-f10-flashplugin11
SUBDIR += linux-firefox
SUBDIR += linux-libgtkembedmoz
diff --git a/www/linux-c6-flashplugin11/Makefile b/www/linux-c6-flashplugin11/Makefile
new file mode 100644
index 000000000000..59cac98569f3
--- /dev/null
+++ b/www/linux-c6-flashplugin11/Makefile
@@ -0,0 +1,54 @@
+# Created by: Artyom Mirgorodskiy <artyom.mirgorodsky@gmail.com>
+# $FreeBSD$
+
+PORTNAME= flashplugin
+PORTVERSION= 11.2r202.400
+CATEGORIES= www multimedia linux
+MASTER_SITES= http://fpdownload.macromedia.com/get/flashplayer/pdc/${PORTVERSION:C/r/\./}/:plugin \
+ LOCAL/nox:suplib
+PKGNAMEPREFIX= linux-${USE_LINUX}-
+DISTFILES= install_flash_player_11_linux.i386.tar.gz:plugin \
+ linux-f10-flashsupport-9.0.1.i386.tar.gz:suplib
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= eadler@FreeBSD.org
+COMMENT= Adobe Flash Player NPAPI Plugin
+
+ONLY_FOR_ARCHS= amd64 i386
+USE_LINUX= c6
+USE_LINUX_APPS= openssl curl cyrus-sasl2 nspr nss gtk2 #-alsalib libssh2 openldap
+WANT_GNOME= yes
+
+RESTRICTED= Redistribution not allowed
+RESTRICTED_FILES= ${DISTFILES:Nlinux-f10-flashsupport*:C/:[^:]+$//}
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+USES= webplugin:linux
+WEBPLUGIN_FILES= libflashplayer.so
+
+OPTIONS_DEFINE= GNOME
+GNOME_DESC= include gnome support for .desktop file
+
+OPTIONS_SUB= yes
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGNOME}
+USES+= desktop-file-utils
+INSTALLS_ICONS= yes
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr|${PREFIX}|' -e '/^NotShowIn=KDE/d' ${WRKDIR}/usr/share/applications/flash-player-properties.desktop
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WEBPLUGIN_DIR} ${STAGEDIR}${LINUXBASE}/usr/lib
+ ${INSTALL_LIB} ${WRKDIR}/libflashplayer.so ${STAGEDIR}${WEBPLUGIN_DIR}
+ ${INSTALL_LIB} ${WRKDIR}/libflashsupport.so ${STAGEDIR}${LINUXBASE}/usr/lib
+ ${INSTALL_PROGRAM} ${WRKDIR}/usr/bin/flash-player-properties ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKDIR}/usr/share/applications/flash-player-properties.desktop ${STAGEDIR}${DESKTOPDIR}
+ (cd ${WRKDIR}/usr/share/icons && ${COPYTREE_SHARE} hicolor ${STAGEDIR}${PREFIX}/share/icons)
+
+.include <bsd.port.mk>
diff --git a/www/linux-c6-flashplugin11/distinfo b/www/linux-c6-flashplugin11/distinfo
new file mode 100644
index 000000000000..9f1746f265c4
--- /dev/null
+++ b/www/linux-c6-flashplugin11/distinfo
@@ -0,0 +1,4 @@
+SHA256 (flashplugin/11.2r202.400/install_flash_player_11_linux.i386.tar.gz) = d0ac17fa50069520e1aee59e3aa893ebec3cfdcecb4f81aba040662352fd6ef7
+SIZE (flashplugin/11.2r202.400/install_flash_player_11_linux.i386.tar.gz) = 6927109
+SHA256 (flashplugin/11.2r202.400/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 4a309b1a326bd2212cc72480628659e5a7fd61d9e0572cb7350c206f030955bf
+SIZE (flashplugin/11.2r202.400/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 3455
diff --git a/www/linux-c6-flashplugin11/pkg-descr b/www/linux-c6-flashplugin11/pkg-descr
new file mode 100644
index 000000000000..9c9dcd2de5d8
--- /dev/null
+++ b/www/linux-c6-flashplugin11/pkg-descr
@@ -0,0 +1,10 @@
+This is the official Flash Player from Adobe. This plugin enables
+you to see .swf and .spl files on the 'net from your Opera, Mozilla or
+Firefox sessions.
+
+Please see the Adobe home page for more information.
+
+FreeBSD Flash License Agreement:
+ http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/96374
+
+WWW: http://www.adobe.com/
diff --git a/www/linux-c6-flashplugin11/pkg-message b/www/linux-c6-flashplugin11/pkg-message
new file mode 100644
index 000000000000..98294fcb3e9b
--- /dev/null
+++ b/www/linux-c6-flashplugin11/pkg-message
@@ -0,0 +1,7 @@
+If this is your first time installing flash each user must run:
+
+ nspluginwrapper -v -a -i
+
+If you are updating flash each user must run:
+
+ nspluginwrapper -v -a -u
diff --git a/www/linux-c6-flashplugin11/pkg-plist b/www/linux-c6-flashplugin11/pkg-plist
new file mode 100644
index 000000000000..1d74fbb9615a
--- /dev/null
+++ b/www/linux-c6-flashplugin11/pkg-plist
@@ -0,0 +1,26 @@
+bin/flash-player-properties
+%%WEBPLUGIN_DIR%%/libflashplayer.so
+share/applications/flash-player-properties.desktop
+share/icons/hicolor/16x16/apps/flash-player-properties.png
+share/icons/hicolor/22x22/apps/flash-player-properties.png
+share/icons/hicolor/24x24/apps/flash-player-properties.png
+share/icons/hicolor/32x32/apps/flash-player-properties.png
+share/icons/hicolor/48x48/apps/flash-player-properties.png
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry %%WEBPLUGIN_DIR%%
+@cwd /compat/linux
+usr/lib/libflashsupport.so
+@dirrmtry usr/lib
+@dirrmtry usr
+@cwd %%RESETPREFIX%%
diff --git a/www/linux-c6-qt47-webkit/Makefile b/www/linux-c6-qt47-webkit/Makefile
new file mode 100644
index 000000000000..3011921e609b
--- /dev/null
+++ b/www/linux-c6-qt47-webkit/Makefile
@@ -0,0 +1,29 @@
+# Created by: Artyom Mirgorodskiy <artyom.mirgorodsky@gmail.com>
+# $FreeBSD$
+
+PORTNAME= qt47-webkit
+PORTVERSION= 4.7.2
+CATEGORIES= www linux
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= xmj
+PKGNAMEPREFIX= linux-${USE_LINUX}-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
+DIST_SUBDIR= rpm/${LINUX_RPM_ARCH}/centos/c5
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= RPM of QT4 (Linux CentOS 5)
+
+ONLY_FOR_ARCHS= i386 amd64
+RPMVERSION= 1_18.el5
+USE_LINUX= c6
+LINUX_RPM_ARCH= i386
+USE_LINUX_APPS= fontconfig png xorglibs sqlite3 qt47 qt47-x11
+
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 5
+USE_LDCONFIG= yes
+DESCR= ${.CURDIR}/../../www/webkit-gtk3/pkg-descr # contains no GTK references, reuse
+
+SRC_DISTFILES:= # unretrievable
+
+.include <bsd.port.mk>
diff --git a/www/linux-c6-qt47-webkit/distinfo.i386 b/www/linux-c6-qt47-webkit/distinfo.i386
new file mode 100644
index 000000000000..95cd9ec0bac3
--- /dev/null
+++ b/www/linux-c6-qt47-webkit/distinfo.i386
@@ -0,0 +1,2 @@
+SHA256 (rpm/i386/centos/c5/qt47-webkit-4.7.2-1_18.el5.i386.rpm) = de86590afcffa2016062bc891530f982445c44a9b599fe2c8a6310f72bcb3f54
+SIZE (rpm/i386/centos/c5/qt47-webkit-4.7.2-1_18.el5.i386.rpm) = 7233670
diff --git a/www/linux-c6-qt47-webkit/pkg-descr b/www/linux-c6-qt47-webkit/pkg-descr
new file mode 100644
index 000000000000..533dd2877349
--- /dev/null
+++ b/www/linux-c6-qt47-webkit/pkg-descr
@@ -0,0 +1,5 @@
+FIXME this file should have actual content.
+Please submit it.
+
+WWW: https://github.com/xmj/linux-ports/
+
diff --git a/www/linux-c6-qt47-webkit/pkg-plist b/www/linux-c6-qt47-webkit/pkg-plist
new file mode 100644
index 000000000000..b7d58b1927bb
--- /dev/null
+++ b/www/linux-c6-qt47-webkit/pkg-plist
@@ -0,0 +1,9 @@
+usr/lib/qt47/imports/QtWebKit/libqmlwebkitplugin.so
+usr/lib/qt47/libQtWebKit.so.4
+usr/lib/qt47/libQtWebKit.so.4.7
+usr/lib/qt47/libQtWebKit.so.4.7.2
+usr/lib/qt47/plugins/designer/libqwebview.so
+usr/lib/qt47/imports/QtWebKit/qmldir
+@dirrm usr/lib/qt47/imports/QtWebKit
+@dirrmtry usr/lib/qt47/plugins/designer
+@dirrmtry usr/lib/qt47/plugins
diff --git a/www/linux-f10-flashplugin11/Makefile b/www/linux-f10-flashplugin11/Makefile
index 97739828a176..caba4537b4f3 100644
--- a/www/linux-f10-flashplugin11/Makefile
+++ b/www/linux-f10-flashplugin11/Makefile
@@ -6,14 +6,14 @@ PORTVERSION= 11.2r202.400
CATEGORIES= www multimedia linux
MASTER_SITES= http://fpdownload.macromedia.com/get/flashplayer/pdc/${PORTVERSION:C/r/\./}/:plugin \
LOCAL/nox:suplib
-PKGNAMEPREFIX= linux-f10-
DISTFILES= install_flash_player_11_linux.i386.tar.gz:plugin \
linux-f10-flashsupport-9.0.1.i386.tar.gz:suplib
-DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= eadler@FreeBSD.org
COMMENT= Adobe Flash Player NPAPI Plugin
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
ONLY_FOR_ARCHS= amd64 i386
USE_LINUX= yes
USE_LINUX_APPS= openssl curl cyrus-sasl2 libssh2 nspr nss openldap gtk2
@@ -25,7 +25,7 @@ RESTRICTED_FILES= ${DISTFILES:Nlinux-f10-flashsupport*:C/:[^:]+$//}
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USES= webplugin:linux desktop-file-utils
+USES= webplugin:linux
WEBPLUGIN_FILES= libflashplayer.so
OPTIONS_DEFINE= GNOME
diff --git a/www/linux-seamonkey/Makefile.common b/www/linux-seamonkey/Makefile.common
index c64b49fc9f8a..b3536168c9b7 100644
--- a/www/linux-seamonkey/Makefile.common
+++ b/www/linux-seamonkey/Makefile.common
@@ -1,9 +1,9 @@
# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-
-.if defined(OVERRIDE_LINUX_NONBASE_PORTS) && \
- ${OVERRIDE_LINUX_NONBASE_PORTS} != "f10"
.undef WANT_GTK218
+.if defined(OVERRIDE_LINUX_NONBASE_PORTS) && \
+ ${OVERRIDE_LINUX_NONBASE_PORTS} == "f10"
+.def WANT_GTK218
.endif
CATEGORIES+= linux
@@ -29,8 +29,8 @@ ONLY_FOR_ARCHS= i386 amd64
APP_NAME= ${PKGBASE}
BIN_NAME?= ${PORTNAME}
USE_LINUX= yes
-USE_LINUX_APPS+=alsalib alsa-plugins-oss atk dbusglib dbuslibs \
- fontconfig gtk2 hicontheme pango
+USE_LINUX_APPS+= alsalib alsa-plugins-oss atk dbusglib dbuslibs \
+ fontconfig gtk2 hicontheme pango
WRKSRC?= ${WRKDIR}/${BIN_NAME}
FDIR= ${STAGEDIR}${PREFIX}/lib/${APP_NAME}
diff --git a/www/nspluginwrapper/Makefile b/www/nspluginwrapper/Makefile
index d073bf5fd4a3..2bfce9693938 100644
--- a/www/nspluginwrapper/Makefile
+++ b/www/nspluginwrapper/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nspluginwrapper
PORTVERSION= 1.4.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www linux emulators
MASTER_SITES= http://nspluginwrapper.org/download/ \
LOCAL/jkim \
diff --git a/www/nspluginwrapper/files/patch-src__npw-config.c b/www/nspluginwrapper/files/patch-src__npw-config.c
index 290fb487963b..aa3a1e34c3d3 100644
--- a/www/nspluginwrapper/files/patch-src__npw-config.c
+++ b/www/nspluginwrapper/files/patch-src__npw-config.c
@@ -1,5 +1,5 @@
---- src/npw-config.c.orig 2011-06-30 23:18:57.000000000 -0400
-+++ src/npw-config.c 2013-11-14 14:41:13.000000000 -0500
+--- ./src/npw-config.c.orig 2011-07-01 06:18:57.000000000 +0300
++++ ./src/npw-config.c 2014-03-28 07:33:35.829791175 +0200
@@ -133,8 +133,9 @@
#if defined(__FreeBSD__)
{
@@ -12,7 +12,7 @@
};
dirs = freebsd_dirs;
}
-@@ -232,11 +233,12 @@
+@@ -232,11 +233,14 @@
"/usr/lib32/nsbrowser/plugins", // XXX how unfortunate
"/usr/lib64/nsbrowser/plugins",
#if defined(__FreeBSD__)
@@ -25,6 +25,8 @@
+ "%%LOCALBASE%%/lib/firefox/plugins",
+ "%%LOCALBASE%%/lib/seamonkey/plugins",
+ "%%LOCALBASE%%/lib/browser_plugins/linux-f10-flashplugin",
++ "%%LOCALBASE%%/lib/browser_plugins/linux-c6-flashplugin",
++ "%%LOCALBASE%%/lib/browser_plugins/symlinks/linux-firefox",
+ "%%LOCALBASE%%/Adobe/Reader8/ENU/Adobe/Reader8/Browser/intellinux",
+ "%%LOCALBASE%%/Adobe/Reader9/ENU/Adobe/Reader9/Browser/intellinux",
#endif