aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2015-03-12 22:05:27 +0800
committervanilla <vanilla@FreeBSD.org>2015-03-12 22:05:27 +0800
commitd64f944c63cf4dc0f0a7b856dda6c7ab35d53047 (patch)
tree0075825d04b6f61bba1a24c8225db99acb754f06 /www
parentf9349825de80c67afdaa924b9b94e2e477de079a (diff)
downloadfreebsd-ports-gnome-d64f944c63cf4dc0f0a7b856dda6c7ab35d53047.tar.gz
freebsd-ports-gnome-d64f944c63cf4dc0f0a7b856dda6c7ab35d53047.tar.zst
freebsd-ports-gnome-d64f944c63cf4dc0f0a7b856dda6c7ab35d53047.zip
Add p5-Dancer2-Plugin-Path-Class 0.02, list a directory using
Path::Class. PR: 198539 Submitted by: Henk van Oers <hvo.pm@xs4all.nl>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Dancer2-Plugin-Path-Class/Makefile24
-rw-r--r--www/p5-Dancer2-Plugin-Path-Class/distinfo2
-rw-r--r--www/p5-Dancer2-Plugin-Path-Class/pkg-descr11
-rw-r--r--www/p5-Dancer2-Plugin-Path-Class/pkg-plist2
5 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f43f8d95f337..f6b5df142806 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -824,6 +824,7 @@
SUBDIR += p5-Dancer2
SUBDIR += p5-Dancer2-Plugin-Ajax
SUBDIR += p5-Dancer2-Plugin-Deferred
+ SUBDIR += p5-Dancer2-Plugin-Path-Class
SUBDIR += p5-Data-TreeDumper-Renderer-DHTML
SUBDIR += p5-Data-Validate-URI
SUBDIR += p5-Emplacken
diff --git a/www/p5-Dancer2-Plugin-Path-Class/Makefile b/www/p5-Dancer2-Plugin-Path-Class/Makefile
new file mode 100644
index 000000000000..91ab0134e964
--- /dev/null
+++ b/www/p5-Dancer2-Plugin-Path-Class/Makefile
@@ -0,0 +1,24 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= Dancer2-Plugin-Path-Class
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hvo.pm@xs4all.nl
+COMMENT= List a directory using Path::Class
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Dancer2>=0.159002:${PORTSDIR}/www/p5-Dancer2 \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-Format-Human-Bytes>=0:${PORTSDIR}/converters/p5-Format-Human-Bytes
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer2-Plugin-Path-Class/distinfo b/www/p5-Dancer2-Plugin-Path-Class/distinfo
new file mode 100644
index 000000000000..201cc1c171f7
--- /dev/null
+++ b/www/p5-Dancer2-Plugin-Path-Class/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer2-Plugin-Path-Class-0.02.tar.gz) = d4579233c529ec419e7acf4e85bed747ca7d0f8c9afc8016ca0d33a9c9c2f2ff
+SIZE (Dancer2-Plugin-Path-Class-0.02.tar.gz) = 7001
diff --git a/www/p5-Dancer2-Plugin-Path-Class/pkg-descr b/www/p5-Dancer2-Plugin-Path-Class/pkg-descr
new file mode 100644
index 000000000000..083d0d25cf0d
--- /dev/null
+++ b/www/p5-Dancer2-Plugin-Path-Class/pkg-descr
@@ -0,0 +1,11 @@
+Dancer2::Plugin::Path::Class exports the keyword 'ls'
+returning a Path::Class object.
+
+The 'ls' keyword also sets some 'vars'.
+- ls_name: The basename of the path
+- ls_cdup: The parent of the request path
+- ls_dirs: A list of subdirectories if the path is a directory object
+- ls_files: A list of files or just one file if the path is a file object
+
+
+WWW: http://search.cpan.org/dist/Dancer2-Plugin-Path-Class/
diff --git a/www/p5-Dancer2-Plugin-Path-Class/pkg-plist b/www/p5-Dancer2-Plugin-Path-Class/pkg-plist
new file mode 100644
index 000000000000..8d8e8623b476
--- /dev/null
+++ b/www/p5-Dancer2-Plugin-Path-Class/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Dancer2/Plugin/Path/Class.pm
+%%PERL5_MAN3%%/Dancer2::Plugin::Path::Class.3.gz