aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-08-23 04:43:27 +0800
committermiwi <miwi@FreeBSD.org>2009-08-23 04:43:27 +0800
commitd65138f2767edb38a40cb53c92184b35c35f8d2f (patch)
treef4a58f52799a7d37973e447fa6f5b9aafe2ff2e3 /www
parent394159316bfcf1901ff2bd8ed2a8373c47788267 (diff)
downloadfreebsd-ports-gnome-d65138f2767edb38a40cb53c92184b35c35f8d2f.tar.gz
freebsd-ports-gnome-d65138f2767edb38a40cb53c92184b35c35f8d2f.tar.zst
freebsd-ports-gnome-d65138f2767edb38a40cb53c92184b35c35f8d2f.zip
This module protects Apache 2.x from the Slowloris HTTP DoS attack by
limiting the number of allowed connections. WWW: http://modules.apache.org/search.php?id=1783 PR: ports/138001 Submitted by: Aleksandar Pejic <alex at vts.su.ac.rs>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_antiloris/Makefile40
-rw-r--r--www/mod_antiloris/distinfo3
-rw-r--r--www/mod_antiloris/files/mod_antiloris.conf.in4
-rw-r--r--www/mod_antiloris/files/pkg-message.rules.in14
-rw-r--r--www/mod_antiloris/pkg-descr4
6 files changed, 66 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 66273b66caf1..6b257bc14713 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -398,6 +398,7 @@
SUBDIR += mod_access_referer
SUBDIR += mod_accesscookie
SUBDIR += mod_accounting
+ SUBDIR += mod_antiloris
SUBDIR += mod_auth_any
SUBDIR += mod_auth_cookie_mysql
SUBDIR += mod_auth_cookie_mysql2
diff --git a/www/mod_antiloris/Makefile b/www/mod_antiloris/Makefile
new file mode 100644
index 000000000000..409d3060d564
--- /dev/null
+++ b/www/mod_antiloris/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: mod_antiloris
+# Date created: 20 August 2009
+# Whom: Aleksandar Pejic <alex@vts.su.ac.rs>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_antiloris
+PORTVERSION= 0.4
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.monshouwer.eu/pub/linux/mod_antiloris/
+
+MAINTAINER= alex@vts.su.ac.rs
+COMMENT= Protect Apache 2.x against the Slowloris HTTP DoS attack
+
+MAKE_JOBS_SAFE= yes
+
+USE_BZIP2= yes
+USE_APACHE= 20+
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+AP_EXTRAS+= -a
+MODULENAME= mod_antiloris
+SRC_FILE= *.c
+SUB_FILES+= mod_antiloris.conf
+SUB_LIST+= APACHEETCDIR="${APACHEETCDIR}"
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.if !defined(SKIP_RULES)
+PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_antiloris.conf
+SUB_FILES+= pkg-message.rules
+.endif
+
+post-install:
+.if !defined(SKIP_RULES)
+ @${INSTALL_DATA} ${WRKDIR}/mod_antiloris.conf ${PREFIX}/${APACHEETCDIR}/Includes/
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_antiloris/distinfo b/www/mod_antiloris/distinfo
new file mode 100644
index 000000000000..5064e91f467e
--- /dev/null
+++ b/www/mod_antiloris/distinfo
@@ -0,0 +1,3 @@
+MD5 (mod_antiloris-0.4.tar.bz2) = 66862bf10e9be3a023e475604a28a0b4
+SHA256 (mod_antiloris-0.4.tar.bz2) = 0de8ea7221b120ef8cbb75f7ee5fb4f865c2e079527dbeda59b878860855a15c
+SIZE (mod_antiloris-0.4.tar.bz2) = 2598
diff --git a/www/mod_antiloris/files/mod_antiloris.conf.in b/www/mod_antiloris/files/mod_antiloris.conf.in
new file mode 100644
index 000000000000..e8d1ccf00ec7
--- /dev/null
+++ b/www/mod_antiloris/files/mod_antiloris.conf.in
@@ -0,0 +1,4 @@
+<IfModule mod_antiloris.c>
+ IPReadLimit 5
+</IfModule>
+
diff --git a/www/mod_antiloris/files/pkg-message.rules.in b/www/mod_antiloris/files/pkg-message.rules.in
new file mode 100644
index 000000000000..515272297601
--- /dev/null
+++ b/www/mod_antiloris/files/pkg-message.rules.in
@@ -0,0 +1,14 @@
+
+The mod_antiloris configuration file has been installed here:
+
+ %%PREFIX%%/%%APACHEETCDIR%%/Includes/mod_antiloris.conf
+
+To activate the module:
+
+ 1. find the line bellow in file %%PREFIX%%/%%APACHEETCDIR%%/httpd.conf,
+ remove the hash sign (#) in front of it and save the file
+
+ #LoadModule antiloris_module libexec/apache2/mod_antiloris.so
+
+ 2. restart your Apache server
+
diff --git a/www/mod_antiloris/pkg-descr b/www/mod_antiloris/pkg-descr
new file mode 100644
index 000000000000..86afa466c962
--- /dev/null
+++ b/www/mod_antiloris/pkg-descr
@@ -0,0 +1,4 @@
+This module protects Apache 2.x from the Slowloris HTTP DoS attack by
+limiting the number of allowed connections.
+
+WWW: http://modules.apache.org/search.php?id=1783