aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2017-08-20 19:49:06 +0800
committerrene <rene@FreeBSD.org>2017-08-20 19:49:06 +0800
commitd7db2b6435b05a2171c76ce7abb9ea55373953bf (patch)
treef582163596027ef6a98bdbfd27ac6872756e0feb /www
parentc636ace8655db574f4d4fb62a8af2c938eb50d5a (diff)
downloadfreebsd-ports-gnome-d7db2b6435b05a2171c76ce7abb9ea55373953bf.tar.gz
freebsd-ports-gnome-d7db2b6435b05a2171c76ce7abb9ea55373953bf.tar.zst
freebsd-ports-gnome-d7db2b6435b05a2171c76ce7abb9ea55373953bf.zip
django-jsonfield is a reusable Django field that allows you to store validated
JSON in your model. It silently takes care of serialization. To use, simply add the field to one of your models. This port is not a duplicate of www/py-django-jsonfield, both ports have distinct but upstreams. WWW: https://github.com/dmkoch/django-jsonfield
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-jsonfield/Makefile22
-rw-r--r--www/py-jsonfield/distinfo3
-rw-r--r--www/py-jsonfield/pkg-descr8
4 files changed, 34 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b4fc09d9fdee..0ba059b7186c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1681,6 +1681,7 @@
SUBDIR += py-hyperlink
SUBDIR += py-imdbpy
SUBDIR += py-jonpy
+ SUBDIR += py-jsonfield
SUBDIR += py-jswebkit
SUBDIR += py-kallithea
SUBDIR += py-libsass
diff --git a/www/py-jsonfield/Makefile b/www/py-jsonfield/Makefile
new file mode 100644
index 000000000000..e4c16dc40214
--- /dev/null
+++ b/www/py-jsonfield/Makefile
@@ -0,0 +1,22 @@
+# Created by: René Ladan <rene@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= jsonfield
+PORTVERSION= 2.0.2
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rene@FreeBSD.org
+COMMENT= Reusable JSONField model for Django to store validated JSON
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django110>=0:www/py-django110
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-jsonfield/distinfo b/www/py-jsonfield/distinfo
new file mode 100644
index 000000000000..3ef4a74b2b54
--- /dev/null
+++ b/www/py-jsonfield/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1503217883
+SHA256 (jsonfield-2.0.2.tar.gz) = beb1cd4850d6d6351c32daefcb826c01757744e9c863228a642f87a1a4acb834
+SIZE (jsonfield-2.0.2.tar.gz) = 10806
diff --git a/www/py-jsonfield/pkg-descr b/www/py-jsonfield/pkg-descr
new file mode 100644
index 000000000000..ff4a487d3679
--- /dev/null
+++ b/www/py-jsonfield/pkg-descr
@@ -0,0 +1,8 @@
+django-jsonfield is a reusable Django field that allows you to store validated
+JSON in your model. It silently takes care of serialization. To use, simply
+add the field to one of your models.
+
+This port is not a duplicate of www/py-django-jsonfield, both ports have
+distinct but upstreams.
+
+WWW: https://github.com/dmkoch/django-jsonfield