aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2012-09-20 02:29:13 +0800
committerosa <osa@FreeBSD.org>2012-09-20 02:29:13 +0800
commitd7efbef8da886a7fd39aa1155eb42ed956b69ca9 (patch)
tree6b666eedc3c5c6c5e04db14877e2b009d1a813e7 /www
parentbee1f359dac59c6cddedf7e813ced082cc724caf (diff)
downloadfreebsd-ports-gnome-d7efbef8da886a7fd39aa1155eb42ed956b69ca9.tar.gz
freebsd-ports-gnome-d7efbef8da886a7fd39aa1155eb42ed956b69ca9.tar.zst
freebsd-ports-gnome-d7efbef8da886a7fd39aa1155eb42ed956b69ca9.zip
Fix rc script for nginx with profiles. (*)
Configure build with original http_dav if third-party http_dav_ext defined. Bump PORTREVISIONs. Found by: Slava Kokorin <slava.kokorin@gmail.com> (*)
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile4
-rw-r--r--www/nginx-devel/files/nginx.in2
-rw-r--r--www/nginx/Makefile4
-rw-r--r--www/nginx/files/nginx.in2
4 files changed, 8 insertions, 4 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index c78775e1cf83..e444633ae879 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nginx
PORTVERSION= 1.3.6
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -336,11 +337,12 @@ DISTFILES+= agentzh-headers-more-nginx-module-v${NGINX_HEADERS_MORE_VERSION}-${G
CONFIGURE_ARGS+=--add-module=${WRKDIR}/agentzh-headers-more-nginx-module-${GIT_HEADERS_MORE_VERSION:S/^0-g//}
.endif
-.if ${PORT_OPTIONS:MHTTP_DAV}
+.if ${PORT_OPTIONS:MHTTP_DAV} || defined(USE_HTTP_DAV)
CONFIGURE_ARGS+=--with-http_dav_module
.endif
.if ${PORT_OPTIONS:MHTTP_DAV_EXT}
+USE_HTTP_DAV= yes
LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2
NGINX_DAV_EXT_VERSION= 0.0.2
GIT_DAV_EXT_VERSION= 0-g0e07a3e
diff --git a/www/nginx-devel/files/nginx.in b/www/nginx-devel/files/nginx.in
index eb77986fb65c..e1c413c2169c 100644
--- a/www/nginx-devel/files/nginx.in
+++ b/www/nginx-devel/files/nginx.in
@@ -47,7 +47,7 @@ load_rc_config $name
if [ -n "$2" ]; then
profile="$2"
if [ "x${nginx_profiles}" != "x" ]; then
- pidfile="${_pidprefix}.${profile}.pid"
+ pidfile="${_pidprefix}/${profile}.pid"
eval nginx_configfile="\${nginx_${profile}_configfile:-}"
if [ "x${nginx_configfile}" = "x" ]; then
echo "You must define a configuration file (nginx_${profile}_configfile)"
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 9401afc7d15e..0edae12bc1b7 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nginx
PORTVERSION= 1.2.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
@@ -334,11 +335,12 @@ DISTFILES+= agentzh-headers-more-nginx-module-v${NGINX_HEADERS_MORE_VERSION}-${G
CONFIGURE_ARGS+=--add-module=${WRKDIR}/agentzh-headers-more-nginx-module-${GIT_HEADERS_MORE_VERSION:S/^0-g//}
.endif
-.if ${PORT_OPTIONS:MHTTP_DAV}
+.if ${PORT_OPTIONS:MHTTP_DAV} || defined(USE_HTTP_DAV)
CONFIGURE_ARGS+=--with-http_dav_module
.endif
.if ${PORT_OPTIONS:MHTTP_DAV_EXT}
+USE_HTTP_DAV= yes
LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2
NGINX_DAV_EXT_VERSION= 0.0.2
GIT_DAV_EXT_VERSION= 0-g0e07a3e
diff --git a/www/nginx/files/nginx.in b/www/nginx/files/nginx.in
index eb77986fb65c..e1c413c2169c 100644
--- a/www/nginx/files/nginx.in
+++ b/www/nginx/files/nginx.in
@@ -47,7 +47,7 @@ load_rc_config $name
if [ -n "$2" ]; then
profile="$2"
if [ "x${nginx_profiles}" != "x" ]; then
- pidfile="${_pidprefix}.${profile}.pid"
+ pidfile="${_pidprefix}/${profile}.pid"
eval nginx_configfile="\${nginx_${profile}_configfile:-}"
if [ "x${nginx_configfile}" = "x" ]; then
echo "You must define a configuration file (nginx_${profile}_configfile)"