aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-25 00:26:00 +0800
committermiwi <miwi@FreeBSD.org>2009-03-25 00:26:00 +0800
commitdb324a5a40a957f0717d9b4a6dcc68e2d974f000 (patch)
tree1a79d086fbafc1f832a4db392b7b769aa56d859e /www
parentea2fb6c2c18b20dcb38cecb952f8c4587e5038d2 (diff)
downloadfreebsd-ports-gnome-db324a5a40a957f0717d9b4a6dcc68e2d974f000.tar.gz
freebsd-ports-gnome-db324a5a40a957f0717d9b4a6dcc68e2d974f000.tar.zst
freebsd-ports-gnome-db324a5a40a957f0717d9b4a6dcc68e2d974f000.zip
HTTP::Daemon::SSL - a simple http server class with SSL support.
Instances of the HTTP::Daemon::SSL class are HTTP/1.1 servers that listen on a socket for incoming requests. WWW: http://search.cpan.org/dist/HTTP-Daemon-SSL/ PR: ports/132810 Submitted by: Mykola Marzhan <delgod at portaone.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-Daemon-SSL/Makefile24
-rw-r--r--www/p5-HTTP-Daemon-SSL/distinfo3
-rw-r--r--www/p5-HTTP-Daemon-SSL/pkg-descr5
-rw-r--r--www/p5-HTTP-Daemon-SSL/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e9ffbf6fed86..8992b59148b6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -917,6 +917,7 @@
SUBDIR += p5-HTTP-Cookies-iCab
SUBDIR += p5-HTTP-Cookies-w3m
SUBDIR += p5-HTTP-DAV
+ SUBDIR += p5-HTTP-Daemon-SSL
SUBDIR += p5-HTTP-Engine
SUBDIR += p5-HTTP-Engine-Middleware
SUBDIR += p5-HTTP-GHTTP
diff --git a/www/p5-HTTP-Daemon-SSL/Makefile b/www/p5-HTTP-Daemon-SSL/Makefile
new file mode 100644
index 000000000000..77ab61037dbd
--- /dev/null
+++ b/www/p5-HTTP-Daemon-SSL/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-HTTP-Daemon-SSL
+# Date created: August 27, 2008
+# Whom: Mykola Marzhan <delgod@portaone.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Daemon-SSL
+PORTVERSION= 1.04
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= delgod@portaone.com
+COMMENT= A simple http server class with SSL support
+
+RUN_DEPENDS= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ ${SITE_PERL}/HTTP/Daemon.pm:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Daemon::SSL.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Daemon-SSL/distinfo b/www/p5-HTTP-Daemon-SSL/distinfo
new file mode 100644
index 000000000000..43208a7f6b92
--- /dev/null
+++ b/www/p5-HTTP-Daemon-SSL/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-Daemon-SSL-1.04.tar.gz) = fb9463de861bba7864d79045d1e8cded
+SHA256 (HTTP-Daemon-SSL-1.04.tar.gz) = 7eae05422d934c8492dfd3505b774fd6590c99808ce8beb6c57efd261e5dc22e
+SIZE (HTTP-Daemon-SSL-1.04.tar.gz) = 9237
diff --git a/www/p5-HTTP-Daemon-SSL/pkg-descr b/www/p5-HTTP-Daemon-SSL/pkg-descr
new file mode 100644
index 000000000000..2c93fce995bc
--- /dev/null
+++ b/www/p5-HTTP-Daemon-SSL/pkg-descr
@@ -0,0 +1,5 @@
+HTTP::Daemon::SSL - a simple http server class with SSL support.
+Instances of the HTTP::Daemon::SSL class are HTTP/1.1 servers
+that listen on a socket for incoming requests.
+
+WWW: http://search.cpan.org/dist/HTTP-Daemon-SSL/
diff --git a/www/p5-HTTP-Daemon-SSL/pkg-plist b/www/p5-HTTP-Daemon-SSL/pkg-plist
new file mode 100644
index 000000000000..f8d2a17124f9
--- /dev/null
+++ b/www/p5-HTTP-Daemon-SSL/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/HTTP/Daemon/SSL.pm
+@dirrmtry %%SITE_PERL%%/HTTP/Daemon
+@dirrmtry %%SITE_PERL%%/HTTP
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Daemon/SSL/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Daemon/SSL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Daemon
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP