aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorler <ler@FreeBSD.org>2017-01-11 11:04:41 +0800
committerler <ler@FreeBSD.org>2017-01-11 11:04:41 +0800
commitdb9a6dec9659ccf0cf36a2133fbe72d8387ac179 (patch)
treed4f866304a22fb19d5924192bf3c0f062a64b340 /www
parentbac0123be595b54650f2437800420d83b90a9644 (diff)
downloadfreebsd-ports-gnome-db9a6dec9659ccf0cf36a2133fbe72d8387ac179.tar.gz
freebsd-ports-gnome-db9a6dec9659ccf0cf36a2133fbe72d8387ac179.tar.zst
freebsd-ports-gnome-db9a6dec9659ccf0cf36a2133fbe72d8387ac179.zip
New Port www/miniminiweb
MiniMiniWeb is my attempt at creating a multithreaded web server in C. Features (and Misfeatures) Written in C Multithreaded (with pthread) Designed for Unix-like systems Supports GET and POST requests Only serves static files No SSL No CGI or anything "dynamic" No Virtual Hosts No Directory Listings (gotten pulled out) No IPv6 PR: 211472 Submitted by: neel@neelc.org Approved by: adamw (mentor) Differential Revision: https://reviews.freebsd.org/D9127
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/miniminiweb/Makefile21
-rw-r--r--www/miniminiweb/distinfo3
-rw-r--r--www/miniminiweb/pkg-descr16
4 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e38e58a1659f..121811e38702 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -407,6 +407,7 @@
SUBDIR += midori
SUBDIR += mimetex
SUBDIR += mini_httpd
+ SUBDIR += miniminiweb
SUBDIR += minio
SUBDIR += mitmproxy
SUBDIR += mkapachepw
diff --git a/www/miniminiweb/Makefile b/www/miniminiweb/Makefile
new file mode 100644
index 000000000000..8fc986c8d652
--- /dev/null
+++ b/www/miniminiweb/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= miniminiweb
+PORTVERSION= 0.0.2
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+
+MAINTAINER= neel@neelc.org
+COMMENT= Minimal, Multithreaded web server in C
+
+LICENSE= BSD2CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= neelchauhan
+GH_PROJECT= MiniMiniWeb
+
+ALL_TARGET= All
+
+PLIST_FILES= bin/${GH_PROJECT}
+
+.include <bsd.port.mk>
diff --git a/www/miniminiweb/distinfo b/www/miniminiweb/distinfo
new file mode 100644
index 000000000000..d0eaa99b274b
--- /dev/null
+++ b/www/miniminiweb/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469924722
+SHA256 (neelchauhan-MiniMiniWeb-v0.0.2_GH0.tar.gz) = 3fcd37fc3aabfcf342b758ec1861f50d74c90ad9451065f6d107a12facc44e1c
+SIZE (neelchauhan-MiniMiniWeb-v0.0.2_GH0.tar.gz) = 4754
diff --git a/www/miniminiweb/pkg-descr b/www/miniminiweb/pkg-descr
new file mode 100644
index 000000000000..a0b95277e8e1
--- /dev/null
+++ b/www/miniminiweb/pkg-descr
@@ -0,0 +1,16 @@
+MiniMiniWeb is a minimal, multithreaded web server in C.
+
+Features (and Misfeatures)
+
+Written in C
+Multithreaded (with pthread)
+Designed for Unix-like systems
+Supports GET and POST requests
+Only serves static files
+No SSL
+No CGI or anything "dynamic"
+No Virtual Hosts
+No Directory Listings (gotten pulled out)
+No IPv6
+
+WWW: https://www.github.com/neelchauhan/MiniMiniWeb