aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2018-10-08 16:52:51 +0800
committertz <tz@FreeBSD.org>2018-10-08 16:52:51 +0800
commitdf310a32dc5482a3355a8fcd4ca55dd5289803bb (patch)
treeadfd6b20496941d7ab22cbbb81aacdf0db2ffbe3 /www
parent6925d9004d56a9f2d5109f1397be7247e1c9c5e0 (diff)
downloadfreebsd-ports-gnome-df310a32dc5482a3355a8fcd4ca55dd5289803bb.tar.gz
freebsd-ports-gnome-df310a32dc5482a3355a8fcd4ca55dd5289803bb.tar.zst
freebsd-ports-gnome-df310a32dc5482a3355a8fcd4ca55dd5289803bb.zip
Add PHP 7.3 RC2 to the ports-tree.
Notable changes: - Switch from PCRE to PCRE2 - Many modules now require PCRE2 for building - graphics/php73-gd: X11 option is no longer default Changes to Mk/Uses/php.mk approved by ale
Diffstat (limited to 'www')
-rw-r--r--www/mod_php73/Makefile15
-rw-r--r--www/php73-opcache/Makefile13
-rw-r--r--www/php73-opcache/files/patch-zend__file__cache.c14
-rw-r--r--www/php73-session/Makefile11
-rw-r--r--www/php73-tidy/Makefile11
5 files changed, 64 insertions, 0 deletions
diff --git a/www/mod_php73/Makefile b/www/mod_php73/Makefile
new file mode 100644
index 000000000000..a0b7560bc315
--- /dev/null
+++ b/www/mod_php73/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+CATEGORIES= www devel
+PKGNAMEPREFIX= mod_
+
+MAINTAINER= ports@FreeBSD.org
+
+PHP_PORT= lang/php73
+MASTERDIR= ${.CURDIR}/../../${PHP_PORT}
+
+OPTIONS_DEFINE= AP2FILTER
+AP2FILTER_DESC= Use Apache 2.x filter interface (experimental)
+OPTIONS_EXCLUDE=CGI CLI FPM EMBED
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/php73-opcache/Makefile b/www/php73-opcache/Makefile
new file mode 100644
index 000000000000..bd4aa1cf5891
--- /dev/null
+++ b/www/php73-opcache/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+CATEGORIES= www
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -opcache
+
+TEST_TARGET= test
+
+USES= php:zend,noflavors
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/php73-opcache/files/patch-zend__file__cache.c b/www/php73-opcache/files/patch-zend__file__cache.c
new file mode 100644
index 000000000000..937290216eef
--- /dev/null
+++ b/www/php73-opcache/files/patch-zend__file__cache.c
@@ -0,0 +1,14 @@
+--- zend_file_cache.c.orig 2017-07-05 13:48:27 UTC
++++ zend_file_cache.c
+@@ -24,9 +24,10 @@
+
+ #include "php.h"
+
++#include "ZendAccelerator.h"
++
+ #ifdef HAVE_OPCACHE_FILE_CACHE
+
+-#include "ZendAccelerator.h"
+ #include "zend_file_cache.h"
+ #include "zend_shared_alloc.h"
+ #include "zend_accelerator_util_funcs.h"
diff --git a/www/php73-session/Makefile b/www/php73-session/Makefile
new file mode 100644
index 000000000000..b4bf59c30257
--- /dev/null
+++ b/www/php73-session/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= www
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -session
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/php73-tidy/Makefile b/www/php73-tidy/Makefile
new file mode 100644
index 000000000000..101623cb7897
--- /dev/null
+++ b/www/php73-tidy/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= www
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -tidy
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"