aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-06-09 06:51:42 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-06-09 06:51:42 +0800
commite26336222baae9afb001941aa5a2172cb511f62a (patch)
tree83b3408240e50d800f369d8c25db3814b340459b /www
parent97cd2c175d63177388f7eda901dbb74950da7f76 (diff)
downloadfreebsd-ports-gnome-e26336222baae9afb001941aa5a2172cb511f62a.tar.gz
freebsd-ports-gnome-e26336222baae9afb001941aa5a2172cb511f62a.tar.zst
freebsd-ports-gnome-e26336222baae9afb001941aa5a2172cb511f62a.zip
Feedzirra is a feed library that is designed to get
and update many feeds as quickly as possible. The fetching and parsing logic have been de-coupled so that either of them can be used in isolation if you'd prefer not to use everything that Feedzirra offers. WWW: http://github.com/pauldix/feedzirra PR: ports/147693 Submitted by: Eric Freeman <freebsdports at chillibear.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-feedzirra/Makefile27
-rw-r--r--www/rubygem-feedzirra/distinfo3
-rw-r--r--www/rubygem-feedzirra/pkg-descr8
4 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a9853c12314f..87a07c0e689b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1529,6 +1529,7 @@
SUBDIR += rubygem-bluecloth
SUBDIR += rubygem-erubis
SUBDIR += rubygem-feed-normalizer
+ SUBDIR += rubygem-feedzirra
SUBDIR += rubygem-haml
SUBDIR += rubygem-hpricot
SUBDIR += rubygem-htauth
diff --git a/www/rubygem-feedzirra/Makefile b/www/rubygem-feedzirra/Makefile
new file mode 100644
index 000000000000..ee853b5475b9
--- /dev/null
+++ b/www/rubygem-feedzirra/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: rubygem-feedzirra
+# Date created: 08 June 2010
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= feedzirra
+PORTVERSION= 0.0.23
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= A feed fetching and parsing library
+
+RUN_DEPENDS= rubygem-activesupport>=2.0.0:${PORTSDIR}/devel/rubygem-activesupport \
+ rubygem-builder>=2.1.2:${PORTSDIR}/devel/rubygem-builder \
+ rubygem-nokogiri>=0.0.0:${PORTSDIR}/textproc/rubygem-nokogiri \
+ rubygem-loofah>=0.3.1:${PORTSDIR}/textproc/rubygem-loofah \
+ rubygem-curb>=0.2.3:${PORTSDIR}/ftp/rubygem-curb \
+ rubygem-sax-machine>=0.0.12:${PORTSDIR}/textproc/rubygem-sax-machine
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-feedzirra/distinfo b/www/rubygem-feedzirra/distinfo
new file mode 100644
index 000000000000..dd399fc4f760
--- /dev/null
+++ b/www/rubygem-feedzirra/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/feedzirra-0.0.23.gem) = 67285c9e4c081276de8357ad3a319f81
+SHA256 (rubygem/feedzirra-0.0.23.gem) = 157849edbb296dbfbef108e0219f1d33f69d80fd2f4c6f9aac92d4f72d353de7
+SIZE (rubygem/feedzirra-0.0.23.gem) = 24064
diff --git a/www/rubygem-feedzirra/pkg-descr b/www/rubygem-feedzirra/pkg-descr
new file mode 100644
index 000000000000..7cabb8cf5894
--- /dev/null
+++ b/www/rubygem-feedzirra/pkg-descr
@@ -0,0 +1,8 @@
+Feedzirra is a feed library that is designed to get
+and update many feeds as quickly as possible.
+
+The fetching and parsing logic have been de-coupled
+so that either of them can be used in isolation if you'd
+prefer not to use everything that Feedzirra offers.
+
+WWW: http://github.com/pauldix/feedzirra