aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2018-09-29 00:35:29 +0800
committermiwi <miwi@FreeBSD.org>2018-09-29 00:35:29 +0800
commite356d6e06859b3027e77db6b4e25f2ae38f83a35 (patch)
tree7894d3b62c262c52a5e13742b203b2d9af38b75a /www
parentb1ab0bfea6df172a83fd83eabda04848a9f5cc46 (diff)
downloadfreebsd-ports-gnome-e356d6e06859b3027e77db6b4e25f2ae38f83a35.tar.gz
freebsd-ports-gnome-e356d6e06859b3027e77db6b4e25f2ae38f83a35.tar.zst
freebsd-ports-gnome-e356d6e06859b3027e77db6b4e25f2ae38f83a35.zip
This package makes it possible to serialize tags generated by the django-taggit
package. Because the tags in the django-taggit package need to be added into a TaggableManager() one cannot use the usual Serializer that is retrieved from the Django REST Framework. WWW: https://github.com/glemmaPaul/django-taggit-serializer PR: 231114 Submitted by: freebsd_ports@k-worx.org Sponsored by: iXsystems Inc.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-taggit-serializer/Makefile23
-rw-r--r--www/py-django-taggit-serializer/distinfo3
-rw-r--r--www/py-django-taggit-serializer/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 335d854b6447..6e033c876c1c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1617,6 +1617,7 @@
SUBDIR += py-django-tables2
SUBDIR += py-django-tagging
SUBDIR += py-django-taggit
+ SUBDIR += py-django-taggit-serializer
SUBDIR += py-django-tastypie
SUBDIR += py-django-templatetag-sugar
SUBDIR += py-django-timezone-field
diff --git a/www/py-django-taggit-serializer/Makefile b/www/py-django-taggit-serializer/Makefile
new file mode 100644
index 000000000000..eb520f856606
--- /dev/null
+++ b/www/py-django-taggit-serializer/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= django-taggit-serializer
+DISTVERSION= 0.1.7
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Django Taggit serializer for the Django REST Framework
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django-taggit>=0:www/py-django-taggit@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-taggit-serializer/distinfo b/www/py-django-taggit-serializer/distinfo
new file mode 100644
index 000000000000..ea22dc02a345
--- /dev/null
+++ b/www/py-django-taggit-serializer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1533884090
+SHA256 (django-taggit-serializer-0.1.7.tar.gz) = f712eb2482079be452bcd1e82b18a820e26427c3ee1cef2b4fcd4d6b8b9f14d0
+SIZE (django-taggit-serializer-0.1.7.tar.gz) = 5589
diff --git a/www/py-django-taggit-serializer/pkg-descr b/www/py-django-taggit-serializer/pkg-descr
new file mode 100644
index 000000000000..dfb52b90812b
--- /dev/null
+++ b/www/py-django-taggit-serializer/pkg-descr
@@ -0,0 +1,6 @@
+This package makes it possible to serialize tags generated by the django-taggit
+package. Because the tags in the django-taggit package need to be added into a
+TaggableManager() one cannot use the usual Serializer that is retrieved from the
+Django REST Framework.
+
+WWW: https://github.com/glemmaPaul/django-taggit-serializer