aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-05-02 10:48:55 +0800
committerbeech <beech@FreeBSD.org>2008-05-02 10:48:55 +0800
commite38161d9c4231b748463f3482fcd463329da7b67 (patch)
tree27f2557701762495d4bdafb5eb5fabfe340d3766 /www
parentefb38267fc69b441fa1bbc3420673c5fc13ff81d (diff)
downloadfreebsd-ports-gnome-e38161d9c4231b748463f3482fcd463329da7b67.tar.gz
freebsd-ports-gnome-e38161d9c4231b748463f3482fcd463329da7b67.tar.zst
freebsd-ports-gnome-e38161d9c4231b748463f3482fcd463329da7b67.zip
- New port dojo-shrinksafe-1.1.0
The Dojo Toolkit's compressor, ShrinkSafe, uses the Rhino JavaScript interpreter to safely rename variables and reduce the size of your scripts without interferring with their operation. It does not change any public APIs making it easy to use in your JavaScript development process. PR: ports/123298 Submitted by: Greg Larkin <glarkin at sourcehosting.net>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/dojo-shrinksafe/Makefile35
-rw-r--r--www/dojo-shrinksafe/distinfo3
-rw-r--r--www/dojo-shrinksafe/files/dojo-shrinksafe.in2
-rw-r--r--www/dojo-shrinksafe/pkg-descr7
-rw-r--r--www/dojo-shrinksafe/pkg-message7
6 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2dcbb3d9efa0..4de4f265ec30 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -115,6 +115,7 @@
SUBDIR += dillo-i18n
SUBDIR += docebo
SUBDIR += dojo
+ SUBDIR += dojo-shrinksafe
SUBDIR += dokeos
SUBDIR += dokuwiki
SUBDIR += dokuwiki-devel
diff --git a/www/dojo-shrinksafe/Makefile b/www/dojo-shrinksafe/Makefile
new file mode 100644
index 000000000000..b103958c0481
--- /dev/null
+++ b/www/dojo-shrinksafe/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: dojo-shrinksafe
+# Date created: 2008-05-01
+# Whom: Greg Larkin <glarkin@sourcehosting.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= shrinksafe
+PORTVERSION= 1.1.0
+CATEGORIES= www java
+MASTER_SITES= http://download.dojotoolkit.org/release-${PORTVERSION}/ \
+ LOCAL/beech
+PKGNAMEPREFIX= dojo-
+DISTNAME= ${PKGNAMEPREFIX}release-${PORTVERSION}-${PORTNAME}
+
+MAINTAINER= glarkin@sourcehosting.net
+COMMENT= A Javascript code compressor
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PKGNAMEPREFIX}${PORTNAME} %%DATADIR%%/custom_rhino.jar
+PLIST_DIRS= %%DATADIR%%
+SUB_FILES= ${PKGNAMEPREFIX}${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/custom_rhino.jar ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME} ${PREFIX}/bin
+ @${CAT} pkg-message
+
+.include <bsd.port.post.mk>
diff --git a/www/dojo-shrinksafe/distinfo b/www/dojo-shrinksafe/distinfo
new file mode 100644
index 000000000000..ccc218965ce6
--- /dev/null
+++ b/www/dojo-shrinksafe/distinfo
@@ -0,0 +1,3 @@
+MD5 (dojo-release-1.1.0-shrinksafe.tar.gz) = 2704351fd623493a82861798484009e8
+SHA256 (dojo-release-1.1.0-shrinksafe.tar.gz) = ff3811286dad0256e2625d413d2218f94a57e2c8763b8cf5fbf38ae6197592c2
+SIZE (dojo-release-1.1.0-shrinksafe.tar.gz) = 799117
diff --git a/www/dojo-shrinksafe/files/dojo-shrinksafe.in b/www/dojo-shrinksafe/files/dojo-shrinksafe.in
new file mode 100644
index 000000000000..2168a5335d97
--- /dev/null
+++ b/www/dojo-shrinksafe/files/dojo-shrinksafe.in
@@ -0,0 +1,2 @@
+#!/bin/sh
+JAVA_VERSION="%%JAVA_VERSION%%" exec %%LOCALBASE%%/bin/java -jar %%DATADIR%%/custom_rhino.jar $@
diff --git a/www/dojo-shrinksafe/pkg-descr b/www/dojo-shrinksafe/pkg-descr
new file mode 100644
index 000000000000..480fce602c2b
--- /dev/null
+++ b/www/dojo-shrinksafe/pkg-descr
@@ -0,0 +1,7 @@
+The Dojo Toolkit's compressor, ShrinkSafe, uses the Rhino JavaScript
+interpreter to safely rename variables and reduce the size of your
+scripts without interferring with their operation. It does not
+change any public APIs making it easy to use in your JavaScript
+development process.
+
+WWW: http://dojotoolkit.org/docs/shrinksafe/
diff --git a/www/dojo-shrinksafe/pkg-message b/www/dojo-shrinksafe/pkg-message
new file mode 100644
index 000000000000..074e3c0d9c3e
--- /dev/null
+++ b/www/dojo-shrinksafe/pkg-message
@@ -0,0 +1,7 @@
+
+*********************************************************************
+You have just installed the Dojo Toolkit Shrinksafe, a
+Javascript code compressor.
+
+Full documentation with usage examples is found at
+http://dojotoolkit.org/docs/shrinksafe/.