aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-19 01:37:16 +0800
committerpgj <pgj@FreeBSD.org>2012-02-19 01:37:16 +0800
commite3a60057cce26ba6be0c4100e0f04a1b6b1a72d2 (patch)
tree0e1884033843cd1fe8af1b9997d8a0a75fa52e6a /www
parent3f34b035469515b59f3147bbbbecbef4ff5bafc5 (diff)
downloadfreebsd-ports-gnome-e3a60057cce26ba6be0c4100e0f04a1b6b1a72d2.tar.gz
freebsd-ports-gnome-e3a60057cce26ba6be0c4100e0f04a1b6b1a72d2.tar.zst
freebsd-ports-gnome-e3a60057cce26ba6be0c4100e0f04a1b6b1a72d2.zip
Provides common features without many dependencies.
WWW: http://github.com/yesodweb/wai Obtained from: FreeBSD Haskell
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/hs-wai-extra/Makefile23
-rw-r--r--www/hs-wai-extra/distinfo2
-rw-r--r--www/hs-wai-extra/pkg-descr3
4 files changed, 29 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c1fcecef1cf8..80aa57d0a572 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -311,6 +311,7 @@
SUBDIR += hs-snap-server
SUBDIR += hs-url
SUBDIR += hs-wai
+ SUBDIR += hs-wai-extra
SUBDIR += hs-warp
SUBDIR += hs-webkit
SUBDIR += hs-xss-sanitize
diff --git a/www/hs-wai-extra/Makefile b/www/hs-wai-extra/Makefile
new file mode 100644
index 000000000000..b31a31dd66f8
--- /dev/null
+++ b/www/hs-wai-extra/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: hs-wai-extra
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= wai-extra
+PORTVERSION= 0.4.6
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Provides some basic WAI handlers and middleware
+
+LICENSE= BSD
+
+USE_CABAL= blaze-builder>=0.2.1.4 blaze-builder-enumerator>=0.2 \
+ case-insensitive>=0.2 data-default>=0.3 enumerator>=0.4.8 \
+ fast-logger>=0.0.1 http-types>=0.6 network>=2.2.1.5 text>=0.7 \
+ transformers>=0.2.2 wai>=0.4 zlib-bindings zlib-enum>=0.2.1
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-wai-extra/distinfo b/www/hs-wai-extra/distinfo
new file mode 100644
index 000000000000..8ee2752c3f63
--- /dev/null
+++ b/www/hs-wai-extra/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/wai-extra-0.4.6.tar.gz) = 1bee3d5046c09eb0a66d4678a324dcc76e2110b9f7beebe3186d7d5cf877edf2
+SIZE (cabal/wai-extra-0.4.6.tar.gz) = 28666
diff --git a/www/hs-wai-extra/pkg-descr b/www/hs-wai-extra/pkg-descr
new file mode 100644
index 000000000000..0a02394b3a92
--- /dev/null
+++ b/www/hs-wai-extra/pkg-descr
@@ -0,0 +1,3 @@
+Provides common features without many dependencies.
+
+WWW: http://github.com/yesodweb/wai