aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-04-19 03:42:39 +0800
committerKai Knoblich <kai@FreeBSD.org>2019-04-19 03:42:39 +0800
commite415ed1be5c1498d12a4c32f9d7ae1bf9c573493 (patch)
tree3f61573875e5696d2c5551bad3e539b2eaf5a015 /www
parentb8b1574599be29a94d4dbbe9fbc9ac9aaff25291 (diff)
downloadfreebsd-ports-gnome-e415ed1be5c1498d12a4c32f9d7ae1bf9c573493.tar.gz
freebsd-ports-gnome-e415ed1be5c1498d12a4c32f9d7ae1bf9c573493.tar.zst
freebsd-ports-gnome-e415ed1be5c1498d12a4c32f9d7ae1bf9c573493.zip
New port: www/py-django-cacheops
A slick app that supports automatic or manual queryset caching and automatic granular event-driven invalidation. It uses redis as backend for ORM cache and redis or filesystem for simple time-invalidated one. And there is more to it: * Decorators to cache any user function or view as a queryset or by time * Extensions for django and jinja2 templates * Transparent transaction support * Dog-pile prevention mechanism * A couple of hacks to make django faster WWW: https://github.com/Suor/django-cacheops Approved by: mentors (implicit)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-cacheops/Makefile25
-rw-r--r--www/py-django-cacheops/distinfo3
-rw-r--r--www/py-django-cacheops/pkg-descr15
4 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 12f31bbf54af..5b6236c5e5d9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1533,6 +1533,7 @@
SUBDIR += py-django-bootstrap3
SUBDIR += py-django-braces
SUBDIR += py-django-bulk-update
+ SUBDIR += py-django-cacheops
SUBDIR += py-django-caching-app-plugins
SUBDIR += py-django-classy-tags
SUBDIR += py-django-cms
diff --git a/www/py-django-cacheops/Makefile b/www/py-django-cacheops/Makefile
new file mode 100644
index 000000000000..02d2d1924a87
--- /dev/null
+++ b/www/py-django-cacheops/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= django-cacheops
+PORTVERSION= 4.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Slick ORM cache with automatic granular event-driven invalidation
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django111>=1.8:www/py-django111@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}redis>=2.9.1:databases/py-redis@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}funcy>=1.8:devel/py-funcy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.4.0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-cacheops/distinfo b/www/py-django-cacheops/distinfo
new file mode 100644
index 000000000000..e44ea959e22d
--- /dev/null
+++ b/www/py-django-cacheops/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1555579412
+SHA256 (django-cacheops-4.1.tar.gz) = 2a5cd01ad64f565d0ad18bf103c96988ccdf7d245601dedd8ef52f9ef63e0727
+SIZE (django-cacheops-4.1.tar.gz) = 53766
diff --git a/www/py-django-cacheops/pkg-descr b/www/py-django-cacheops/pkg-descr
new file mode 100644
index 000000000000..9df3c28b800e
--- /dev/null
+++ b/www/py-django-cacheops/pkg-descr
@@ -0,0 +1,15 @@
+A slick app that supports automatic or manual queryset caching and automatic
+granular event-driven invalidation.
+
+It uses redis as backend for ORM cache and redis or filesystem for simple
+time-invalidated one.
+
+And there is more to it:
+
+* Decorators to cache any user function or view as a queryset or by time
+* Extensions for django and jinja2 templates
+* Transparent transaction support
+* Dog-pile prevention mechanism
+* A couple of hacks to make django faster
+
+WWW: https://github.com/Suor/django-cacheops