aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2016-05-01 02:31:57 +0800
committerSergey A. Osokin <osa@FreeBSD.org>2016-05-01 02:31:57 +0800
commite728786ee1801a64a39c13882448f90fcd0906a1 (patch)
tree1b40d8e75619630c49af81fb47d8d65d2774041b /www
parent2325b7bd7d6776222e696e889a2928a2b6a2a784 (diff)
downloadfreebsd-ports-gnome-e728786ee1801a64a39c13882448f90fcd0906a1.tar.gz
freebsd-ports-gnome-e728786ee1801a64a39c13882448f90fcd0906a1.tar.zst
freebsd-ports-gnome-e728786ee1801a64a39c13882448f90fcd0906a1.zip
Do not force WITH_OPENSSL_PORT on 11.x and above.
Bump PORTREVISION. PR: 209159
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile7
-rw-r--r--www/nginx/Makefile7
2 files changed, 8 insertions, 6 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index f998d63e3c62..a769dbdd4109 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.10.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
MASTER_SITES+= LOCAL/osa
@@ -424,7 +424,6 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_ct}
.endif
NGINX_OPENSSL= yes
USE_HTTP_SSL= yes
-WITH_OPENSSL_PORT= yes
.endif
.if ${PORT_OPTIONS:MECHO}
@@ -991,7 +990,6 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_xss}
NGINX_OPENSSL= yes
USE_HTTP_SSL= yes
CONFIGURE_ARGS+=--with-http_v2_module
-WITH_OPENSSL_PORT= yes
.endif
.if ${PORT_OPTIONS:MNJS}
@@ -1106,6 +1104,9 @@ GROUPS?=${WWWGRP}
.if defined(NGINX_OPENSSL)
USE_OPENSSL= yes
+.if ${OSVERSION} < 1100000
+WITH_OPENSSL_PORT=yes
+.endif
.endif
pre-everything::
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 2c1171e6cc2e..d2daf63e4213 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.10.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
@@ -424,7 +424,6 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_ct}
.endif
NGINX_OPENSSL= yes
USE_HTTP_SSL= yes
-WITH_OPENSSL_PORT= yes
.endif
.if ${PORT_OPTIONS:MECHO}
@@ -991,7 +990,6 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_xss}
NGINX_OPENSSL= yes
USE_HTTP_SSL= yes
CONFIGURE_ARGS+=--with-http_v2_module
-WITH_OPENSSL_PORT= yes
.endif
.if ${PORT_OPTIONS:MNJS}
@@ -1106,6 +1104,9 @@ GROUPS?=${WWWGRP}
.if defined(NGINX_OPENSSL)
USE_OPENSSL= yes
+.if ${OSVERSION} < 1100000
+WITH_OPENSSL_PORT=yes
+.endif
.endif
pre-everything::