aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2016-04-20 14:17:45 +0800
committerbrnrd <brnrd@FreeBSD.org>2016-04-20 14:17:45 +0800
commiteda254da69b60c11a8c3eb41e3f36fdc28134712 (patch)
tree3c3f40f59d9061ba1bb7d8ba59ebed217d0e496a /www
parent0aac0202747ca003bf8825ccfc9a41997144be38 (diff)
downloadfreebsd-ports-gnome-eda254da69b60c11a8c3eb41e3f36fdc28134712.tar.gz
freebsd-ports-gnome-eda254da69b60c11a8c3eb41e3f36fdc28134712.tar.zst
freebsd-ports-gnome-eda254da69b60c11a8c3eb41e3f36fdc28134712.zip
www/py-demjson: encoder, decoder, and lint/validator for JSON
- New python port - Add README documents Reviewed by: feld (mentor) Approved by: feld (mentor) Differential Revision: D5969
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-demjson/Makefile27
-rw-r--r--www/py-demjson/distinfo2
-rw-r--r--www/py-demjson/pkg-descr10
4 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 05fe1bf56d20..0357359e2c50 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1520,6 +1520,7 @@
SUBDIR += py-cssmin
SUBDIR += py-cssselect
SUBDIR += py-cssutils
+ SUBDIR += py-demjson
SUBDIR += py-django
SUBDIR += py-django-allauth
SUBDIR += py-django-annoying
diff --git a/www/py-demjson/Makefile b/www/py-demjson/Makefile
new file mode 100644
index 000000000000..2e2f15035a1a
--- /dev/null
+++ b/www/py-demjson/Makefile
@@ -0,0 +1,27 @@
+# Created by: Bernard Spil <brnrd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= demjson
+PORTVERSION= 2.2.4
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= Bernard Spil <brnrd@FreeBSD.org>
+COMMENT= encoder, decoder, and lint/validator for JSON (JavaScript Object Notation) compliant with RFC 7159
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+PORTDOCS= README.txt README.md
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_MAN} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/www/py-demjson/distinfo b/www/py-demjson/distinfo
new file mode 100644
index 000000000000..1070ad7df63c
--- /dev/null
+++ b/www/py-demjson/distinfo
@@ -0,0 +1,2 @@
+SHA256 (demjson-2.2.4.tar.gz) = 31de2038a0fdd9c4c11f8bf3b13fe77bc2a128307f965c8d5fb4dc6d6f6beb79
+SIZE (demjson-2.2.4.tar.gz) = 131457
diff --git a/www/py-demjson/pkg-descr b/www/py-demjson/pkg-descr
new file mode 100644
index 000000000000..2e4e7bb75617
--- /dev/null
+++ b/www/py-demjson/pkg-descr
@@ -0,0 +1,10 @@
+The "demjson" module, and the included "jsonlint" script, provide methods for
+encoding and decoding JSON formatted data, as well as checking JSON data for
+errors and/or portability issues. The jsonlint command/script can be used from
+the command line without needing any programming. Although the standard Python
+library now includes basic JSON support (which it did not when demjson was first
+written), this module provides a much more comprehensive implementation with
+many features not found elsewhere. It is especially useful for error checking
+or for parsing JavaScript data which may not strictly be valid JSON data.
+
+WWW: http://deron.meranda.us/python/demjson/