aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2018-02-20 14:32:06 +0800
committerantoine <antoine@FreeBSD.org>2018-02-20 14:32:06 +0800
commitee36ce3cce05feecc383874d0aa0bf781fa6c22c (patch)
tree963ca67971cd7efd7ce025b6183c055a9ba5f2fd /www
parent1b5bc854f759f09977dac07da49acd58bfd15d06 (diff)
downloadfreebsd-ports-gnome-ee36ce3cce05feecc383874d0aa0bf781fa6c22c.tar.gz
freebsd-ports-gnome-ee36ce3cce05feecc383874d0aa0bf781fa6c22c.tar.zst
freebsd-ports-gnome-ee36ce3cce05feecc383874d0aa0bf781fa6c22c.zip
Remove dependency on the python metaports
PR: 225752 Submitted by: Yasuhiro KIMURA
Diffstat (limited to 'www')
-rw-r--r--www/chromium/Makefile14
-rw-r--r--www/iridium/Makefile10
2 files changed, 12 insertions, 12 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 17ca75be889d..48e87a3c87ce 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -14,8 +14,7 @@ COMMENT?= Google web browser based on WebKit
LICENSE= BSD3CLAUSE LGPL21 MPL11
LICENSE_COMB= multi
-BUILD_DEPENDS= python:lang/python \
- bash:shells/bash \
+BUILD_DEPENDS= bash:shells/bash \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ply>0:devel/py-ply@${PY_FLAVOR} \
@@ -69,12 +68,13 @@ ONLY_FOR_ARCHS= aarch64 amd64 i386
.endif
.if defined(GN_ONLY)
-USES= compiler:c++14-lang ninja pkgconfig python:2,build shebangfix tar:xz
+USES= compiler:c++14-lang ninja pkgconfig python:2.7,build shebangfix tar:xz
.else
USES= bison cpe desktop-file-utils jpeg ninja perl5 pkgconfig \
- python:2,build shebangfix tar:xz
+ python:2.7,build shebangfix tar:xz
.endif
MAKE_ARGS= -C out/${BUILDTYPE}
+BINARY_ALIAS= python=${PYTHON_CMD}
.if !defined(GN_ONLY)
CPE_VENDOR= google
@@ -231,18 +231,18 @@ pre-configure:
# system libraries and not shipped ones.
# cd ${WRKSRC} && ${PYTHON_CMD} \
#./build/linux/unbundle/remove_bundled_libraries.py [list of preserved]
- cd ${WRKSRC} && ${PYTHON_CMD} \
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${PYTHON_CMD} \
./build/linux/unbundle/replace_gn_files.py --system-libraries \
ffmpeg flac harfbuzz-ng libwebp libxml libxslt snappy yasm || ${FALSE}
.endif
do-configure:
# GN generator bootstrapping and generating ninja files
- cd ${WRKSRC} && ${SETENV} CC=${CC} CXX=${CXX} LD=${CXX} \
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} CC=${CC} CXX=${CXX} LD=${CXX} \
READELF=${READELF} AR=${AR} NM=${NM} ${PYTHON_CMD} \
./tools/gn/bootstrap/bootstrap.py ${GN_BOOTSTRAP_FLAGS}
.if !defined(GN_ONLY)
- cd ${WRKSRC} && ${SETENV} ./out/${BUILDTYPE}/gn \
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./out/${BUILDTYPE}/gn \
gen --args='${GN_ARGS}' out/${BUILDTYPE}
# Setup nodejs dependency
diff --git a/www/iridium/Makefile b/www/iridium/Makefile
index 26aee6228cd3..3159066196e1 100644
--- a/www/iridium/Makefile
+++ b/www/iridium/Makefile
@@ -18,7 +18,6 @@ LICENSE_COMB= multi
BUILD_DEPENDS= gperf:devel/gperf \
clang50:devel/llvm50 \
yasm:devel/yasm \
- python:lang/python \
ffmpeg>=3.2.2,1:multimedia/ffmpeg \
bash:shells/bash \
flock:sysutils/flock \
@@ -62,7 +61,7 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils \
ONLY_FOR_ARCHS= amd64 i386
USES= bison desktop-file-utils jpeg ninja perl5 \
- pkgconfig python:2,build shebangfix tar:xz
+ pkgconfig python:2.7,build shebangfix tar:xz
USE_PERL5= build
USE_XORG= scrnsaverproto x11 xcb xcomposite xcursor xext xdamage xfixes xi \
@@ -71,6 +70,7 @@ USE_GNOME= atk dconf glib20 gtk20 gtk30 libxml2 libxslt
MAKE_ARGS= -C out/${BUILDTYPE}
ALL_TARGET= chrome
INSTALLS_ICONS= yes
+BINARY_ALIAS= python=${PYTHON_CMD}
CC= clang50
CXX= clang++50
@@ -186,16 +186,16 @@ pre-configure:
# system libraries and not shippen ones.
# cd ${WRKSRC} && ${PYTHON_CMD} \
#./build/linux/unbundle/remove_bundled_libraries.py [list of preserved]
- cd ${WRKSRC} && ${PYTHON_CMD} \
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${PYTHON_CMD} \
./build/linux/unbundle/replace_gn_files.py --system-libraries \
ffmpeg flac harfbuzz-ng libwebp libxml libxslt snappy yasm || ${FALSE}
do-configure:
# GN generator bootstrapping and generating ninja files
- cd ${WRKSRC} && ${SETENV} CC=${CC} CXX=${CXX} LD=${CXX} \
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} CC=${CC} CXX=${CXX} LD=${CXX} \
READELF=${READELF} AR=${AR} NM=${NM} ${PYTHON_CMD} \
./tools/gn/bootstrap/bootstrap.py ${GN_BOOTSTRAP_FLAGS}
- cd ${WRKSRC} && ${SETENV} ./out/${BUILDTYPE}/gn \
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./out/${BUILDTYPE}/gn \
gen --args='${GN_ARGS}' out/${BUILDTYPE}
# Setup nodejs dependency