aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-03-05 04:19:39 +0800
committerarved <arved@FreeBSD.org>2003-03-05 04:19:39 +0800
commitefe857fece6d135f79a5bc8a24a72da50def724d (patch)
tree8d1c77a72c5ffe5d5109dea426db7eb29364f7d0 /www
parent4b6336635247d8ffd097afb7d901409fc668e289 (diff)
downloadfreebsd-ports-gnome-efe857fece6d135f79a5bc8a24a72da50def724d.tar.gz
freebsd-ports-gnome-efe857fece6d135f79a5bc8a24a72da50def724d.tar.zst
freebsd-ports-gnome-efe857fece6d135f79a5bc8a24a72da50def724d.zip
make gzip-encoded pages display properly
PR: 48644 Submitted by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/elinks/Makefile1
-rw-r--r--www/elinks/files/patch-compression44
2 files changed, 45 insertions, 0 deletions
diff --git a/www/elinks/Makefile b/www/elinks/Makefile
index c9c9db90852f..b73d69a2fb24 100644
--- a/www/elinks/Makefile
+++ b/www/elinks/Makefile
@@ -7,6 +7,7 @@
PORTNAME= elinks
PORTVERSION= 0.4.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://elinks.or.cz/download/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
diff --git a/www/elinks/files/patch-compression b/www/elinks/files/patch-compression
new file mode 100644
index 000000000000..9b67317e74e6
--- /dev/null
+++ b/www/elinks/files/patch-compression
@@ -0,0 +1,44 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+NotDashEscaped: You need GnuPG to verify this message
+
+
+# copied from:
+# http://archive.linuxfromscratch.org/mail-archives/links-list/2003/02/att-0021/01-elinks-openbsd_bug.patch
+# http://archive.linuxfromscratch.org/mail-archives/links-list/2003/02/0021.html
+
+--- src/protocol/http/http.c.orig Sun Feb 9 02:14:19 2003
++++ src/protocol/http/http.c Sun Feb 9 02:21:10 2003
+@@ -710,6 +710,8 @@
+ }
+
+ do {
++ int init;
++
+ if (to_read == PIPE_BUF / 2) {
+ /* ... we aren't finishing yet. */
+ int written = write(conn->stream_pipes[1], data,
+@@ -743,12 +745,13 @@
+ conn->stream = open_encoded(conn->stream_pipes[0],
+ conn->content_encoding);
+ if (!conn->stream) return NULL;
+- }
++ else init = 1;
++ } else init = 0;
+
+ output = (unsigned char *) mem_realloc(output, *new_len + to_read);
+ if (!output) break;
+
+- did_read = read_encoded(conn->stream, output + *new_len, to_read);
++ did_read = read_encoded(conn->stream, output + *new_len, init ? PIPE_BUF / 4 : to_read);
+ if (did_read > 0) *new_len += did_read;
+ } while (!(!len && did_read != to_read));
+
+
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.1 (FreeBSD)
+
+iD8DBQE+Wnf/SypIl9OdoOMRAiKLAJ9UoMBFqKp6Z5WQPCpWyyLnZ5js3ACfbalV
+mEIH0ioE4rpuE/Tmcu9nj08=
+=5S2+
+-----END PGP SIGNATURE-----