aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2006-01-07 14:29:57 +0800
committerdougb <dougb@FreeBSD.org>2006-01-07 14:29:57 +0800
commitf22aefad354646e367125e29367738156d9ce45e (patch)
tree263b1289f4801350149db40a8f79e53ace385ecc /www
parent11b367b069d969e162b021882dd5ad152744a56e (diff)
downloadfreebsd-ports-gnome-f22aefad354646e367125e29367738156d9ce45e.tar.gz
freebsd-ports-gnome-f22aefad354646e367125e29367738156d9ce45e.tar.zst
freebsd-ports-gnome-f22aefad354646e367125e29367738156d9ce45e.zip
Now that new style rc.d scripts are being run as part of the
base rcorder, hard coded variable values in these scripts are overriding the values in /etc/rc.conf[.local] (due to the way that variables from the latter are read at boot time). Therefore, change the boot scripts to set default values only if the variable is unset in /etc/rc.conf[.local]. This will allow the service to start at boot time if it's been enabled as the user would expect. This change will be a noop for users who have systems that have not yet been upgraded to the new rc.d code in the base. In many cases there are other variables in the scripts that should get similar treatment, however I did not change anything other than the _enable lines. I'll leave the rest up to the maintainers to do as they see fit. Bump PORTREVISION to make sure that users and packages pick up this change.
Diffstat (limited to 'www')
-rw-r--r--www/aolserver/Makefile2
-rw-r--r--www/aolserver/files/aolserver.sh.in2
-rw-r--r--www/apache13-modperl/Makefile2
-rw-r--r--www/apache13-modperl/files/apache.sh4
-rw-r--r--www/apache13-modssl/Makefile2
-rw-r--r--www/apache13-modssl/files/rcng.sh2
6 files changed, 7 insertions, 7 deletions
diff --git a/www/aolserver/Makefile b/www/aolserver/Makefile
index bedd3edfcd4f..13017df9deb1 100644
--- a/www/aolserver/Makefile
+++ b/www/aolserver/Makefile
@@ -7,7 +7,7 @@
PORTNAME= aolserver
PORTVERSION= 4.0.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= aolserver
diff --git a/www/aolserver/files/aolserver.sh.in b/www/aolserver/files/aolserver.sh.in
index b0c30f5331c2..2ba9e5e58d3a 100644
--- a/www/aolserver/files/aolserver.sh.in
+++ b/www/aolserver/files/aolserver.sh.in
@@ -11,7 +11,7 @@
#
# Tweakable parameters for users to override in rc.conf
-aolserver_enable=NO
+aolserver_enable="${aolserver_enable-NO}"
aolserver_home=%%PREFIX%%/aolserver
aolserver_conf=${aolserver_home}/sample-config.tcl
aolserver_flags="-u nobody -g nobody"
diff --git a/www/apache13-modperl/Makefile b/www/apache13-modperl/Makefile
index ff6441de2db5..dffcd9d353b3 100644
--- a/www/apache13-modperl/Makefile
+++ b/www/apache13-modperl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apache+mod_perl
PORTVERSION= ${VERSION_APACHE}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD:S/$/:apache/} \
${MASTER_SITE_PERL_CPAN:S/$/Apache\/:modperl/}
diff --git a/www/apache13-modperl/files/apache.sh b/www/apache13-modperl/files/apache.sh
index bc1f82cc4373..2491e0514d97 100644
--- a/www/apache13-modperl/files/apache.sh
+++ b/www/apache13-modperl/files/apache.sh
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/www/apache13-modperl/files/Attic/apache.sh,v 1.1 2004-06-05 14:25:18 pav Exp $
+# $FreeBSD: /tmp/pcvs/ports/www/apache13-modperl/files/Attic/apache.sh,v 1.2 2006-01-07 06:29:56 dougb Exp $
# PROVIDE: apache
# REQUIRE: DAEMON
@@ -13,7 +13,7 @@
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
-apache_enable="NO"
+apache_enable="${apache_enable-NO}"
apache_flags=""
apache_pidfile="/var/run/httpd.pid"
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index 0ab8779761ea..92e875851156 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apache+mod_ssl
PORTVERSION= ${VERSION_APACHE}+${VERSION_MODSSL}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= www security
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITES_MODSSL:S/$/:mod_ssl/} \
diff --git a/www/apache13-modssl/files/rcng.sh b/www/apache13-modssl/files/rcng.sh
index 34220690ef36..237365f1978c 100644
--- a/www/apache13-modssl/files/rcng.sh
+++ b/www/apache13-modssl/files/rcng.sh
@@ -13,7 +13,7 @@
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
-apache_enable="NO"
+apache_enable="${apache_enable-NO}"
apache_flags="-DSSL"
apache_pidfile="/var/run/httpd.pid"