aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2006-09-15 16:17:11 +0800
committerlinimon <linimon@FreeBSD.org>2006-09-15 16:17:11 +0800
commitf2d8437c35c46dc1131c982c1f25abcd7d641fb3 (patch)
tree61136cc420c647223541df746f011f5307a7b184 /www
parent6c16383d95de00351d4ecaf674a95f310d209a6b (diff)
downloadfreebsd-ports-gnome-f2d8437c35c46dc1131c982c1f25abcd7d641fb3.tar.gz
freebsd-ports-gnome-f2d8437c35c46dc1131c982c1f25abcd7d641fb3.tar.zst
freebsd-ports-gnome-f2d8437c35c46dc1131c982c1f25abcd7d641fb3.zip
Modify these files to reflect bsd.lua.mk as tested on the cluster.
PR: ports/101612 Submitted by: alepulver Hat: portmgr
Diffstat (limited to 'www')
-rw-r--r--www/elinks/Makefile4
-rw-r--r--www/lighttpd/Makefile4
2 files changed, 5 insertions, 3 deletions
diff --git a/www/elinks/Makefile b/www/elinks/Makefile
index dfc521f0941f..7ea3ff7f9634 100644
--- a/www/elinks/Makefile
+++ b/www/elinks/Makefile
@@ -74,8 +74,10 @@ CONFIGURE_ARGS+= --without-guile
.endif
.if defined(WITH_LUASCRIPT)
-LIB_DEPENDS+= lua:${PORTSDIR}/lang/lua50
+USE_LUA= 5.0
CONFIGURE_ARGS+= --with-lua
+CPPFLAGS+= -I${LUA_INCDIR}
+LDFLAGS+= -L${LUA_LIBDIR}
.else
CONFIGURE_ARGS+= --without-lua
.endif
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 6d7ccb94afbb..764563be7cbb 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -64,9 +64,9 @@ CONFIGURE_ARGS+= --disable-ipv6
.endif
.if defined(WITH_CML)
-LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua50
+USE_LUA= 5.0
CONFIGURE_ARGS+= --with-lua
-CONFIGURE_ENV+= CFLAGS=-I${LOCALBASE}/include LDFLAGS=-L/${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="-I${LUA_INCDIR}" LDFLAGS="-L${LUA_LIBDIR}"
.endif
SUB_LIST+= REQUIRE="${_REQUIRE}"