aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2015-03-11 02:22:43 +0800
committerolivierd <olivierd@FreeBSD.org>2015-03-11 02:22:43 +0800
commitf5f0cfd4a1638a09d02bfc9da1993cd7d255634e (patch)
tree0102c10b73c66ce99cf81488663a0fcff282e8fb /www
parent81ce56aa3811e33d01f7519a70d15b135d3c45ef (diff)
downloadfreebsd-ports-gnome-f5f0cfd4a1638a09d02bfc9da1993cd7d255634e.tar.gz
freebsd-ports-gnome-f5f0cfd4a1638a09d02bfc9da1993cd7d255634e.tar.zst
freebsd-ports-gnome-f5f0cfd4a1638a09d02bfc9da1993cd7d255634e.zip
- Update to 0.4.6
- Adjust URL of FreeBSD Bugzilla (quick search)
Diffstat (limited to 'www')
-rw-r--r--www/xfce4-smartbookmark-plugin/Makefile4
-rw-r--r--www/xfce4-smartbookmark-plugin/distinfo4
-rw-r--r--www/xfce4-smartbookmark-plugin/files/patch-src__smartbookmark.c26
-rw-r--r--www/xfce4-smartbookmark-plugin/pkg-plist8
4 files changed, 26 insertions, 16 deletions
diff --git a/www/xfce4-smartbookmark-plugin/Makefile b/www/xfce4-smartbookmark-plugin/Makefile
index 81ba2b32f358..00ca64111e6e 100644
--- a/www/xfce4-smartbookmark-plugin/Makefile
+++ b/www/xfce4-smartbookmark-plugin/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xfce4-smartbookmark-plugin
-PORTVERSION= 0.4.5
-PORTREVISION= 3
+PORTVERSION= 0.4.6
CATEGORIES= www xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
@@ -19,6 +18,5 @@ GNU_CONFIGURE= yes
USE_GNOME= gtk20 intltool intlhack
USES= pkgconfig gettext gmake libtool xfce tar:bzip2
USE_XFCE= panel
-USE_XORG= ice
.include <bsd.port.mk>
diff --git a/www/xfce4-smartbookmark-plugin/distinfo b/www/xfce4-smartbookmark-plugin/distinfo
index c369efc25824..6435d7c0744d 100644
--- a/www/xfce4-smartbookmark-plugin/distinfo
+++ b/www/xfce4-smartbookmark-plugin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/xfce4-smartbookmark-plugin-0.4.5.tar.bz2) = 6aa4269a5f4b7a3332d3c491efbbbd0a9ff0031a0005fee780346863bcf4f886
-SIZE (xfce4/xfce4-smartbookmark-plugin-0.4.5.tar.bz2) = 271402
+SHA256 (xfce4/xfce4-smartbookmark-plugin-0.4.6.tar.bz2) = 3bed2b322cd39ce5845d6da07938c702260f3f1a9700b690ef377fba752ba24f
+SIZE (xfce4/xfce4-smartbookmark-plugin-0.4.6.tar.bz2) = 280664
diff --git a/www/xfce4-smartbookmark-plugin/files/patch-src__smartbookmark.c b/www/xfce4-smartbookmark-plugin/files/patch-src__smartbookmark.c
index 31f3f8466e0b..ac4fbb2318c7 100644
--- a/www/xfce4-smartbookmark-plugin/files/patch-src__smartbookmark.c
+++ b/www/xfce4-smartbookmark-plugin/files/patch-src__smartbookmark.c
@@ -1,28 +1,32 @@
---- ./src/smartbookmark.c.orig 2013-01-03 21:18:38.000000000 +0000
-+++ ./src/smartbookmark.c 2014-06-02 19:08:44.000000000 +0000
-@@ -183,9 +183,9 @@
- box = gtk_vbox_new(FALSE, 0);
+--- src/smartbookmark.c.orig 2013-02-18 21:14:36 UTC
++++ src/smartbookmark.c
+@@ -182,10 +182,10 @@ static t_search *search_new(XfcePanelPlu
+ gtk_container_add(GTK_CONTAINER(align), search->box);
/* default options */
- search->url = "http://bugs.debian.org/";
- search->label_text = "BTS";
- search->size = 5;
-+ search->url = "https://bugs.freebsd.org/bugzilla/";
-+ search->label_text = "Bugzilla";
+- search->hide_label = FALSE;
++ search->url = "https://bugs.freebsd.org/bugzilla/buglist.cgi?quicksearch=";
++ search->label_text = "FreeBSD";
+ search->size = 10;
- search->hide_label = FALSE;
++ search->hide_label = TRUE;
/* read config file options */
filename = xfce_panel_plugin_save_location(plugin, TRUE);
-@@ -255,9 +255,9 @@
+ search_read_config(search, filename);
+@@ -218,10 +218,10 @@ static void search_read_config(t_search
if( (rcfile = xfce_rc_simple_open(filename, TRUE) ))
{
xfce_rc_set_group(rcfile, NULL);
- search->url = g_strdup(xfce_rc_read_entry(rcfile,"url","http://bugs.debian.org/"));
- search->label_text = g_strdup(xfce_rc_read_entry(rcfile,"value","DBS"));
- search->size = xfce_rc_read_int_entry(rcfile, "size", 5);
-+ search->url = g_strdup(xfce_rc_read_entry(rcfile,"url","https://bugs.freebsd.org/bugzilla/"));
-+ search->label_text = g_strdup(xfce_rc_read_entry(rcfile,"value","Bugzilla"));
+- search->hide_label = xfce_rc_read_bool_entry(rcfile, "hidelabel", FALSE);
++ search->url = g_strdup(xfce_rc_read_entry(rcfile,"url","https://bugs.freebsd.org/bugzilla/buglist.cgi?quicksearch="));
++ search->label_text = g_strdup(xfce_rc_read_entry(rcfile,"value","FreeBSD"));
+ search->size = xfce_rc_read_int_entry(rcfile, "size", 10);
- search->hide_label = xfce_rc_read_bool_entry(rcfile, "hidelabel", FALSE);
++ search->hide_label = xfce_rc_read_bool_entry(rcfile, "hidelabel", TRUE);
}
}
+
diff --git a/www/xfce4-smartbookmark-plugin/pkg-plist b/www/xfce4-smartbookmark-plugin/pkg-plist
index 01e80729b2e8..30219f63dfbe 100644
--- a/www/xfce4-smartbookmark-plugin/pkg-plist
+++ b/www/xfce4-smartbookmark-plugin/pkg-plist
@@ -1,11 +1,13 @@
lib/xfce4/panel/plugins/libsmartbookmark.so
share/locale/ar/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/ast/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
+share/locale/bg/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/ca/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/cs/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/da/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/de/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/el/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
+share/locale/en_AU/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/en_GB/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/es/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/eu/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
@@ -14,19 +16,25 @@ share/locale/gl/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/hr/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/hu/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/id/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
+share/locale/is/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/it/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/ja/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/ko/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/lt/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/lv/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
+share/locale/ms/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
+share/locale/nb/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/nl/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
+share/locale/oc/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/pl/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/pt/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/pt_BR/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/ru/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/sk/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/sq/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
+share/locale/sr/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/sv/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
+share/locale/th/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/tr/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/ug/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/uk/LC_MESSAGES/xfce4-smartbookmark-plugin.mo