aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2012-12-17 18:22:02 +0800
committeraz <az@FreeBSD.org>2012-12-17 18:22:02 +0800
commitf64d729d13e21859e4df216eea220474fec8e8b6 (patch)
tree20a18ac29a2c3b58b7aca0491a2394b50e590163 /www
parent507c2b8f2fb4d2c6305f879d2941383aa10946e4 (diff)
downloadfreebsd-ports-gnome-f64d729d13e21859e4df216eea220474fec8e8b6.tar.gz
freebsd-ports-gnome-f64d729d13e21859e4df216eea220474fec8e8b6.tar.zst
freebsd-ports-gnome-f64d729d13e21859e4df216eea220474fec8e8b6.zip
Cleanup supporting perl version 5.8 and 5.10,
lang/perl5.8 and lang/5.10 will be removed from ports tree soon.
Diffstat (limited to 'www')
-rw-r--r--www/p5-Apache-ASP/Makefile8
-rw-r--r--www/p5-Catalyst-Authentication-Credential-OpenID/Makefile9
-rw-r--r--www/p5-Catalyst-Plugin-Cache/Makefile8
-rw-r--r--www/p5-CatalystX-InjectComponent/Makefile9
-rw-r--r--www/p5-FCGI-Engine/Makefile8
-rw-r--r--www/p5-FEAR-API/Makefile8
-rw-r--r--www/p5-Jifty/Makefile8
-rw-r--r--www/p5-WWW-Mechanize-GZip/Makefile9
-rw-r--r--www/p5-WWW-Mechanize-Pluggable/Makefile8
9 files changed, 9 insertions, 66 deletions
diff --git a/www/p5-Apache-ASP/Makefile b/www/p5-Apache-ASP/Makefile
index 28cebed200b0..0a173867ef60 100644
--- a/www/p5-Apache-ASP/Makefile
+++ b/www/p5-Apache-ASP/Makefile
@@ -42,10 +42,4 @@ MAN3= Apache::ASP.3 \
Bundle::Apache::ASP.3 \
Bundle::Apache::ASP::Extra.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Authentication-Credential-OpenID/Makefile b/www/p5-Catalyst-Authentication-Credential-OpenID/Makefile
index 7ab780b155aa..ede5e9949ab4 100644
--- a/www/p5-Catalyst-Authentication-Credential-OpenID/Makefile
+++ b/www/p5-Catalyst-Authentication-Credential-OpenID/Makefile
@@ -33,14 +33,7 @@ PERL_CONFIGURE= yes
MAN3= Catalyst::Authentication::Credential::OpenID.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/Module::Install::AuthorTests/d' ${WRKSRC}/Makefile.PL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Plugin-Cache/Makefile b/www/p5-Catalyst-Plugin-Cache/Makefile
index 190d8e6e8cae..482a850165e2 100644
--- a/www/p5-Catalyst-Plugin-Cache/Makefile
+++ b/www/p5-Catalyst-Plugin-Cache/Makefile
@@ -36,10 +36,4 @@ MAN3= Catalyst::Plugin::Cache.3 \
post-patch:
@${PERL} -i.bak -ne 'print unless m,ok|Test::,' ${WRKSRC}/Makefile.PL
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-CatalystX-InjectComponent/Makefile b/www/p5-CatalystX-InjectComponent/Makefile
index 518c7fc5e8a8..6d914522abf0 100644
--- a/www/p5-CatalystX-InjectComponent/Makefile
+++ b/www/p5-CatalystX-InjectComponent/Makefile
@@ -26,11 +26,4 @@ PERL_CONFIGURE= yes
MAN3= CatalystX::InjectComponent.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-FCGI-Engine/Makefile b/www/p5-FCGI-Engine/Makefile
index 8a54d6aa3a05..1557858806b8 100644
--- a/www/p5-FCGI-Engine/Makefile
+++ b/www/p5-FCGI-Engine/Makefile
@@ -44,10 +44,4 @@ MAN3= FCGI::Engine.3 \
Plack::Server::FCGI::Engine.3 \
Plack::Server::FCGI::Engine::ProcManager.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-FEAR-API/Makefile b/www/p5-FEAR-API/Makefile
index 37c5ceaec7c9..7649e60c4ed8 100644
--- a/www/p5-FEAR-API/Makefile
+++ b/www/p5-FEAR-API/Makefile
@@ -53,10 +53,4 @@ MAN3= FEAR::API.3 \
FEAR::API::Filters.3 \
FEAR::API::Document.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Jifty/Makefile b/www/p5-Jifty/Makefile
index 0370f98423f7..87e15e29a021 100644
--- a/www/p5-Jifty/Makefile
+++ b/www/p5-Jifty/Makefile
@@ -110,13 +110,7 @@ PERL_CONFIGURE= yes
.include "Makefile.man"
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
post-patch:
${REINPLACE_CMD} -e '/auto_install/d' ${WRKSRC}/Makefile.PL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Mechanize-GZip/Makefile b/www/p5-WWW-Mechanize-GZip/Makefile
index ac1201ece885..002b7a8daba5 100644
--- a/www/p5-WWW-Mechanize-GZip/Makefile
+++ b/www/p5-WWW-Mechanize-GZip/Makefile
@@ -22,11 +22,4 @@ PERL_CONFIGURE= yes
MAN3= WWW::Mechanize::GZip.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Mechanize-Pluggable/Makefile b/www/p5-WWW-Mechanize-Pluggable/Makefile
index 829e671fbcd6..924c1356900a 100644
--- a/www/p5-WWW-Mechanize-Pluggable/Makefile
+++ b/www/p5-WWW-Mechanize-Pluggable/Makefile
@@ -33,10 +33,4 @@ MAN3= WWW::Mechanize::Pluggable.3 \
WWW::Mechanize::Plugin::Cookbook.3 \
WWW::Mechanize::Plugin::HelloWorld.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500809
-RUN_DEPENDS+= p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>