aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-03-27 13:03:00 +0800
committersobomax <sobomax@FreeBSD.org>2002-03-27 13:03:00 +0800
commitf76697d3dd0414659ba23b6c3f4cd66f5b85b601 (patch)
tree5207333287b39a5c822f8d9b34b9cd24066323f5 /www
parent55d61452a09143abacd461c448878a18eb2e95ed (diff)
downloadfreebsd-ports-gnome-f76697d3dd0414659ba23b6c3f4cd66f5b85b601.tar.gz
freebsd-ports-gnome-f76697d3dd0414659ba23b6c3f4cd66f5b85b601.tar.zst
freebsd-ports-gnome-f76697d3dd0414659ba23b6c3f4cd66f5b85b601.zip
Don't link with libgnuregex - the benefit is unclear (if any), while it causes
certain problems on -stable when editing html text (evolution et al). Reported by: Mark Sergeant <msergeant@looksmart.net> Submitted by: Joe Marcus Clarke <marcus@marcuscom.com>
Diffstat (limited to 'www')
-rw-r--r--www/gtkhtml/Makefile3
-rw-r--r--www/gtkhtml/files/patch-src::htmlsearch.h14
-rw-r--r--www/gtkhtml/files/patch-src::htmltext.c14
-rw-r--r--www/gtkhtml3/Makefile3
-rw-r--r--www/gtkhtml3/files/patch-src::htmlsearch.h14
-rw-r--r--www/gtkhtml3/files/patch-src::htmltext.c14
-rw-r--r--www/gtkhtml38/Makefile3
-rw-r--r--www/gtkhtml38/files/patch-src::htmlsearch.h14
-rw-r--r--www/gtkhtml38/files/patch-src::htmltext.c14
-rw-r--r--www/libgtkhtml/Makefile3
-rw-r--r--www/libgtkhtml/files/patch-src::htmlsearch.h14
-rw-r--r--www/libgtkhtml/files/patch-src::htmltext.c14
12 files changed, 8 insertions, 116 deletions
diff --git a/www/gtkhtml/Makefile b/www/gtkhtml/Makefile
index 5c20dfa13d6e..6089b285ecfb 100644
--- a/www/gtkhtml/Makefile
+++ b/www/gtkhtml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtkhtml
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/gtkhtml
@@ -27,7 +28,7 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gconf=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgnuregex"
+ LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
diff --git a/www/gtkhtml/files/patch-src::htmlsearch.h b/www/gtkhtml/files/patch-src::htmlsearch.h
deleted file mode 100644
index f4a96db5ce60..000000000000
--- a/www/gtkhtml/files/patch-src::htmlsearch.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/htmlsearch.h 2002/03/25 14:12:56 1.1
-+++ src/htmlsearch.h 2002/03/25 14:13:16
-@@ -24,7 +24,7 @@
- #define _HTML_SEARCH_H_
-
- #include <sys/types.h>
--#include <regex.h>
-+#include <gnuregex.h>
- #include "htmltypes.h"
-
- struct _HTMLSearch {
diff --git a/www/gtkhtml/files/patch-src::htmltext.c b/www/gtkhtml/files/patch-src::htmltext.c
deleted file mode 100644
index 0cfe711701ba..000000000000
--- a/www/gtkhtml/files/patch-src::htmltext.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/htmltext.c 2002/03/25 14:12:56 1.1
-+++ src/htmltext.c 2002/03/25 14:13:10
-@@ -25,7 +25,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <sys/types.h>
--#include <regex.h>
-+#include <gnuregex.h>
- #include <gal/widgets/e-unicode.h>
-
- #include "htmltext.h"
diff --git a/www/gtkhtml3/Makefile b/www/gtkhtml3/Makefile
index 5c20dfa13d6e..6089b285ecfb 100644
--- a/www/gtkhtml3/Makefile
+++ b/www/gtkhtml3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtkhtml
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/gtkhtml
@@ -27,7 +28,7 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gconf=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgnuregex"
+ LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
diff --git a/www/gtkhtml3/files/patch-src::htmlsearch.h b/www/gtkhtml3/files/patch-src::htmlsearch.h
deleted file mode 100644
index f4a96db5ce60..000000000000
--- a/www/gtkhtml3/files/patch-src::htmlsearch.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/htmlsearch.h 2002/03/25 14:12:56 1.1
-+++ src/htmlsearch.h 2002/03/25 14:13:16
-@@ -24,7 +24,7 @@
- #define _HTML_SEARCH_H_
-
- #include <sys/types.h>
--#include <regex.h>
-+#include <gnuregex.h>
- #include "htmltypes.h"
-
- struct _HTMLSearch {
diff --git a/www/gtkhtml3/files/patch-src::htmltext.c b/www/gtkhtml3/files/patch-src::htmltext.c
deleted file mode 100644
index 0cfe711701ba..000000000000
--- a/www/gtkhtml3/files/patch-src::htmltext.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/htmltext.c 2002/03/25 14:12:56 1.1
-+++ src/htmltext.c 2002/03/25 14:13:10
-@@ -25,7 +25,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <sys/types.h>
--#include <regex.h>
-+#include <gnuregex.h>
- #include <gal/widgets/e-unicode.h>
-
- #include "htmltext.h"
diff --git a/www/gtkhtml38/Makefile b/www/gtkhtml38/Makefile
index 5c20dfa13d6e..6089b285ecfb 100644
--- a/www/gtkhtml38/Makefile
+++ b/www/gtkhtml38/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtkhtml
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/gtkhtml
@@ -27,7 +28,7 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gconf=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgnuregex"
+ LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
diff --git a/www/gtkhtml38/files/patch-src::htmlsearch.h b/www/gtkhtml38/files/patch-src::htmlsearch.h
deleted file mode 100644
index f4a96db5ce60..000000000000
--- a/www/gtkhtml38/files/patch-src::htmlsearch.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/htmlsearch.h 2002/03/25 14:12:56 1.1
-+++ src/htmlsearch.h 2002/03/25 14:13:16
-@@ -24,7 +24,7 @@
- #define _HTML_SEARCH_H_
-
- #include <sys/types.h>
--#include <regex.h>
-+#include <gnuregex.h>
- #include "htmltypes.h"
-
- struct _HTMLSearch {
diff --git a/www/gtkhtml38/files/patch-src::htmltext.c b/www/gtkhtml38/files/patch-src::htmltext.c
deleted file mode 100644
index 0cfe711701ba..000000000000
--- a/www/gtkhtml38/files/patch-src::htmltext.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/htmltext.c 2002/03/25 14:12:56 1.1
-+++ src/htmltext.c 2002/03/25 14:13:10
-@@ -25,7 +25,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <sys/types.h>
--#include <regex.h>
-+#include <gnuregex.h>
- #include <gal/widgets/e-unicode.h>
-
- #include "htmltext.h"
diff --git a/www/libgtkhtml/Makefile b/www/libgtkhtml/Makefile
index 5c20dfa13d6e..6089b285ecfb 100644
--- a/www/libgtkhtml/Makefile
+++ b/www/libgtkhtml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtkhtml
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/gtkhtml
@@ -27,7 +28,7 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gconf=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgnuregex"
+ LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
diff --git a/www/libgtkhtml/files/patch-src::htmlsearch.h b/www/libgtkhtml/files/patch-src::htmlsearch.h
deleted file mode 100644
index f4a96db5ce60..000000000000
--- a/www/libgtkhtml/files/patch-src::htmlsearch.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/htmlsearch.h 2002/03/25 14:12:56 1.1
-+++ src/htmlsearch.h 2002/03/25 14:13:16
-@@ -24,7 +24,7 @@
- #define _HTML_SEARCH_H_
-
- #include <sys/types.h>
--#include <regex.h>
-+#include <gnuregex.h>
- #include "htmltypes.h"
-
- struct _HTMLSearch {
diff --git a/www/libgtkhtml/files/patch-src::htmltext.c b/www/libgtkhtml/files/patch-src::htmltext.c
deleted file mode 100644
index 0cfe711701ba..000000000000
--- a/www/libgtkhtml/files/patch-src::htmltext.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/htmltext.c 2002/03/25 14:12:56 1.1
-+++ src/htmltext.c 2002/03/25 14:13:10
-@@ -25,7 +25,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <sys/types.h>
--#include <regex.h>
-+#include <gnuregex.h>
- #include <gal/widgets/e-unicode.h>
-
- #include "htmltext.h"