aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-07-11 20:32:39 +0800
committerperky <perky@FreeBSD.org>2004-07-11 20:32:39 +0800
commitf792d19b04cf934c60a8764f236f3825518f2135 (patch)
tree95e7ed03d093f963a9f8a7793bd9cae7a397d1cf /www
parent4bb23eac5e10498285eb88d3fb15a0cc6dd463f7 (diff)
downloadfreebsd-ports-gnome-f792d19b04cf934c60a8764f236f3825518f2135.tar.gz
freebsd-ports-gnome-f792d19b04cf934c60a8764f236f3825518f2135.tar.zst
freebsd-ports-gnome-f792d19b04cf934c60a8764f236f3825518f2135.zip
Fix build and umark BROKEN.
Diffstat (limited to 'www')
-rw-r--r--www/mod_scgi/Makefile6
-rw-r--r--www/mod_scgi/files/patch-apache2-Makefile11
2 files changed, 4 insertions, 13 deletions
diff --git a/www/mod_scgi/Makefile b/www/mod_scgi/Makefile
index 6c94424b1963..2506dac8106d 100644
--- a/www/mod_scgi/Makefile
+++ b/www/mod_scgi/Makefile
@@ -16,10 +16,9 @@ MAINTAINER= dryice@liu.com.cn
COMMENT= Apache module that implements the client side of the SCGI protocol
USE_APACHE= yes
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/${APACHE_DIR}
-BROKEN= "Does not build"
-
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/include/apache2/apr.h)
WITH_APACHE2= yes
@@ -33,6 +32,9 @@ APACHE_DIR= apache1
PLIST_SUB= APACHE_DIR=apache
.endif
+post-patch:
+ ${REINPLACE_CMD} -E -e 's,apxs2?,${APXS},g' ${WRKSRC}/Makefile
+
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/www/mod_scgi/files/patch-apache2-Makefile b/www/mod_scgi/files/patch-apache2-Makefile
deleted file mode 100644
index 0fc8186f5111..000000000000
--- a/www/mod_scgi/files/patch-apache2-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../apache2/Makefile.orig Sat Jun 26 08:54:08 2004
-+++ ../apache2/Makefile Sat Jun 26 08:54:56 2004
-@@ -1,6 +1,6 @@
-
--APXS=apxs2
--APACHECTL=apache2ctl
-+APXS=apxs
-+APACHECTL=apachectl
-
- all:
- $(APXS) -c mod_scgi.c