aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-01-06 04:04:29 +0800
committerSteve Wills <swills@FreeBSD.org>2019-01-06 04:04:29 +0800
commitf79ea9ff6f3112627ceea6689e9ebab3e447574f (patch)
tree04be81c176606c4c14a13be31b636e6d079a482e /www
parentbc034bdfc5cc589320295015ae4182e2ccd8506a (diff)
downloadfreebsd-ports-gnome-f79ea9ff6f3112627ceea6689e9ebab3e447574f.tar.gz
freebsd-ports-gnome-f79ea9ff6f3112627ceea6689e9ebab3e447574f.tar.zst
freebsd-ports-gnome-f79ea9ff6f3112627ceea6689e9ebab3e447574f.zip
www/p5-Woothee: create port
'Woothee' is user-agent string parser, returns just same result over multi-language by sharing same datasets and testsets over implementations of each languages. This is the Perl implementation version. WWW: http://woothee.github.io/ PR: 229153 Submitted by: Tomohiro Hosaka <bokutin@bokut.in>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Woothee/Makefile27
-rw-r--r--www/p5-Woothee/distinfo3
-rw-r--r--www/p5-Woothee/pkg-descr7
-rw-r--r--www/p5-Woothee/pkg-plist18
5 files changed, 56 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 1b15b470f84b..4ec455e98b23 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1351,6 +1351,7 @@
SUBDIR += p5-WebService-Simple
SUBDIR += p5-WebService-Technorati
SUBDIR += p5-WebService-YouTube
+ SUBDIR += p5-Woothee
SUBDIR += p5-WordPress-XMLRPC
SUBDIR += p5-Yahoo-Search
SUBDIR += p5-chklinks
diff --git a/www/p5-Woothee/Makefile b/www/p5-Woothee/Makefile
new file mode 100644
index 000000000000..81a74efe0f05
--- /dev/null
+++ b/www/p5-Woothee/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= Woothee
+PORTVERSION= 1.8.0
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:TAGOMORIS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bokutin@bokut.in
+COMMENT= Multi-language user-agent strings parsers (perl implementation)
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= p5-Module-Build>=0.38:devel/p5-Module-Build
+TEST_DEPENDS= p5-File-Find-Rule>=0:devel/p5-File-Find-Rule \
+ p5-Path-Class>=0:devel/p5-Path-Class \
+ p5-YAML>=0:textproc/p5-YAML
+
+USES= perl5
+
+NO_ARCH= yes
+USE_PERL5= modbuildtiny
+
+.include <bsd.port.mk>
diff --git a/www/p5-Woothee/distinfo b/www/p5-Woothee/distinfo
new file mode 100644
index 000000000000..811a57af2102
--- /dev/null
+++ b/www/p5-Woothee/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532496096
+SHA256 (Woothee-1.8.0.tar.gz) = 62a29255795b56ed539608417c0896a0ff04e543c03755e948658d0f27c06ebc
+SIZE (Woothee-1.8.0.tar.gz) = 30322
diff --git a/www/p5-Woothee/pkg-descr b/www/p5-Woothee/pkg-descr
new file mode 100644
index 000000000000..683b44bf855e
--- /dev/null
+++ b/www/p5-Woothee/pkg-descr
@@ -0,0 +1,7 @@
+'Woothee' is user-agent string parser, returns just same result over
+multi-language by sharing same datasets and testsets over implementations of
+each languages.
+
+This is the Perl implementation version.
+
+WWW: http://woothee.github.io/
diff --git a/www/p5-Woothee/pkg-plist b/www/p5-Woothee/pkg-plist
new file mode 100644
index 000000000000..1edb90c179d2
--- /dev/null
+++ b/www/p5-Woothee/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/Woothee.pm
+%%SITE_PERL%%/Woothee/Appliance.pm
+%%SITE_PERL%%/Woothee/Browser.pm
+%%SITE_PERL%%/Woothee/Crawler.pm
+%%SITE_PERL%%/Woothee/DataSet.pm
+%%SITE_PERL%%/Woothee/Misc.pm
+%%SITE_PERL%%/Woothee/MobilePhone.pm
+%%SITE_PERL%%/Woothee/OS.pm
+%%SITE_PERL%%/Woothee/Util.pm
+%%PERL5_MAN3%%/Woothee.3.gz
+%%PERL5_MAN3%%/Woothee::Appliance.3.gz
+%%PERL5_MAN3%%/Woothee::Browser.3.gz
+%%PERL5_MAN3%%/Woothee::Crawler.3.gz
+%%PERL5_MAN3%%/Woothee::DataSet.3.gz
+%%PERL5_MAN3%%/Woothee::Misc.3.gz
+%%PERL5_MAN3%%/Woothee::MobilePhone.3.gz
+%%PERL5_MAN3%%/Woothee::OS.3.gz
+%%PERL5_MAN3%%/Woothee::Util.3.gz