aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2008-12-29 08:52:58 +0800
committerpgollucci <pgollucci@FreeBSD.org>2008-12-29 08:52:58 +0800
commitf7adf32f579ac6ad2882be6397373de54fb85c99 (patch)
treea35fcb6f2e888506765a6dc6df6a9ea09d48acfb /www
parent80d522bda523c2c4d21de2f64384aac10218debc (diff)
downloadfreebsd-ports-gnome-f7adf32f579ac6ad2882be6397373de54fb85c99.tar.gz
freebsd-ports-gnome-f7adf32f579ac6ad2882be6397373de54fb85c99.tar.zst
freebsd-ports-gnome-f7adf32f579ac6ad2882be6397373de54fb85c99.zip
- Update to 3.4 (latest version for www/apache13)
- set conflicts for www/mod_layout2 and upcomming www/mod_layout22
Diffstat (limited to 'www')
-rw-r--r--www/mod_layout/Makefile9
-rw-r--r--www/mod_layout/distinfo6
-rw-r--r--www/mod_layout/files/patch-Makefile27
3 files changed, 34 insertions, 8 deletions
diff --git a/www/mod_layout/Makefile b/www/mod_layout/Makefile
index 3b4b787731ed..9691503cd191 100644
--- a/www/mod_layout/Makefile
+++ b/www/mod_layout/Makefile
@@ -6,22 +6,21 @@
#
PORTNAME= mod_layout
-PORTVERSION= 3.2.1
+PORTVERSION= 3.4
CATEGORIES= www
MASTER_SITES= http://download.tangent.org/
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module to wrap served pages with a header and/or footer
-USE_APACHE= yes
+USE_APACHE= 13
-CONFLICTS= mod_layout-4.* apache-contrib-1.*
+CONFLICTS= mod_layout-4.* mod_layout-5.* apache-contrib-1.*
CFLAGS+= -fPIC
post-patch:
- @${REINPLACE_CMD} -e 's!apxs!${LOCALBASE}/sbin/apxs!g; \
- s!-DDEBUG!$$(CFLAGS)!g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's!apxs!${LOCALBASE}/sbin/apxs!g' ${WRKSRC}/Makefile
post-install:
.if !defined(NOPORTDOCS)
diff --git a/www/mod_layout/distinfo b/www/mod_layout/distinfo
index 15b642e13291..a351e01f1473 100644
--- a/www/mod_layout/distinfo
+++ b/www/mod_layout/distinfo
@@ -1,3 +1,3 @@
-MD5 (mod_layout-3.2.1.tar.gz) = fdad44ac360f65b2ca75f08fe53af4ad
-SHA256 (mod_layout-3.2.1.tar.gz) = 9a788027ecd0e55541e524905fe61a6d8c25d81f0ffaf589b8590603e4bcfde3
-SIZE (mod_layout-3.2.1.tar.gz) = 33459
+MD5 (mod_layout-3.4.tar.gz) = 2bdfda83c6ef15e7e03c23ac43f3009d
+SHA256 (mod_layout-3.4.tar.gz) = 99973c7ec7d0258990181dfdcd2871cf3344173de90d9b05d84001d9772607db
+SIZE (mod_layout-3.4.tar.gz) = 41454
diff --git a/www/mod_layout/files/patch-Makefile b/www/mod_layout/files/patch-Makefile
new file mode 100644
index 000000000000..e0f39d51e9e6
--- /dev/null
+++ b/www/mod_layout/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- ./Makefile.orig 2008-12-28 19:38:42.000000000 -0500
++++ ./Makefile 2008-12-28 19:39:41.000000000 -0500
+@@ -40,19 +40,19 @@
+ $(APXS) -c $(LIB) $(OBJ)
+
+ mod_layout.o : mod_layout.c
+- $(CC) $(INC) -c mod_layout.c $(DEF) $(LIB)
++ $(CC) $(CFLAGS) $(INC) -c mod_layout.c $(DEF) $(LIB)
+
+ utility.o : utility.c
+- $(CC) $(INC) -c utility.c $(DEF) $(LIB)
++ $(CC) $(CFLAGS) $(INC) -c utility.c $(DEF) $(LIB)
+
+ origin.o : origin.c
+- $(CC) $(INC) -c origin.c $(DEF) $(LIB)
++ $(CC) $(CFLAGS) $(INC) -c origin.c $(DEF) $(LIB)
+
+ layout.o : layout.c
+- $(CC) $(INC) -c layout.c $(DEF) $(LIB)
++ $(CC) $(CFLAGS) $(INC) -c layout.c $(DEF) $(LIB)
+
+ header.o : header.c
+- $(CC) $(INC) -c header.c $(DEF) $(LIB)
++ $(CC) $(CFLAGS) $(INC) -c header.c $(DEF) $(LIB)
+ # install the shared object file into Apache
+ install: all
+ strip mod_layout.so