aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-19 01:48:55 +0800
committerpgj <pgj@FreeBSD.org>2012-02-19 01:48:55 +0800
commitf7e0883083ec968dbfd0a2de566e5d040f02b824 (patch)
treebfe38fcfd501fab0ccd12cc27bba0505566f98ea /www
parent4e18a36a6596eaa7cbedbf16cb95a271042ad4fb (diff)
downloadfreebsd-ports-gnome-f7e0883083ec968dbfd0a2de566e5d040f02b824.tar.gz
freebsd-ports-gnome-f7e0883083ec968dbfd0a2de566e5d040f02b824.tar.zst
freebsd-ports-gnome-f7e0883083ec968dbfd0a2de566e5d040f02b824.zip
Generate content for Yesod using the aeson package.
WWW: http://www.yesodweb.com/ Obtained from: FreeBSD Haskell
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/hs-yesod-json/Makefile22
-rw-r--r--www/hs-yesod-json/distinfo2
-rw-r--r--www/hs-yesod-json/pkg-descr3
4 files changed, 28 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b8dc3f487e80..31d75188581a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -318,6 +318,7 @@
SUBDIR += hs-xss-sanitize
SUBDIR += hs-yesod-core
SUBDIR += hs-yesod-form
+ SUBDIR += hs-yesod-json
SUBDIR += hs-yesod-persistent
SUBDIR += htdump
SUBDIR += html2hdml
diff --git a/www/hs-yesod-json/Makefile b/www/hs-yesod-json/Makefile
new file mode 100644
index 000000000000..4eef3638c7d5
--- /dev/null
+++ b/www/hs-yesod-json/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hs-yesod-json
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= yesod-json
+PORTVERSION= 0.2.3
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Generate content for Yesod using the aeson package
+
+LICENSE= BSD
+
+USE_CABAL= aeson>=0.3 attoparsec-enumerator>=0.3 blaze-builder \
+ shakespeare-js>=0.10 text>=0.8 transformers>=0.2.2 \
+ unordered-containers vector>=0.9 yesod-core>=0.9
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-yesod-json/distinfo b/www/hs-yesod-json/distinfo
new file mode 100644
index 000000000000..f0ad142c14f7
--- /dev/null
+++ b/www/hs-yesod-json/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/yesod-json-0.2.3.tar.gz) = c5637aca8b899ef2865c2cadea8ee825ae0fb62ca16cb1d0c45965dcff2fa72d
+SIZE (cabal/yesod-json-0.2.3.tar.gz) = 2480
diff --git a/www/hs-yesod-json/pkg-descr b/www/hs-yesod-json/pkg-descr
new file mode 100644
index 000000000000..e2cd1824acd1
--- /dev/null
+++ b/www/hs-yesod-json/pkg-descr
@@ -0,0 +1,3 @@
+Generate content for Yesod using the aeson package.
+
+WWW: http://www.yesodweb.com/