aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorgblach <gblach@FreeBSD.org>2019-03-18 03:31:25 +0800
committergblach <gblach@FreeBSD.org>2019-03-18 03:31:25 +0800
commitface22b64d93b6d3d08aec5c90b0ff0bec4ad3a3 (patch)
tree5e80eacb51f0585bfafaf10809bcdcc021202eb9 /www
parent1b08f5858b3b14474695b22ca9ce9cb307cbfdee (diff)
downloadfreebsd-ports-gnome-face22b64d93b6d3d08aec5c90b0ff0bec4ad3a3.tar.gz
freebsd-ports-gnome-face22b64d93b6d3d08aec5c90b0ff0bec4ad3a3.tar.zst
freebsd-ports-gnome-face22b64d93b6d3d08aec5c90b0ff0bec4ad3a3.zip
- Add new port: www/py-tornado6
- In www/py-tornado: Add conflict with py-tornado6 - In www/py-tornado4: Add conflict with py-tornado6
Diffstat (limited to 'www')
-rw-r--r--www/py-tornado/Makefile2
-rw-r--r--www/py-tornado4/Makefile2
-rw-r--r--www/py-tornado6/Makefile26
-rw-r--r--www/py-tornado6/distinfo3
-rw-r--r--www/py-tornado6/files/patch-setup.py12
-rw-r--r--www/py-tornado6/pkg-descr15
6 files changed, 58 insertions, 2 deletions
diff --git a/www/py-tornado/Makefile b/www/py-tornado/Makefile
index f04204f9b2c9..da034c926acd 100644
--- a/www/py-tornado/Makefile
+++ b/www/py-tornado/Makefile
@@ -12,7 +12,7 @@ COMMENT= Python Web Server from FriendFeed
LICENSE= APACHE20
-CONFLICTS= py[0-9]*-tornado4-*
+CONFLICTS= py[0-9]*-tornado[46]-*
USES= python
USE_PYTHON= autoplist distutils
diff --git a/www/py-tornado4/Makefile b/www/py-tornado4/Makefile
index 421e61cd5a71..cabea5e93ad0 100644
--- a/www/py-tornado4/Makefile
+++ b/www/py-tornado4/Makefile
@@ -13,7 +13,7 @@ COMMENT= Python Web Server from FriendFeed
LICENSE= APACHE20
-CONFLICTS= py[0-9]*-tornado-*
+CONFLICTS= py[0-9]*-tornado-* py[0-9]*-tornado6-*
USES= python
USE_PYTHON= autoplist distutils
diff --git a/www/py-tornado6/Makefile b/www/py-tornado6/Makefile
new file mode 100644
index 000000000000..fc84feeb395d
--- /dev/null
+++ b/www/py-tornado6/Makefile
@@ -0,0 +1,26 @@
+# Created by: Guixing Bai <khsing.cn@gmail.com>
+# $FreeBSD$
+
+PORTNAME= tornado
+PORTVERSION= 6.0.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gblach@FreeBSD.org
+COMMENT= Python Web Server from FriendFeed
+
+LICENSE= APACHE20
+
+CONFLICTS= py[0-9]*-tornado-* py[0-9]*-tornado4-*
+
+USES= python:3.5+
+USE_PYTHON= autoplist distutils
+
+post-build:
+ @${FIND} ${WRKSRC}/build -name speedups.so -exec ${STRIP_CMD} {} \;
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m tornado.test.runtests
+
+.include <bsd.port.mk>
diff --git a/www/py-tornado6/distinfo b/www/py-tornado6/distinfo
new file mode 100644
index 000000000000..60938faeaf77
--- /dev/null
+++ b/www/py-tornado6/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1552850221
+SHA256 (tornado-6.0.1.tar.gz) = de274c65f45f6656c375cdf1759dbf0bc52902a1e999d12a35eb13020a641a53
+SIZE (tornado-6.0.1.tar.gz) = 481563
diff --git a/www/py-tornado6/files/patch-setup.py b/www/py-tornado6/files/patch-setup.py
new file mode 100644
index 000000000000..dc22450431ac
--- /dev/null
+++ b/www/py-tornado6/files/patch-setup.py
@@ -0,0 +1,12 @@
+--- setup.py.orig 2015-11-06 20:08:26 UTC
++++ setup.py
+@@ -147,9 +147,6 @@ setup(
+ # in the sdist tarball)
+ "tornado.test": [
+ "README",
+- "csv_translations/fr_FR.csv",
+- "gettext_translations/fr_FR/LC_MESSAGES/tornado_test.mo",
+- "gettext_translations/fr_FR/LC_MESSAGES/tornado_test.po",
+ "options_test.cfg",
+ "static/robots.txt",
+ "static/sample.xml",
diff --git a/www/py-tornado6/pkg-descr b/www/py-tornado6/pkg-descr
new file mode 100644
index 000000000000..d70dfd3d4036
--- /dev/null
+++ b/www/py-tornado6/pkg-descr
@@ -0,0 +1,15 @@
+Tornado is an open source version of the scalable, non-blocking web server and
+tools that power FriendFeed. The FriendFeed application is written using a web
+framework that looks a bit like web.py or Google's webapp, but with additional
+tools and optimizations to take advantage of the underlying non-blocking
+infrastructure.
+
+The framework is distinct from most mainstream web server frameworks (and
+certainly most Python frameworks) because it is non-blocking and reasonably
+fast. Because it is non-blocking and uses epoll or kqueue, it can handle
+thousands of simultaneous standing connections, which means it is ideal for
+real-time web services. We built the web server specifically to handle
+FriendFeed's real-time features - every active user of FriendFeed maintains an
+open connection to the FriendFeed servers.
+
+WWW: http://www.tornadoweb.org/