aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-03-09 17:14:08 +0800
committerflz <flz@FreeBSD.org>2005-03-09 17:14:08 +0800
commitff54952245b4895397c248a65a4cbbbbe25f9166 (patch)
tree571c4c0f8b6639ad63c708469cd32db62b123eed /www
parentdcf7fc26a72d9149f759f06589381e2fc9dcef24 (diff)
downloadfreebsd-ports-gnome-ff54952245b4895397c248a65a4cbbbbe25f9166.tar.gz
freebsd-ports-gnome-ff54952245b4895397c248a65a4cbbbbe25f9166.tar.zst
freebsd-ports-gnome-ff54952245b4895397c248a65a4cbbbbe25f9166.zip
- Add p5-W3C-LinkChecker 4.1, a HTML link validity checker.
PR: ports/74438 Submitted by: Aaron Dalton <aaron@daltons.ca> Approved by: pav (mentor)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-W3C-LinkChecker/Makefile33
-rw-r--r--www/p5-W3C-LinkChecker/distinfo2
-rw-r--r--www/p5-W3C-LinkChecker/pkg-descr15
-rw-r--r--www/p5-W3C-LinkChecker/pkg-plist4
5 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b1c54fc87e8b..25533f447b0a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -549,6 +549,7 @@
SUBDIR += p5-Template-Plugin-MP3
SUBDIR += p5-Template-Toolkit
SUBDIR += p5-URI-Sequin
+ SUBDIR += p5-W3C-LinkChecker
SUBDIR += p5-W3C-LogValidator
SUBDIR += p5-WWW-Automate
SUBDIR += p5-WWW-Babelfish
diff --git a/www/p5-W3C-LinkChecker/Makefile b/www/p5-W3C-LinkChecker/Makefile
new file mode 100644
index 000000000000..f422081662bf
--- /dev/null
+++ b/www/p5-W3C-LinkChecker/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: www/p5-W3C-LinkChecker
+# Date created: 25 November 2004
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= W3C-LinkChecker
+PORTVERSION= 4.1
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/S/SC/SCOP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Checks the validity of links in an HTML or XHTML document
+
+BUILD_DEPENDS= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
+ ${SITE_PERL}/Config/General.pm:${PORTSDIR}/devel/p5-Config-General \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/Net/IP.pm:${PORTSDIR}/net-mgmt/p5-Net-IP \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN1= checklink.1
+MANCOMPRESSED= no
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/www/p5-W3C-LinkChecker/distinfo b/www/p5-W3C-LinkChecker/distinfo
new file mode 100644
index 000000000000..91b7003f595c
--- /dev/null
+++ b/www/p5-W3C-LinkChecker/distinfo
@@ -0,0 +1,2 @@
+MD5 (W3C-LinkChecker-4.1.tar.gz) = 513a50f2a6b0f0d54a8bd29449460fb6
+SIZE (W3C-LinkChecker-4.1.tar.gz) = 52391
diff --git a/www/p5-W3C-LinkChecker/pkg-descr b/www/p5-W3C-LinkChecker/pkg-descr
new file mode 100644
index 000000000000..38c21f665a55
--- /dev/null
+++ b/www/p5-W3C-LinkChecker/pkg-descr
@@ -0,0 +1,15 @@
+This manual page documents briefly the checklink command, a.k.a. the W3C
+Link Checker.
+
+checklink is a program that reads an HTML or XHTML document, extracts a
+list of anchors and lists and checks that no anchor is defined twice and
+that all the links are dereferenceable, including the fragments. It warns
+about HTTP redirects, including directory redirects, and can check
+recursively a part of a web site.
+
+The program can be used either as a command line tool or as a CGI script.
+
+WWW: http://search.cpan.org/dist/W3C-LinkChecker/
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/www/p5-W3C-LinkChecker/pkg-plist b/www/p5-W3C-LinkChecker/pkg-plist
new file mode 100644
index 000000000000..25fae7260113
--- /dev/null
+++ b/www/p5-W3C-LinkChecker/pkg-plist
@@ -0,0 +1,4 @@
+bin/checklink
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/W3C/LinkChecker/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/W3C/LinkChecker
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/W3C 2>/dev/null || true