aboutsummaryrefslogtreecommitdiffstats
path: root/x11-drivers/xf86-video-ati
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2015-03-27 16:33:27 +0800
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2015-03-27 16:33:27 +0800
commitc3af233527fff97c96882ae6f58274838f267a98 (patch)
tree878850ee542b37e6d435b88e94bc6be95c9a096d /x11-drivers/xf86-video-ati
parentbaab8cbbbb111faf3688e29cc97b6a47c9796784 (diff)
downloadfreebsd-ports-gnome-c3af233527fff97c96882ae6f58274838f267a98.tar.gz
freebsd-ports-gnome-c3af233527fff97c96882ae6f58274838f267a98.tar.zst
freebsd-ports-gnome-c3af233527fff97c96882ae6f58274838f267a98.zip
x11-drivers/drm-kmod: Port for the DRM kernel drivers for FreeBSD 9.3
This port allows us to provide updated DRM kernel drivers on FreeBSD 9.3. Kernel modules are suffixed with "_port" compared to the vanilla drivers (eg. i915kms.ko becomes i915kms_port.ko). The device-independent module, renamed as drm2_port.ko, is also included. However, Radeon firmwares are not: the vanilla ones are still being used. xf86-video-ati and xf86-video-intel depends on drm-kmod on FreeBSD 9.3. These ports are modified to automatically load the *_port kernel module. This initial version brings hardware context support to the i915 driver. This feature is required by Mesa 9.2+, which itself is required by xserver 1.15+. Differential Revision: https://reviews.freebsd.org/D2149 Reviewed by: kwm Approved by: kwm Tested by: Florian Degner <f.degner@gmx.de>
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/Makefile b/x11-drivers/xf86-video-ati/Makefile
index eee705aa4716..3f7cb4341fb5 100644
--- a/x11-drivers/xf86-video-ati/Makefile
+++ b/x11-drivers/xf86-video-ati/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xf86-video-ati
PORTVERSION= 7.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -22,4 +22,14 @@ ONLY_FOR_ARCHS= i386 amd64
CONFIGURE_ARGS+=--disable-udev
CONFIGURE_ARGS+=--disable-glamor
+.include <bsd.port.options.mk>
+
+.if (${OSVERSION} >= 903000 && ${OSVERSION} < 1000000)
+RUN_DEPENDS+= drm-kmod>=9:${PORTSDIR}/x11-drivers/drm-kmod
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|"radeonkms"|"radeonkms_port"|g' \
+ ${WRKSRC}/src/radeon_kms.c
+.endif
+
.include <bsd.port.mk>