aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/binder
diff options
context:
space:
mode:
authorkiri <kiri@FreeBSD.org>2003-05-08 19:00:15 +0800
committerkiri <kiri@FreeBSD.org>2003-05-08 19:00:15 +0800
commitc02e408ab212bb818b4a6d4c34feb06f89dfca18 (patch)
tree32f348f7f9b52e1472a679e4e6c9bb92faa0baab /x11-fm/binder
parent262d0a2f95068109fea6f021fb97cb489c111fff (diff)
downloadfreebsd-ports-gnome-c02e408ab212bb818b4a6d4c34feb06f89dfca18.tar.gz
freebsd-ports-gnome-c02e408ab212bb818b4a6d4c34feb06f89dfca18.tar.zst
freebsd-ports-gnome-c02e408ab212bb818b4a6d4c34feb06f89dfca18.zip
Change in-place replacement.
Diffstat (limited to 'x11-fm/binder')
-rw-r--r--x11-fm/binder/Makefile1
-rw-r--r--x11-fm/binder/scripts/post-install4
2 files changed, 3 insertions, 2 deletions
diff --git a/x11-fm/binder/Makefile b/x11-fm/binder/Makefile
index bfa606a19cd9..d8dfef4a7f66 100644
--- a/x11-fm/binder/Makefile
+++ b/x11-fm/binder/Makefile
@@ -24,6 +24,7 @@ NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
+REINPLACE_ARGS=
SCRIPTS_ENV= LANG=C LN=${LN} REINPLACE_CMD="${REINPLACE_CMD}" \
LANGUAGE=${LANGUAGE} VERSION=${TKSTEPVERSION}
PLIST_SUB= PIXMAP_PATH=${PIXMAPPATH:S@^${PREFIX}/@@}
diff --git a/x11-fm/binder/scripts/post-install b/x11-fm/binder/scripts/post-install
index a746119ec114..86752cc9a17a 100644
--- a/x11-fm/binder/scripts/post-install
+++ b/x11-fm/binder/scripts/post-install
@@ -5,7 +5,7 @@ installdir=${PREFIX}/JDE/Binder; export installdir
case ${LANGUAGE} in
Japanese)
for f in bin/Binder.app bin/Processes.app misc/Mounter/Mounter.app; do
- ${REINPLACE_CMD} -E -e \
+ ${REINPLACE_CMD} -i "" -E -e \
"s/^(exec[[:space:]]+)wishstep[[:space:]]*([[:space:]]+.*)\$/\1wishstep${VERSION}jp\2/" \
${installdir}/${f}
done
@@ -28,7 +28,7 @@ for f in Binder Binder.app Processes.app Mounter.app shortcut; do
target=${installdir}/lib/${f}
;;
esac
- ${REINPLACE_CMD} -E \
+ ${REINPLACE_CMD} -i "" -E \
-e "s@^([[:space:]]*set[[:space:]]+ttblibPath[[:space:]]+)\"[^\"]*\"\$@\1\"${installdir}\"@" \
-e "s@^([[:space:]]*set[[:space:]]+ttblibPath[[:space:]]+)\{[^\}]*\}\$@\1\{${installdir}\}@" \
-e "s@^([a-zA-Z.]+;)/usr/local/([a-zA-Z/.]+;[a-zA-Z]+)\$@\1${PREFIX}/\2@" \