aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/dolphin
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 04:03:36 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 04:03:36 +0800
commitce2cdb22084bbbccc9f68c71df94cc8f05f73044 (patch)
tree43a1c4b34a4477685f8295748a8f910cd2609ac0 /x11-fm/dolphin
parent206349fdfd02c1a29dd766f025721412c08bda3b (diff)
downloadfreebsd-ports-gnome-ce2cdb22084bbbccc9f68c71df94cc8f05f73044.tar.gz
freebsd-ports-gnome-ce2cdb22084bbbccc9f68c71df94cc8f05f73044.tar.zst
freebsd-ports-gnome-ce2cdb22084bbbccc9f68c71df94cc8f05f73044.zip
New ports: x11-fm/dolphin, x11-fm/konqueror
This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4.
Diffstat (limited to 'x11-fm/dolphin')
-rw-r--r--x11-fm/dolphin/Makefile32
-rw-r--r--x11-fm/dolphin/distinfo3
-rw-r--r--x11-fm/dolphin/pkg-descr3
-rw-r--r--x11-fm/dolphin/pkg-plist96
4 files changed, 134 insertions, 0 deletions
diff --git a/x11-fm/dolphin/Makefile b/x11-fm/dolphin/Makefile
new file mode 100644
index 000000000000..3d7038362436
--- /dev/null
+++ b/x11-fm/dolphin/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= dolphin
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= x11-fm kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE filemanager dolphin
+
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${QT_PLUGINDIR}/ffmpegthumbs.so:multimedia/kdemultimedia-ffmpegthumbs \
+ ${QT_PLUGINDIR}/gsthumbnail.so:graphics/kdegraphics-thumbnailers \
+ ${QT_PLUGINDIR}/audiothumbnail.so:devel/kio-extras
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= activities attica auth baloo baloo-widgets bookmarks codecs \
+ completion config configwidgets coreaddons crash dbusaddons \
+ doctools ecm emoticons filemetadata i18n iconthemes init \
+ itemmodels itemviews jobwidgets kcmutils \
+ kdelibs4support kio newstuff notifications parts service \
+ solid sonnet texteditor textwidgets widgetsaddons \
+ windowsystem xmlgui
+USE_QT5= concurrent core dbus gui network phonon4 widgets xml \
+ buildtools_build qmake_build
+
+SHLIB_VER= 5.0.0
+PLIST_SUB+= SHLIB_VER="${SHLIB_VER}" \
+ SHLIB_SHVER="${SHLIB_VER:R:R}"
+
+.include <bsd.port.mk>
diff --git a/x11-fm/dolphin/distinfo b/x11-fm/dolphin/distinfo
new file mode 100644
index 000000000000..1e6a68a128db
--- /dev/null
+++ b/x11-fm/dolphin/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520519322
+SHA256 (KDE/applications/17.12.3/dolphin-17.12.3.tar.xz) = 40dc96fa05cf6a09c49329cd69c9f1079b4ddb57592c9ff0e957eec6e761a439
+SIZE (KDE/applications/17.12.3/dolphin-17.12.3.tar.xz) = 4841752
diff --git a/x11-fm/dolphin/pkg-descr b/x11-fm/dolphin/pkg-descr
new file mode 100644
index 000000000000..9323f7f7e4dc
--- /dev/null
+++ b/x11-fm/dolphin/pkg-descr
@@ -0,0 +1,3 @@
+Dolphin is a file manager for the KDE Plasma Desktop.
+
+WWW: https://userbase.kde.org/Dolphin
diff --git a/x11-fm/dolphin/pkg-plist b/x11-fm/dolphin/pkg-plist
new file mode 100644
index 000000000000..549a3cf58b03
--- /dev/null
+++ b/x11-fm/dolphin/pkg-plist
@@ -0,0 +1,96 @@
+bin/dolphin
+bin/servicemenudeinstallation
+bin/servicemenuinstallation
+etc/xdg/servicemenu.knsrc
+include/Dolphin/KVersionControlPlugin
+include/Dolphin/dolphinvcs_version.h
+include/Dolphin/kversioncontrolplugin.h
+include/dolphin_export.h
+include/dolphinvcs_export.h
+lib/cmake/DolphinVcs/DolphinVcsConfig.cmake
+lib/cmake/DolphinVcs/DolphinVcsConfigVersion.cmake
+lib/cmake/DolphinVcs/DolphinVcsTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/DolphinVcs/DolphinVcsTargets.cmake
+lib/libdolphinprivate.so.%%SHLIB_SHVER%%
+lib/libdolphinprivate.so.%%SHLIB_VER%%
+lib/libdolphinvcs.so
+lib/libdolphinvcs.so.%%SHLIB_SHVER%%
+lib/libdolphinvcs.so.%%SHLIB_VER%%
+lib/libkdeinit%%SHLIB_SHVER%%_dolphin.so
+%%QT_PLUGINDIR%%/dolphinpart.so
+%%QT_PLUGINDIR%%/kcm_dolphingeneral.so
+%%QT_PLUGINDIR%%/kcm_dolphinnavigation.so
+%%QT_PLUGINDIR%%/kcm_dolphinservices.so
+%%QT_PLUGINDIR%%/kcm_dolphinviewmodes.so
+share/applications/org.kde.dolphin.desktop
+share/config.kcfg/dolphin_compactmodesettings.kcfg
+share/config.kcfg/dolphin_detailsmodesettings.kcfg
+share/config.kcfg/dolphin_directoryviewpropertysettings.kcfg
+share/config.kcfg/dolphin_generalsettings.kcfg
+share/config.kcfg/dolphin_iconsmodesettings.kcfg
+share/config.kcfg/dolphin_versioncontrolsettings.kcfg
+share/dbus-1/interfaces/org.freedesktop.FileManager1.xml
+share/dbus-1/services/org.kde.dolphin.FileManager1.service
+share/kservices5/dolphinpart.desktop
+share/kservices5/kcmdolphingeneral.desktop
+share/kservices5/kcmdolphinnavigation.desktop
+share/kservices5/kcmdolphinservices.desktop
+share/kservices5/kcmdolphinviewmodes.desktop
+share/kservicetypes5/fileviewversioncontrolplugin.desktop
+share/locale/ar/LC_MESSAGES/dolphin.mo
+share/locale/ast/LC_MESSAGES/dolphin.mo
+share/locale/bg/LC_MESSAGES/dolphin.mo
+share/locale/bs/LC_MESSAGES/dolphin.mo
+share/locale/ca/LC_MESSAGES/dolphin.mo
+share/locale/ca@valencia/LC_MESSAGES/dolphin.mo
+share/locale/cs/LC_MESSAGES/dolphin.mo
+share/locale/da/LC_MESSAGES/dolphin.mo
+share/locale/de/LC_MESSAGES/dolphin.mo
+share/locale/el/LC_MESSAGES/dolphin.mo
+share/locale/en_GB/LC_MESSAGES/dolphin.mo
+share/locale/eo/LC_MESSAGES/dolphin.mo
+share/locale/es/LC_MESSAGES/dolphin.mo
+share/locale/et/LC_MESSAGES/dolphin.mo
+share/locale/eu/LC_MESSAGES/dolphin.mo
+share/locale/fa/LC_MESSAGES/dolphin.mo
+share/locale/fi/LC_MESSAGES/dolphin.mo
+share/locale/fi/LC_SCRIPTS/dolphin/dolphin.js
+share/locale/fr/LC_MESSAGES/dolphin.mo
+share/locale/ga/LC_MESSAGES/dolphin.mo
+share/locale/gl/LC_MESSAGES/dolphin.mo
+share/locale/he/LC_MESSAGES/dolphin.mo
+share/locale/hi/LC_MESSAGES/dolphin.mo
+share/locale/hr/LC_MESSAGES/dolphin.mo
+share/locale/hu/LC_MESSAGES/dolphin.mo
+share/locale/ia/LC_MESSAGES/dolphin.mo
+share/locale/id/LC_MESSAGES/dolphin.mo
+share/locale/is/LC_MESSAGES/dolphin.mo
+share/locale/it/LC_MESSAGES/dolphin.mo
+share/locale/ja/LC_MESSAGES/dolphin.mo
+share/locale/kk/LC_MESSAGES/dolphin.mo
+share/locale/km/LC_MESSAGES/dolphin.mo
+share/locale/ko/LC_MESSAGES/dolphin.mo
+share/locale/lt/LC_MESSAGES/dolphin.mo
+share/locale/lv/LC_MESSAGES/dolphin.mo
+share/locale/mr/LC_MESSAGES/dolphin.mo
+share/locale/nb/LC_MESSAGES/dolphin.mo
+share/locale/nds/LC_MESSAGES/dolphin.mo
+share/locale/nl/LC_MESSAGES/dolphin.mo
+share/locale/nn/LC_MESSAGES/dolphin.mo
+share/locale/pa/LC_MESSAGES/dolphin.mo
+share/locale/pl/LC_MESSAGES/dolphin.mo
+share/locale/pt/LC_MESSAGES/dolphin.mo
+share/locale/pt_BR/LC_MESSAGES/dolphin.mo
+share/locale/ro/LC_MESSAGES/dolphin.mo
+share/locale/ru/LC_MESSAGES/dolphin.mo
+share/locale/sk/LC_MESSAGES/dolphin.mo
+share/locale/sl/LC_MESSAGES/dolphin.mo
+share/locale/sr/LC_MESSAGES/dolphin.mo
+share/locale/sv/LC_MESSAGES/dolphin.mo
+share/locale/tr/LC_MESSAGES/dolphin.mo
+share/locale/ug/LC_MESSAGES/dolphin.mo
+share/locale/uk/LC_MESSAGES/dolphin.mo
+share/locale/wa/LC_MESSAGES/dolphin.mo
+share/locale/zh_CN/LC_MESSAGES/dolphin.mo
+share/locale/zh_TW/LC_MESSAGES/dolphin.mo
+share/metainfo/org.kde.dolphin.appdata.xml