aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/nemo
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-11-19 19:49:04 +0800
committerkwm <kwm@FreeBSD.org>2014-11-19 19:49:04 +0800
commitbe884cd42990f2e755c2c06bc38c8042cb8b0325 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /x11-fm/nemo
parent1c38992aaca771dc7aab7ae768e5753c6381ecd3 (diff)
downloadfreebsd-ports-gnome-be884cd42990f2e755c2c06bc38c8042cb8b0325.tar.gz
freebsd-ports-gnome-be884cd42990f2e755c2c06bc38c8042cb8b0325.tar.zst
freebsd-ports-gnome-be884cd42990f2e755c2c06bc38c8042cb8b0325.zip
The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.
Gnome 3.14.1 and Cinnamon 2.2.16 are supported on FreeBSD 9.3-RELEASE and up. This commit removes the old GNOME 2 desktop, bindings and some ports that can't be compiled. A few ports where updated to more recent versions to allow them to compile with this update. Apart from updating ports to newer versions GDM is more integrated with gnome-shell now, and handles several things for the GNOME desktop such as screen locking. If you want to use GNOME 3 via startx, you will have to add your own lock screen/screensaver. For example xscreensaver can be used for sessions started without GDM. Shell Extensions can be installed via https://extensions.gnome.org/ , we have ported a few that can't be installed via this way. The old gnome-utils and gnome-games ports where split up into single ports and where converted to meta-ports. gnome-terminal requires a UTF-8 locale to run, gdm handles this already, but if you use startx you need to do this yourself. Upgrade instructions: Delete the old and conflicting packages: # pkg delete clutter gnome-utils gnome-panel gnome-keyring vala-vapigen \ guile gcalctool gnome-media libgnomekbd # pkg delete gnome-screensaver gnome-applets bug-buddy evolution-exchange \ evolution-webcal gnome-system-tools seahorse-plugins gnome-control-center For package users the following lines will be enough: # pkg upgrade # pkg install gnome3 For ports users should do the following: # portmaster -a # portmaster x11/gnome3 We are currently aware of two issues. The first issue is a bug in the file monitoring code in the glib20 port. This bug causes glib programs to crash when files in a monitored directory are added or removed. Upstream is aware of the problem, but since the problem is quite complex there is no solution yet. This problem isn't restricted to BSD. The second issue is that on certain video cards totem will display a purple/pink overlay on the video. It not clear yet where the issues comes from. Major thanks goes to Gustau Perez for being a driving force behind getting GNOME 3 up to speed again. Also thanks to Antoine Brodin for running the exp-runs. This update was also made possible by: Joe Maloney Kris Moore Beeblebrox Ryan Lortie Antoine Jacoutot and everyone I missed
Diffstat (limited to 'x11-fm/nemo')
-rw-r--r--x11-fm/nemo/Makefile91
-rw-r--r--x11-fm/nemo/distinfo2
-rw-r--r--x11-fm/nemo/files/patch-autogen.sh10
-rw-r--r--x11-fm/nemo/files/patch-eel_eel-editable-label.c14
-rw-r--r--x11-fm/nemo/files/patch-libnemo-extensions_Makefile.am11
-rw-r--r--x11-fm/nemo/files/patch-libnemo-private_nemo-action.c27
-rw-r--r--x11-fm/nemo/files/patch-src_nemo-icon-view.c11
-rw-r--r--x11-fm/nemo/files/patch-src_nemo-list-view.c11
-rw-r--r--x11-fm/nemo/files/patch-src_nemo-notebook.c15
-rw-r--r--x11-fm/nemo/files/patch-src_nemo-view.c11
-rw-r--r--x11-fm/nemo/pkg-descr5
-rw-r--r--x11-fm/nemo/pkg-plist70
12 files changed, 278 insertions, 0 deletions
diff --git a/x11-fm/nemo/Makefile b/x11-fm/nemo/Makefile
new file mode 100644
index 000000000000..2d4e2e2c1ad0
--- /dev/null
+++ b/x11-fm/nemo/Makefile
@@ -0,0 +1,91 @@
+# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/x11-fm/nemo/Makefile 20008 2014-10-21 15:13:35Z gusi $
+
+PORTNAME= nemo
+PORTVERSION= 2.2.4
+CATEGORIES= x11-fm gnome
+MASTER_SITES= http://github.com/linuxmint/${PORTNAME}/archive/${PORTVERSION}.tar.gz?dummy=/
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= File manager for the Cinnamon desktop
+
+BUILD_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme \
+ gtkdocize:${PORTSDIR}/textproc/gtk-doc \
+ py*-polib>=0:${PORTSDIR}/devel/py-polib \
+ gnome-autogen.sh:${PORTSDIR}/devel/gnome-common \
+ gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
+LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif \
+ libcinnamon-desktop.so:${PORTSDIR}/x11/cinnamon-desktop \
+ libnotify.so:${PORTSDIR}/devel/libnotify \
+ libexempi.so:${PORTSDIR}/textproc/exempi
+RUN_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme \
+ gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
+
+USES= autoreconf:build desktop-file-utils gettext gmake libtool pathfix \
+ pkgconfig python:2 shared-mime-info
+USE_GNOME= gnomedesktop3 gnomeprefix intlhack introspection:build \
+ libxml2 pygobject3
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+USE_LDCONFIG= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+INSTALL_TARGET= install-strip
+CONFIGURE_ARGS= --enable-static --disable-packagekit
+
+GLIB_SCHEMAS= org.nemo.gschema.xml
+
+OPTIONS_SUB= yes
+OPTIONS_DEFINE= TRACKER
+OPTIONS_DEFAULT= TRACKER
+TRACKER_CONFIGURE_ENABLE= tracker
+TRACKER_LIB_DEPENDS= libtracker-sparql-1.0.so:${PORTSDIR}/sysutils/tracker
+TRACKER_DESC= Integration with tracker
+
+post-patch:
+ @${MKDIR} ${WRKSRC}/files${PREFIX}
+
+ @${MV} ${WRKSRC}/files/usr/share ${WRKSRC}/files${PREFIX}
+
+ @${REINPLACE_CMD} -e 's|0.16|1.0|g' \
+ ${WRKSRC}/configure.in
+
+ @${REINPLACE_CMD} -e 's|find|find ${WRKSRC}/files|g' \
+ ${WRKSRC}/files/Makefile.in
+
+ @${REINPLACE_CMD} -e 's|-DGTK_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/configure.in
+
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
+ ${WRKSRC}/src/nemo-properties-window.c
+
+ @${REINPLACE_CMD} -e 's|"-DG_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED"|""|g' \
+ ${WRKSRC}/configure.in
+
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g ;\
+ s|@INTROSPECTION_TYPELIBDIR@|$$(libdir)/girepository-1.0|g ;\
+ s|@INTROSPECTION_GIRDIR@|$$(datadir)/gir-1.0|g' \
+ ${WRKSRC}/libnemo-extension/Makefile.am
+
+ @${REINPLACE_CMD} -e 's|x-gnome-saved-search|x-nemo-saved-search|g' \
+ ${WRKSRC}/data/nemo.xml.in \
+ ${WRKSRC}/libnemo-private/nemo-file-utilities.h
+
+# @${REINPLACE_CMD} '/merge_action/d' \
+# ${WRKSRC}/files/Makefile.in
+
+ @${FIND} ${WRKSRC} -name \* | ${XARGS} ${EGREP} -l "#!.*\/usr\/bin\/python" | \
+ ${XARGS} ${REINPLACE_CMD} -I "" -e "s|#!.*python.*|#!${PYTHON_CMD}|g"
+
+ @${REINPLACE_CMD} 's|\"/usr|\"${PREFIX}|g' \
+ ${WRKSRC}/data/merge_action_strings
+
+ @${REINPLACE_CMD} 's|"files", "usr"|"files", "${PREFIX}".strip("/")|g' \
+ ${WRKSRC}/data/merge_action_strings
+
+pre-configure:
+ cd ${WRKSRC} && ${SETENV} NOCONFIGURE=yes ${SH} ./autogen.sh
+
+.include <bsd.port.mk>
diff --git a/x11-fm/nemo/distinfo b/x11-fm/nemo/distinfo
new file mode 100644
index 000000000000..327555d29ee3
--- /dev/null
+++ b/x11-fm/nemo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/nemo-2.2.4.tar.gz) = c05cccde1f84f8136a76c1a4b12054fb5ea38c1082747a6c32588c11ae0be72a
+SIZE (gnome3/nemo-2.2.4.tar.gz) = 1343344
diff --git a/x11-fm/nemo/files/patch-autogen.sh b/x11-fm/nemo/files/patch-autogen.sh
new file mode 100644
index 000000000000..245362b24ad7
--- /dev/null
+++ b/x11-fm/nemo/files/patch-autogen.sh
@@ -0,0 +1,10 @@
+--- autogen.sh.orig 2013-07-20 21:14:17.454775429 +0000
++++ autogen.sh 2013-07-20 21:14:26.096159846 +0000
+@@ -4,6 +4,7 @@
+ test -z "$srcdir" && srcdir=.
+
+ PKG_NAME="nemo"
++REQUIRED_AUTOMAKE_VERSION=1.14
+
+ which gnome-autogen.sh || {
+ echo "You need to install gnome-common from GNOME Git (or from"
diff --git a/x11-fm/nemo/files/patch-eel_eel-editable-label.c b/x11-fm/nemo/files/patch-eel_eel-editable-label.c
new file mode 100644
index 000000000000..4818520a49f8
--- /dev/null
+++ b/x11-fm/nemo/files/patch-eel_eel-editable-label.c
@@ -0,0 +1,14 @@
+--- eel/eel-editable-label.c.orig 2014-04-03 11:36:31.849369101 +0000
++++ eel/eel-editable-label.c 2014-04-03 11:37:01.819371871 +0000
+@@ -36,6 +36,11 @@
+ #include <gtk/gtk.h>
+ #include <gdk/gdkkeysyms.h>
+
++/* g_memmove is removed in glib 2.40 */
++#if GLIB_CHECK_VERSION (2, 39, 0)
++#define g_memmove memmove
++#endif
++
+ enum {
+ MOVE_CURSOR,
+ POPULATE_POPUP,
diff --git a/x11-fm/nemo/files/patch-libnemo-extensions_Makefile.am b/x11-fm/nemo/files/patch-libnemo-extensions_Makefile.am
new file mode 100644
index 000000000000..73a6761eb920
--- /dev/null
+++ b/x11-fm/nemo/files/patch-libnemo-extensions_Makefile.am
@@ -0,0 +1,11 @@
+--- libnemo-extension/Makefile.orig.am 2013-03-02 09:00:45.222570308 +0100
++++ libnemo-extension/Makefile.am 2013-03-02 09:02:01.279567955 +0100
+@@ -52,7 +52,7 @@
+ nemo-menu.c \
+ $(NULL)
+
+-pkgconfigdir=$(libdir)/pkgconfig
++pkgconfigdir=$(prefix)/libdata/pkgconfig
+ pkgconfig_DATA=libnemo-extension.pc
+
+ EXTRA_DIST = \
diff --git a/x11-fm/nemo/files/patch-libnemo-private_nemo-action.c b/x11-fm/nemo/files/patch-libnemo-private_nemo-action.c
new file mode 100644
index 000000000000..a1f883e03ed0
--- /dev/null
+++ b/x11-fm/nemo/files/patch-libnemo-private_nemo-action.c
@@ -0,0 +1,27 @@
+--- libnemo-private/nemo-action.c.orig 2013-11-25 10:51:16.047414327 +0000
++++ libnemo-private/nemo-action.c 2013-11-25 10:53:12.539547401 +0000
+@@ -1083,7 +1083,7 @@
+ const gchar *orig_label = nemo_action_get_orig_label (action);
+
+ if (orig_label == NULL)
+- return;
++ return NULL;
+
+ action->escape_underscores = TRUE;
+
+@@ -1106,7 +1106,7 @@
+ const gchar *orig_tt = nemo_action_get_orig_tt (action);
+
+ if (orig_tt == NULL)
+- return;
++ return NULL;
+
+ action->escape_underscores = FALSE;
+
+@@ -1350,4 +1350,4 @@
+ out:
+
+ return selection_type_show && extension_type_show && condition_type_show;
+-}
+\ No newline at end of file
++}
diff --git a/x11-fm/nemo/files/patch-src_nemo-icon-view.c b/x11-fm/nemo/files/patch-src_nemo-icon-view.c
new file mode 100644
index 000000000000..53f37fd24420
--- /dev/null
+++ b/x11-fm/nemo/files/patch-src_nemo-icon-view.c
@@ -0,0 +1,11 @@
+--- src/nemo-icon-view.orig.c 2013-03-02 09:06:43.664571510 +0100
++++ src/nemo-icon-view.c 2013-03-02 09:06:59.822567644 +0100
+@@ -1197,7 +1197,7 @@
+ static NemoZoomLevel
+ nemo_icon_view_get_default_zoom_level (NemoView *view)
+ {
+- g_return_if_fail (NEMO_IS_ICON_VIEW (view));
++ g_return_val_if_fail (NEMO_IS_ICON_VIEW (view), NEMO_ZOOM_LEVEL_STANDARD);
+
+ return get_default_zoom_level(NEMO_ICON_VIEW (view));
+ }
diff --git a/x11-fm/nemo/files/patch-src_nemo-list-view.c b/x11-fm/nemo/files/patch-src_nemo-list-view.c
new file mode 100644
index 000000000000..40fac57d5f12
--- /dev/null
+++ b/x11-fm/nemo/files/patch-src_nemo-list-view.c
@@ -0,0 +1,11 @@
+--- src/nemo-list-view.orig.c 2013-03-02 09:13:21.519569837 +0100
++++ src/nemo-list-view.c 2013-03-02 09:13:41.166572327 +0100
+@@ -2846,7 +2846,7 @@
+ static NemoZoomLevel
+ nemo_list_view_get_default_zoom_level (NemoView *view)
+ {
+- g_return_if_fail (NEMO_IS_LIST_VIEW (view));
++ g_return_val_if_fail (NEMO_IS_LIST_VIEW (view), NEMO_ZOOM_LEVEL_STANDARD);
+
+ return get_default_zoom_level();
+ }
diff --git a/x11-fm/nemo/files/patch-src_nemo-notebook.c b/x11-fm/nemo/files/patch-src_nemo-notebook.c
new file mode 100644
index 000000000000..ab2667b41416
--- /dev/null
+++ b/x11-fm/nemo/files/patch-src_nemo-notebook.c
@@ -0,0 +1,15 @@
+--- src/nemo-notebook.c.orig 2014-03-08 01:46:16.347348229 +0000
++++ src/nemo-notebook.c 2014-03-08 01:56:25.092307128 +0000
+@@ -51,12 +51,6 @@
+ static void nemo_notebook_remove (GtkContainer *container,
+ GtkWidget *tab_widget);
+
+-static const GtkTargetEntry url_drag_types[] =
+-{
+- { NEMO_ICON_DND_GNOME_ICON_LIST_TYPE, 0, NEMO_ICON_DND_GNOME_ICON_LIST },
+- { NEMO_ICON_DND_URI_LIST_TYPE, 0, NEMO_ICON_DND_URI_LIST },
+-};
+-
+ enum
+ {
+ TAB_CLOSE_REQUEST,
diff --git a/x11-fm/nemo/files/patch-src_nemo-view.c b/x11-fm/nemo/files/patch-src_nemo-view.c
new file mode 100644
index 000000000000..b50b32d24a44
--- /dev/null
+++ b/x11-fm/nemo/files/patch-src_nemo-view.c
@@ -0,0 +1,11 @@
+--- src/nemo-view.orig.c 2013-03-02 09:17:03.405569034 +0100
++++ src/nemo-view.c 2013-03-02 09:17:16.902582392 +0100
+@@ -680,7 +680,7 @@
+ NemoZoomLevel
+ nemo_view_get_default_zoom_level (NemoView *view)
+ {
+- g_return_if_fail (NEMO_IS_VIEW (view));
++ g_return_val_if_fail (NEMO_IS_VIEW (view), NEMO_ZOOM_LEVEL_STANDARD);
+
+ if (!nemo_view_supports_zooming (view)) {
+ return -1;
diff --git a/x11-fm/nemo/pkg-descr b/x11-fm/nemo/pkg-descr
new file mode 100644
index 000000000000..b4f3fd678e8f
--- /dev/null
+++ b/x11-fm/nemo/pkg-descr
@@ -0,0 +1,5 @@
+Nautilus is a file manager tightly integrated into the GNOME destkop.
+It is also responsible for desktop and icon management, and provides
+an intuitive interface for accessing files and webpages.
+
+WWW: http://www.gnome.org/projects/nautilus/
diff --git a/x11-fm/nemo/pkg-plist b/x11-fm/nemo/pkg-plist
new file mode 100644
index 000000000000..1c8c6f0a1dc9
--- /dev/null
+++ b/x11-fm/nemo/pkg-plist
@@ -0,0 +1,70 @@
+bin/nemo
+bin/nemo-autorun-software
+bin/nemo-connect-server
+include/nemo/libnemo-extension/nemo-column-provider.h
+include/nemo/libnemo-extension/nemo-column.h
+include/nemo/libnemo-extension/nemo-extension-types.h
+include/nemo/libnemo-extension/nemo-file-info.h
+include/nemo/libnemo-extension/nemo-info-provider.h
+include/nemo/libnemo-extension/nemo-location-widget-provider.h
+include/nemo/libnemo-extension/nemo-menu-item.h
+include/nemo/libnemo-extension/nemo-menu-provider.h
+include/nemo/libnemo-extension/nemo-menu.h
+include/nemo/libnemo-extension/nemo-property-page-provider.h
+include/nemo/libnemo-extension/nemo-property-page.h
+lib/girepository-1.0/Nemo-3.0.typelib
+lib/libnemo-extension.a
+lib/libnemo-extension.so
+lib/libnemo-extension.so.1.4.0
+libdata/pkgconfig/libnemo-extension.pc
+libexec/nemo-convert-metadata
+man/man1/nemo-connect-server.1.gz
+man/man1/nemo.1.gz
+share/applications/nemo-autorun-software.desktop
+share/applications/nemo-autostart.desktop
+share/applications/nemo.desktop
+share/dbus-1/services/org.Nemo.service
+share/dbus-1/services/org.freedesktop.NemoFileManager1.service
+share/gir-1.0/Nemo-3.0.gir
+share/gtksourceview-2.0/language-specs/nemo_action.lang
+share/gtksourceview-3.0/language-specs/nemo_action.lang
+share/icons/hicolor/16x16/actions/nemo-eject.png
+share/icons/hicolor/16x16/apps/nemo.png
+share/icons/hicolor/22x22/apps/nemo.png
+share/icons/hicolor/24x24/apps/nemo.png
+share/icons/hicolor/32x32/actions/nemo-eject.png
+share/icons/hicolor/32x32/apps/nemo.png
+share/icons/hicolor/scalable/actions/location-symbolic.svg
+share/icons/hicolor/scalable/actions/sidebar-hide-symbolic.svg
+share/icons/hicolor/scalable/actions/sidebar-places-symbolic.svg
+share/icons/hicolor/scalable/actions/sidebar-show-symbolic.svg
+share/icons/hicolor/scalable/actions/sidebar-tree-symbolic.svg
+share/icons/hicolor/scalable/actions/view-compact-symbolic.svg
+share/icons/hicolor/scalable/status/progress-0-symbolic.svg
+share/icons/hicolor/scalable/status/progress-10-symbolic.svg
+share/icons/hicolor/scalable/status/progress-100-symbolic.svg
+share/icons/hicolor/scalable/status/progress-20-symbolic.svg
+share/icons/hicolor/scalable/status/progress-30-symbolic.svg
+share/icons/hicolor/scalable/status/progress-40-symbolic.svg
+share/icons/hicolor/scalable/status/progress-50-symbolic.svg
+share/icons/hicolor/scalable/status/progress-60-symbolic.svg
+share/icons/hicolor/scalable/status/progress-70-symbolic.svg
+share/icons/hicolor/scalable/status/progress-80-symbolic.svg
+share/icons/hicolor/scalable/status/progress-90-symbolic.svg
+share/icons/hicolor/scalable/apps/nemo.svg
+share/mime/application/nemo-action.xml
+share/mime/application/x-nemo-saved-search.xml
+share/mime/packages/nemo.xml
+%%DATADIR%%/actions/add-desklets.nemo_action
+%%DATADIR%%/actions/change-background.nemo_action
+%%DATADIR%%/actions/mount-archive.nemo_action
+%%DATADIR%%/actions/myaction.py
+%%DATADIR%%/actions/new-launcher.nemo_action
+%%DATADIR%%/actions/sample.nemo_action
+%%DATADIR%%/actions/set-as-background.nemo_action
+%%DATADIR%%/icons/hicolor/16x16/emblems/emblem-note.png
+%%DATADIR%%/icons/hicolor/24x24/emblems/emblem-note.png
+%%DATADIR%%/icons/hicolor/48x48/emblems/emblem-note.png
+%%DATADIR%%/nemo-extras.placeholder
+%%DATADIR%%/nemo-suggested.placeholder
+share/polkit-1/actions/org.nemo.root.policy